Ergebnis 1 bis 4 von 4

Thema: Anzahl bestimmter Werte ermitteln in geschlossener Arbeitsmappe (Office 2013)

  1. #1
    Office-Hilfe.com - Neuling
    Registriert seit
    13.12.2015
    Beiträge
    3

    Anzahl bestimmter Werte ermitteln in geschlossener Arbeitsmappe

    Hallo,
    ich hoffe man kann mir hier helfen.
    Ich habe eine Masterarbeitsmappe in der ich diverse Werte aus vielen anderen aber geschlossenen Arbeitsmappen auslesen möchte.
    Dies kommt daher, da die anderen Arbeitsmappen auf verschiedensten Netzlaufwerken liegen, uns ich nicht alles in eine einzige Arbeitsmappe packen möchte.
    Nun habe ich aber ein Problem:

    In einer Arbeitsmappe (Beigefügte Beispielmappe „Mappe2.xls“) sind 2 Spalten mit Werten.
    Spalte A = SOLL-Wert
    Spalte B = IST-Wert

    In meiner Mastermappe („Mappe1“) möchte ich jetzt auf die geschlossene „Mappe2“ zugreifen und zählen in wieviel Spalten der SOLL-Wert überschritten wurde.
    Das Ergebnis soll mir dann in der „Mappe1“ in Zelle B2 ausgegeben werden.

    Ich habe es mit „zählenwenn“ probiert aber das funktioniert wohl nicht bei einer geschlossenen Mappe

    Übrigens zum testen habe ich beide Beispielmappen auf Laufwerk C in den Ordner Beispiel liegen.

    Wäre toll wenn mir hier jemand weiterhelfen könnte.

    Gruß
    Gerry
    Angehängte Dateien Angehängte Dateien

  2. #2
    Hola,

    nimm Summenprodukt.

    Gruß,
    steve1da

  3. #3
    Office-Hilfe.com - Neuling
    Registriert seit
    13.12.2015
    Beiträge
    3
    Zitat Zitat von steve1da Beitrag anzeigen
    Hola,

    nimm Summenprodukt.

    Gruß,
    steve1da
    Uih, da habe ich als Anfänger noch gar nichts mit zu tun gehabt.

    habe jetzt die Formel so in Zelle B2 in Mappe1 stehen, aber das geht gar nicht

    =SUMMENPRODUKT("c:\Beispiel\[Mappe2.xlsx]Tabelle1!"$B:$B>";"c:\Beispiel\[Mappe2.xlsx]Tabelle1!"[Mappe2.xlsx]Tabelle1!$A:$A)

  4. #4
    Office-Hilfe.com - Neuling
    Registriert seit
    13.12.2015
    Beiträge
    3
    Also wenn beide Mappen geöffnet sind habe ich es mit Summenprodukt so hinbekommen

    =SUMMENPRODUKT(([Mappe2.xlsx]Tabelle1!B1:B100>[Mappe2.xlsx]Tabelle1!A1:A100)*1)

    Aber wie setze ich jetzt den Bezug ein zu einer geschlossenen Mappe2 ?


    EDIT:
    Gelöst

    =SUMMENPRODUKT(('C:\Beispiel\[Mappe2.xlsx]Tabelle1'!B1:B100>'C:\Beispiel\[Mappe2.xlsx]Tabelle1'!A1:A100)*1)

    Danke für den Tipp mit SUMMENPRODUKT
    Geändert von gerryhome (09.07.2019 um 17:35 Uhr)

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Excel Ticker - News, Tipps und Tricks zu Microsoft Excel | SMS kostenlos versenden | Forenuser - Die Foren Findmaschine