Office: Automatische Ermittlung der Anrede mit WENN Funktion

Helfe beim Thema Automatische Ermittlung der Anrede mit WENN Funktion in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo zusammen, ich komme bei meiner Tabelle momentan nicht weiter und bin etwas am Verzweifeln. Meine Tabelle hat 3 Spalten: 1 - Anrede 2 -... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von Joey_Tribbiani, 6. April 2021.

  1. Automatische Ermittlung der Anrede mit WENN Funktion


    Hallo zusammen,

    ich komme bei meiner Tabelle momentan nicht weiter und bin etwas am Verzweifeln. Meine Tabelle hat 3 Spalten:

    1 - Anrede

    2 - Geschlecht

    3 - Sprache

    Jetzt soll bei Eingabe des Geschlechts (M/W) und der Sprache (Deutsche/Englisch) mithilfe der Formel in der Spalte Anrede entweder Herr, Frau, Mr. oder Mrs. stehen.

    Ich habe jetzt folgende Formel, aber die funktioniert leider nicht wie gewünscht:

    =WENN(UND([@geschlecht]="M";[@sprache]="Deutsch");"Herr";WENN(UND[@geschlecht]="M";[@sprache]="Englisch")"Mr";WENN(UND([@geschlecht]="F";[@sprache]="Deutsch");"Frau";WENN(UND[@geschlecht]="F";[@sprache]="Englisch")"Mrs.";))))

    Hat jemand Ahnung, was ich da falsch mache? Vielen Dank für Eure Hilfe!
     
    Joey_Tribbiani, 6. April 2021
    #1
  2. DL_
    DL_ User
    Moin

    Zunächst mal stehen in der Tabelle M und W aber du fragst M und F ab.
    Und die Formel kann man überhaupt nicht eintragen weil sie diverse Fehler enthält.
     
  3. ralf_b Neuer User
    sofern nur zwei Sprachen existieren reicht die Abfrage auf eine =WENN(Tabelle[@sprache]="deutsch";WENN(Tabelle[@geschlecht]="M";"Herr";"Frau");WENN(Tabelle[@geschlecht]="M";"MR";"Mrs"))
     
    ralf_b, 7. April 2021
    #3
  4. RPP63
    RPP63 Erfahrener User

    Automatische Ermittlung der Anrede mit WENN Funktion

    Wenn Du Dir eine kleine Verweis-Tabelle erstellst, ist es nur noch eine winzige Formel:
    =VERWEIS(B2&C2;$E$2:$F$5)
    Automatische Ermittlung der Anrede mit WENN Funktion rwzAuxf.png

    Hat den großen Vorteil, dass beliebig viele Sprachen ergänzt werden können, ohne eine Monsterformel zu brauchen.
    Wichtig ist nur, dass Spalte E sortiert sein muss.
    Ansonsten müsste man den SVERWEIS() bemühen.
     
    Zuletzt bearbeitet: 7. April 2021
    RPP63, 7. April 2021
    #4
Thema:

Automatische Ermittlung der Anrede mit WENN Funktion

Die Seite wird geladen...
  1. Automatische Ermittlung der Anrede mit WENN Funktion - Similar Threads - Automatische Ermittlung Anrede

  2. Outlook-Termin mit automatischen Terminblocker

    in Microsoft Outlook Hilfe
    Outlook-Termin mit automatischen Terminblocker: Hallo zusammen, ich habe ein Problem zu lösen, bei dem ich der Suche im Internet bisher keine Idee, oder Lösung fand. Deshalb wende ich mich jetzt an euch. Es geht um folgendes: System: Exchange...
  3. Zeitüberschneidungen verschiedener Tage automatisch erkennen

    in Microsoft Excel Hilfe
    Zeitüberschneidungen verschiedener Tage automatisch erkennen: Hallo ihr Lieben, meine Mutter trägt ihre Arbeitszeiten regelmäßig händisch in eine Excel-Tabelle ein. Dabei steht in Spalte A das Datum, in Spalte B die Anfangszeit des Arbeitspakets und in...
  4. automatische Aktivierung einer Checkbox funktioniert

    in Microsoft Excel Hilfe
    automatische Aktivierung einer Checkbox funktioniert: Hallo zusammen, ich habe folgendes Problem, hoffe eine Lösung. Ich habe leider keine Idee, warum der Fehler nur bei zwei Zeilen auftritt. In einem Arbeitsblatt (eine "intelligente" Checkliste)...
  5. Automatische Spesenberechnung in Excel

    in Microsoft Excel Hilfe
    Automatische Spesenberechnung in Excel: Hallo und Grüß Gott, ich sitze nun schon seit mehreren Tagen an einem Problem und finde einfach keine Lösung. Vielleicht gibt es ja hier den einen oder anderen der sich mit diesen Formeln...
  6. Automatische Kopieren von Kalendereinträgen in einen Gruppenkalender

    in Microsoft Outlook Hilfe
    Automatische Kopieren von Kalendereinträgen in einen Gruppenkalender: Hallo zusammen, ich besitze 2 Kalender, einen Exchange Kalender und einen Gruppenkalender. Jetzt möchte ich vom Exchange Kalender die Einträge in einen Sharepoint Gruppenkalender automatisch...
  7. .xlsm - Formeln werden nicht berechnet

    in Microsoft Excel Hilfe
    .xlsm - Formeln werden nicht berechnet: Hallo zusammen, ich habe eine Arbeitsmappe mit einem kleinen Makro und ein paar "normalen" Berechnungen. Eine davon [...
  8. Spalten automatisch Verbinden und anpassen.

    in Microsoft Excel Hilfe
    Spalten automatisch Verbinden und anpassen.: Hallo, ich bin für meine Arbeit für unsere Excel Tabellen verantwortlich und stehe dort nun vor einem Problem, welches ich auch mit einiger Internet Recherche nicht lösen kann: Wir nutzen die...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden