Office: Automatische Erweiterung Wochen // Stunden auf Wochen aufteilen

Helfe beim Thema Automatische Erweiterung Wochen // Stunden auf Wochen aufteilen in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo ihr Lieben, ich habe folgende Aufgabe: Ich habe eine Stundenzahl für Aufgaben, ein Startdatum und ein Enddatum, aus dem die Anzahl der Wochen... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von dvda2002, 28. August 2023.

  1. dvda2002 Neuer User

    Automatische Erweiterung Wochen // Stunden auf Wochen aufteilen


    Hallo ihr Lieben,

    ich habe folgende Aufgabe:

    Ich habe eine Stundenzahl für Aufgaben, ein Startdatum und ein Enddatum, aus dem die Anzahl der Wochen gekürzt zu errechnen und die Stunden auf die Anzahl der Wochen zu verteilen ist.

    Die Tabelle soll nun um die Anzahl der Wochen mit jeweiligem Startdatum der Wochen automatisch erweitert und der aufgeteilte Stundenwert eingetragen werden.

    Die Einzelschritte sind weniger das Problem. Ich bekomme es nur nicht im Ganzen automatisiert hin.

    Hört sich irgendwie nicht schwierig an, aber komme damit an meine Grenzen…
     
    dvda2002, 28. August 2023
    #1
  2. steve1da Office Guru
    Hola,
    warum ist der 26.09.2023 nicht mehr aufgeführt? Der ist doch in der KW des Enddatums?
    Gruß,
    steve1da
     
    steve1da, 28. August 2023
    #2
  3. neopa C hat Ahnung
    Hallo,

    wenn Deine Datenwertvorgaben in A2:B2 und E2 stehen, dann folgende Formeln:
    In A3: =WENN((A2="")+(VERWEIS(9^9;A$2:A2)+7>B$2);"";A2+7)
    In C2: =WENN(A2="";"";KALENDERWOCHE(A2;21))
    in E3: =WENN(A3="";"";$E$2/(ANZAHL(A:A)-1))

    Und die Formeln nach unten kopieren.
     
    neopa C, 28. August 2023
    #3
  4. dvda2002 Neuer User

    Automatische Erweiterung Wochen // Stunden auf Wochen aufteilen

    Hallo Steve, ich habe den falschen Screenshot eingefügt... Sorry...
     
    dvda2002, 28. August 2023
    #4
  5. neopa C hat Ahnung
    Hallo dvda2002,

    da Du anstelle einer Exceldatei nur ein Bildchen eingestellt hast aus der zudem nicht ersichtlich ist, wo Deine Daten stehen, habe ich dafür die Annahmen getroffen, die ich obenstehend aufgeführt habe. Meine Formeln ermitteln dafür das von Dir angestrebte.
     
    neopa C, 28. August 2023
    #5
    1 Person gefällt das.
  6. dvda2002 Neuer User
    Klasse... Danke für die schnelle Lösung. Das funktioniert super!
    Ich bin total begeistert.
    Automatische Erweiterung Wochen // Stunden auf Wochen aufteilen *:)*
    Nun ergibt sich für mich daraus allerdings das nächste Problem.
    Wie setze ich es jetzt um, wenn ich weitere Aufgaben der Tabelle hinzufügen möchte?
     
    dvda2002, 28. August 2023
    #6
  7. dvda2002 Neuer User
    Hallo Werner, das hat super gepasst und war total klasse zu verstehen. Ich danke dir dafür. Viele Grüße - Olaf
     
    dvda2002, 28. August 2023
    #7
  8. dvda2002 Neuer User

    Automatische Erweiterung Wochen // Stunden auf Wochen aufteilen

    Wie lässt sich die Tabelle am besten mit weiteren Aufgaben erweitern, ohne die erste Aufgabenberechnung durcheinander zu würfeln? Es kommt eine neue Aufgabe mit einem anderen Start-, Enddatum und einer anderen Stundenzahl hinzu und soll unter dem letzten Eintrag neu ansetzen. Funktioniert es vielleicht nur per Makro?
     
    dvda2002, 29. August 2023
    #8
  9. neopa C hat Ahnung
    Hallo dvda2002,

    warum stellst Du immer nur ein Bildchen ein? Deine XLSx-Datei anstelle dessen wäre hilfreich(er).

    Gruß Werner
    .. , - ...
     
    neopa C, 29. August 2023
    #9
  10. dvda2002 Neuer User
    Hallo Werner, anbei die Datei. Der zweite Block ist ohne Formel. Viele Grüße, Olaf
     
    dvda2002, 29. August 2023
    #10
  11. neopa C hat Ahnung
    Hallo Olaf,

    ist realisierbar, aber so nicht wirklich empfehlenswert, da zumindest die Formel in Spalte G sehr lang wird und vor allem eine nachträgliche Änderung der "Enddatums"-Werte sich verbietet, wenn diese später liegen sollen.

    In C3: =WENN((C2="")+(VERWEIS(9^9;C$2:C2)+7>VERWEIS(9^9;D$2:D3));"";C2+7)
    und Formeln nach unten kopieren.
    In G2: =WENN((F2>0)+(C2="");"";$F$2/(ANZAHL(INDEX(C:C;VERWEIS(9;1/(D1:D$2<>"");ZEILE(C1:C$2))):INDEX(C:C;VERWEIS(9;1/(D1:D$2<>"");ZEILE(C1:C$2))+VERWEIS(9^9;E1:E$2)))-1))
    und Formel durchgehend nach unten kopieren.
    Formel H2 bleibt, mußt Du nur nach unten kopieren.
     
    neopa C, 29. August 2023
    #11
Thema:

Automatische Erweiterung Wochen // Stunden auf Wochen aufteilen

Die Seite wird geladen...
  1. Automatische Erweiterung Wochen // Stunden auf Wochen aufteilen - Similar Threads - Automatische Erweiterung Wochen

  2. Bilder und Absatzmarke automatisch einfügen

    in Microsoft Word Hilfe
    Bilder und Absatzmarke automatisch einfügen: Hallo, wenn ich in Word mehrere Bilder über „Grafik einfügen“ markiere, werden die hintereinander eingefügt, siehe erste Spalte im beigefügten Bild. Für die nachträgliche Bearbeitung wäre es...
  3. Automatische Formatierung des Firmennamens

    in Microsoft PowerPoint Hilfe
    Automatische Formatierung des Firmennamens: Hallo liebes Forum! Kann man im PPT Einstellungen vornehmen (Regel erstellen), damit zb. der Firmenname im Text immer Versal geschrieben wird. Also statt zB. "Die Firma Mustermax stellt ..."...
  4. automatische Formelanpassung

    in Microsoft Excel Hilfe
    automatische Formelanpassung: Hallo Excel Spezialisten Bin dankbar für eure Hilfe zu folgender Situation: In einem Arbeitsblatt mit Spalte A, beginnend mit A4, habe ich in Spalte C einen Produktionswert auch ab C4. Der Wert...
  5. Tabelle automatisch mit Formeln erweitern

    in Microsoft Excel Hilfe
    Tabelle automatisch mit Formeln erweitern: Hallo zusammen, ich habe folgende Tabelle [ATTACH] Wenn ich in A2 etwas einge, kommen in A3 und A4 automatisch Werte (via SVERWEIS). Ich muss danach Zelle A4 anklicken und dann TAB drücken,...
  6. Automatische Erweiterung einer Tabelle für Drop-Down (Excel 2013)

    in Microsoft Excel Hilfe
    Automatische Erweiterung einer Tabelle für Drop-Down (Excel 2013): Hallo @ll, ich bin neu in diesem Forum hier angemeldet, habe aber schon sehr oft bei euch super Tipps bekommen. Jetzt habe ich leider ein Problem, dass ich bei euch noch nicht gefunden habe. Ich...
  7. Automatische Erweiterung der Zeile

    in Microsoft Excel Hilfe
    Automatische Erweiterung der Zeile: Hallo liebe Freunde des besten Rechentools der Welt, ich hätte da wieder einmal eine Idee. Allerdings liegt die Problematik darin, dass ich die Lösung zurzeit meilenweit von mir entfernt sehe....
  8. automatisch an Spaltenende erweiterung anfügen

    in Microsoft Excel Hilfe
    automatisch an Spaltenende erweiterung anfügen: Hallo ihr habe folgendes Problem: Ich habe ein paar hundert Artikelnummern die in einer Excel Tabelle stehen. Diese Tabelle wird für einen Online shop verwendet und da muss jetzt vor die...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden