Office: (Office 2000) Automatische Zimmerbelegung

Helfe beim Thema Automatische Zimmerbelegung in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo alle zusammen, erneut trete ich mit einem Problem an euch. Beispieldatei habe ich dieses Mal an den Beitrag gehängt. (edit: ZIP Datei, da... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von AlwaysWithYou, 22. Februar 2016.

  1. AlwaysWithYou Erfahrener User

    Automatische Zimmerbelegung


    Hallo alle zusammen,

    erneut trete ich mit einem Problem an euch.

    Beispieldatei habe ich dieses Mal an den Beitrag gehängt. (edit: ZIP Datei, da Excel Datei über max. Größe)

    Den Anhang Dateien.zip betrachten

    Ich möchte ganz gerne mir die Zimmerbelegung für eine Jugendherrberge einfacher machen.

    Und zwar, wenn ich meinem Beispielpatienten Max Mustermann das Zimmer 14 zuweise.

    Dann soll Excel bitte in Zimmer 14 (dort wo 6 (Anzahl Betten) und 0 (Anzahl der dort wohnenden Personen)) bei der 0 ein +1 einfügen, damit ich immer aktuell weiß, wie viele Leute in dem Zimmer sind, ohne das per Hand eintragen zu müssen.

    Das müsste ja theoretisch mit einer WENN Funktion möglich sein. Nur wie?

    Liebe Grüße,
    AlwaysWithYou
     
    Zuletzt bearbeitet: 24. Februar 2016
    AlwaysWithYou, 22. Februar 2016
    #1
  2. steve1da Super-Moderator
    Hola,

    Code:
    =ZÄHLENWENN(Gesamtbelegung!G3:G153;Q9)
    Gruß,
    steve1da
     
    steve1da, 22. Februar 2016
    #2
  3. AlwaysWithYou Erfahrener User
    Inwiefern muss ich denn den Code ändern, wenn ich es für die anderen Zimmer auch so machen will? :)
     
    AlwaysWithYou, 22. Februar 2016
    #3
  4. steve1da Super-Moderator

    Automatische Zimmerbelegung

    Hola,

    Q9 durch die jeweilige Zelle ersetzen.
    Edit: einmal die Formel
    Code:
    =ZÄHLENWENN(Gesamtbelegung!$G$3:$G$153;Q9)
    in R8 schreiben. Dann diese kopieren und in jede braune Zelle einfügen. Die Bezüge passen sich automatisch an.

    Gruß,
    steve1da
     
    Zuletzt bearbeitet: 22. Februar 2016
    steve1da, 22. Februar 2016
    #4
  5. AlwaysWithYou Erfahrener User
    Vielen Lieben Dank! Das funktioniert und hat super geholfen.

    Nun möchte ich Excel noch etwas beibringen. Beispieldatei im Beitrag ändere ich sofort demnach.

    Jeder Jugendliche bekommt von mir eine sogenannte Identifikationsnummer.

    Und ich will wissen, welche Nummern in welchem Raum liegen.

    Kann ich Excel irgendwie beibringen, dass..

    - wenn ich eine 2 bei Raum eingebe (in Gesamtbelegung), er die Identifikationsnummer in das andere Tabellenblatt (Zimmerverteilung) in Raum 2 reinschreibt
    - dass Excel weiß, wenn bereits eine Spalte belegt ist, dass er die nächste nehmen muss

    Geht das irgendwie? Das ist ein bisschen zu hoch für mich, würde mir meine Arbeit aber einfach ungemein erleichtern, da ich dass sonst immer per Hand aktualisieren muss.

    Liebe Grüße,
    AlwaysWithYou
     
    AlwaysWithYou, 22. Februar 2016
    #5
  6. steve1da Super-Moderator
    Hola,

    das ist etwas komplizierter, aber nicht unmöglich :)

    In B1 folgende Matrixformel (mit Strg-Shift-Enter abschließen!):

    Code:
    =WENN(ISTFEHLER(INDEX(Gesamtbelegung!$A$3:$A$153;KKLEINSTE(WENN(Gesamtbelegung!$H$3:$H$153=RECHTS($A$1;1)*1;ZEILE($3:$153)-2);ZEILE(A1))));"";INDEX(Gesamtbelegung!$A$3:$A$153;KKLEINSTE(WENN(Gesamtbelegung!$H$3:$H$153=RECHTS($A$1;1)*1;ZEILE($3:$153)-2);ZEILE(A1))))
    In B8:

    Code:
    =WENN(ISTFEHLER(INDEX(Gesamtbelegung!$A$3:$A$153;KKLEINSTE(WENN(Gesamtbelegung!$H$3:$H$153=RECHTS($A$8;1)*1;ZEILE($3:$153)-2);ZEILE(A1))));"";INDEX(Gesamtbelegung!$A$3:$A$153;KKLEINSTE(WENN(Gesamtbelegung!$H$3:$H$153=RECHTS($A$8;1)*1;ZEILE($3:$153)-2);ZEILE(A1))))
    In B15:
    Code:
    =WENN(ISTFEHLER(INDEX(Gesamtbelegung!$A$3:$A$153;KKLEINSTE(WENN(Gesamtbelegung!$H$3:$H$153=RECHTS($A$15;1)*1;ZEILE($3:$153)-2);ZEILE(A1))));"";INDEX(Gesamtbelegung!$A$3:$A$153;KKLEINSTE(WENN(Gesamtbelegung!$H$3:$H$153=RECHTS($A$15;1)*1;ZEILE($3:$153)-2);ZEILE(A1))))
    Wenn du Raum 1, Raum 2.... in jede Zelle in Spalte A schreibst, geht es mit nur einer Formel:

    Code:
    =WENN(ISTFEHLER(INDEX(Gesamtbelegung!$A$3:$A$153;KKLEINSTE(WENN(Gesamtbelegung!$H$3:$H$153=RECHTS(A1;1)*1;ZEILE($3:$153)-2);ZÄHLENWENN($A$1:A1;A1))));"";INDEX(Gesamtbelegung!$A$3:$A$153;KKLEINSTE(WENN(Gesamtbelegung!$H$3:$H$153=RECHTS(A1;1)*1;ZEILE($3:$153)-2);ZÄHLENWENN($A$1:A1;A1))))
    Gruß,
    steve1da
     
    steve1da, 22. Februar 2016
    #6
  7. AlwaysWithYou Erfahrener User
    Also jetzt bin ich offziell überfordert.

    Ich habe jetzt die Datei noch einmal verändert im Originalbeitrag. Auch noch leere Zeilen hinzugefügt, damit ich auch später den Code so verwenden kann, wie es in der Datei mit bereits eingetragenen Daten auch ist.

    Genauso habe ich den Plan einmal eingefügt, wie er am Ende wirklich aussehen soll :)

    Wenn du von eintragen in B15 etc. redest, ist dann die Tabelle Gesamtbelegung oder die Tabelle Zimmerverteilung gemeint?

    Vielen Lieben Dank, dass du dir so viel Mühe machst :)
     
    AlwaysWithYou, 22. Februar 2016
    #7
  8. steve1da Super-Moderator

    Automatische Zimmerbelegung

    Hola,

    die Formeln kommen immer dahin, wo du die Ergebnisse erwartest.


    Ich schau es mir morgen früh an.


    Gruß,
    steve1da
     
    steve1da, 22. Februar 2016
    #8
  9. AlwaysWithYou Erfahrener User
    Vielen Lieben Dank, das ist super von dir.

    Grüße,
    AlwaysWithYou
     
    AlwaysWithYou, 22. Februar 2016
    #9
  10. steve1da Super-Moderator
    Hola,

    auch mit der veränderten Datei ändert sich nichts an meinem Beitrag.
    Schreib die Raumnummern in jede Zelle! Also von A1 bis A7 steht immer Raum 1 in den Zellen, danach immer Raum 2 usw.

    Dann in B1:

    Code:
    =WENN(ISTFEHLER(INDEX(Gesamtbelegung!$A$3:$A$153;KKLEINSTE(WENN(Gesamtbelegung!$H$3:$H$153=RECHTS(A2;1)*1;ZEILE($3:$153)-2);ZÄHLENWENN($A$1:A1;A1))));"";INDEX(Gesamtbelegung!$A$3:$A$153;KKLEINSTE(WENN(Gesamtbelegung!$H$3:$H$153=RECHTS(A2;1)*1;ZEILE($3:$153)-2);ZÄHLENWENN($A$1:A1;A1))))
    Diese Formel mit Strg-Shift-Enter abschließen und anschließend nach unten kopieren. Danach die Formel in D1 kopieren und nach unten ziehen, danach in F1 usw.

    Gruß,
    steve1da
     
    steve1da, 23. Februar 2016
    #10
  11. AlwaysWithYou Erfahrener User
    Vielen Dank für deine Mühe, aber leider funktioniert die Formel nicht, so wie sie soll :)

    Aber ist nicht schlimm, dann lassen wir das einfach :D

    Liebe Grüße,
    AlwaysWithYou
     
    AlwaysWithYou, 23. Februar 2016
    #11
  12. steve1da Super-Moderator
    Hola,

    also bei mir funktioniert es.

    Zeig doch mal ein Beispiel mit meiner Formel.

    Gruß,
    steve1da
     
    steve1da, 23. Februar 2016
    #12
  13. AlwaysWithYou Erfahrener User

    Automatische Zimmerbelegung

    Also habe die Datei mal aktualisiert.

    Bitte nicht wundern, ich habe die Schrift weiß gemacht, bei den überflüssigen RAUM 1, RAUM 2, etc. weil mich das wahnsinnig gemacht hat :D

    Habe deinen Code jetzt mal in alle Zimmer bis 18 eingefügt. Also oben reinkopiert und dann runtergezogen.

    Mal sehen, ob du den Fehler findest, ich finde ihn nicht :D Aber hey, ich kann auch kein Excel.

    Liebe Grüße,
    AlwaysWithYou
     
    AlwaysWithYou, 23. Februar 2016
    #13
  14. steve1da Super-Moderator
    Hola,

    das liegt daran, das du nicht umgesetzt hast, was ich geschrieben habe.

    Die Raumnummer im Blatt Zimmerverteilung muss in JEDE Zelle, also Raum 1 von A1 bis A7, Raum 2 von A8 bis A14......

    Dann ist die Raumnummer im Blatt Gastbelegung auf einmal nicht mehr in Spalte H, sondern in J. Das muss natürlich auch angepasst werden in der Formel!

    Code:
    =WENN(ISTFEHLER(INDEX(Gesamtbelegung!$A$3:$A$153;KKLEINSTE(WENN(Gesamtbelegung!$J$3:$J$153=RECHTS(A2;1)*1;ZEILE($3:$153)-2);ZÄHLENWENN($A$1:A1;A1))));"";INDEX(Gesamtbelegung!$A$3:$A$153;KKLEINSTE(WENN(Gesamtbelegung!$J$3:$J$153=RECHTS(A2;1)*1;ZEILE($3:$153)-2);ZÄHLENWENN($A$1:A1;A1))))
    Dann sollst du nicht die Formel in B1, D1, F1....zu gleich einfügen, sondern die Formel in B1 einfügen, mit Strg-Shift-Enter abschließen, dann wieder in B1 gehen, Strg-C drücken und dann in D1 Strg-V drücken. Somit passt sich das A1 in der Formel automatisch in C1, E1....an.

    Sorry, aber manchmal frag ich mich, warum ich soviel schreibe, wenn es ja doch nicht gelesen wird.

    Gruß,
    steve1da
     
    steve1da, 23. Februar 2016
    #14
  15. AlwaysWithYou Erfahrener User
    WOW, VIELEN DANK!

    Jetzt hat es funktioniert.

    Aber einmal muss ich noch nerven. Nun wenn ich RAUM 7, ID 8,9,10,11 habe beispielsweise. Sind diese auch gemeldet in den anderen Räumen, die mit 7 sind. Also finde ich die gleichen auch nochmal in RAUM 17, RAUM 27, RAUM 37 und RAUM 47.

    Wie kann ich das verhindern? :D

    edit: Und er vergibt auch teilweise ID Nummern in die Räume, wo ich in der Gesamtbelegung gar keine Räume eingetragen habe.

    Beispieldatei funktioniert leider nicht mehr, da sie mit den Formeln leider zu groß ist Automatische Zimmerbelegung :(
     
    AlwaysWithYou, 23. Februar 2016
    #15
Thema:

Automatische Zimmerbelegung

Die Seite wird geladen...
  1. Automatische Zimmerbelegung - Similar Threads - Automatische Zimmerbelegung

  2. email automatisch verschiken Von einer WENN Unktion

    in Microsoft Excel Hilfe
    email automatisch verschiken Von einer WENN Unktion: Hallo ich kenne mich was VBA angeht nicht aus! Ich habe das Logo Access toll das von einer Logo Steuerung Werte Abgreift! In der Spalte V Wenn Funktionen die mir Bei bestimten werten dan...
  3. Tabelle automatisch mit Daten aus der Tabelle erstellen

    in Microsoft Excel Hilfe
    Tabelle automatisch mit Daten aus der Tabelle erstellen: Hallo an euch Excel-Profis, ich benötige folgende Hilfe. Ich erstelle gerade eine Exceldatei mit 38 Tabellen in denen drei Spalten mit personenbezogenen Daten eingetragen werden...
  4. VBA: Datum automatisch hinzufügen nach Übertrag

    in Microsoft Excel Hilfe
    VBA: Datum automatisch hinzufügen nach Übertrag: Hallo zusammen, ich habe ein Makro gebaut, welches die Daten aus dem Tabellenblatt Bestellformular kopiert und diese in ein anderes Tabellenblatt (Bestellhistorie) überträgt, wobei zusätzlich in...
  5. Automatisch Syncro. von 2Konten

    in Microsoft Outlook Hilfe
    Automatisch Syncro. von 2Konten: Moin ich habe eine frage und zwar nutze ich office Professional Plus 2021 ich manage dort 2 email Konten (beide Posteingänge sind unter Favoriten gespeichert) nur wird das email Konto was...
  6. Wort aus Tab2 in Tab1 automatisch einfügen

    in Microsoft Excel Hilfe
    Wort aus Tab2 in Tab1 automatisch einfügen: Hallo liebe Excel-Profis, ich bin mir eine Excel am basteln, die in meinem Kopf funktioniert aber in Excel an der Umsetzung hapert Folgendes möchte ich gerne umsetzen: Auf dem Tab1 möchte ich...
  7. Arbeitsmappe automatisch speichern und schließen nach Zeit x

    in Microsoft Excel Hilfe
    Arbeitsmappe automatisch speichern und schließen nach Zeit x: Guten Tag, Ich habe folgendes Problem: Ich führe eine Excel Liste, auf die verschiedene Büros Zugriff haben und diese bearbeiten. Nun brauche ein ein Makro, bei dem die Liste nach einer Zeit x...
  8. Bildgröße automatisch bei Powerpoint

    in Microsoft PowerPoint Hilfe
    Bildgröße automatisch bei Powerpoint: Hallo, ich konnte vor ca. ein, zwei Jahren Bilder auf eine Powerpointfolie ziehen und sie haben sich automatisch zentriert und maximal in der Bildhöhe ausgerichtet. Jetzt geht es nicht mehr. Was...
Schlagworte:
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden