Office: Bedingte Formatierung: Farbe, Bedingung: ODER

Helfe beim Thema Bedingte Formatierung: Farbe, Bedingung: ODER in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo, Aufgabenstellung: 365 Anzeigenmotive sollen über das Jahr hinweg geschaltet werden, ein Motiv pro Tag, keines doppelt. Ich habe also 12... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von juergenryzek, 8. März 2013.

  1. Bedingte Formatierung: Farbe, Bedingung: ODER


    Hallo,

    Aufgabenstellung:

    365 Anzeigenmotive sollen über das Jahr hinweg geschaltet werden, ein Motiv pro Tag, keines doppelt. Ich habe also 12 Tabellen erstellt (365 Tage auf einmal schafft mein EXCEL 2003 nicht). Jetzt möchte ich farblich erkennen, welches Motiv bereits "durch" ist. Eine Zelle am Anfang der Zeile soll also auf farbig schalten, sobald in einem von 31 Tagen im Monat eine Markierung, z. B. "x" eingetragen wird.

    Wenn das funktioniert, soll in jedem Monat - möglichst ebenfalls farbig - erkennbar sein, ob das Motiv in den übrigen Monaten bereits verplant ist. Bedingte Formatierung über Registerblätter hinweg geht nicht, also bräuchte ich eine andere Lösung.

    Ich krieg´s nicht hin. Kann jemand helfen? Danke!
    Jürgen
     
    juergenryzek, 8. März 2013
    #1
  2. schatzi Super-Moderator
    Hallo!

    Für ein einzelnes Tabellenblatt ist das schnell gemacht mit =ZÄHLENWENN(DeinBereich;"x")>0

    Für mehrere Blätter könntest du zunächst mit einer Formel von hier zählen:
    http://excelformeln.de/formeln.html?welcher=235 (siehe dort auch den Link zu Nr. 234)

    Aus das Formelergebnis wendest du dann die Bedingte Formatierung an.
     
    schatzi, 8. März 2013
    #2
  3. Danke, Schatzi. Wenn man anfangs wüsste, wie einfach es ist. :-) Den ersten Teil Deiner Antwort habe ich sofort umgesetzt.

    In den zweiten Teil werde ich mich jetzt vertiefen.

    Gruß, Jürgen
     
    juergenryzek, 8. März 2013
    #3
  4. Bedingte Formatierung: Farbe, Bedingung: ODER

    Hallo,

    meine Blattnamen lauten "01", "02" bis "12". Ich brauche die Summe aller Zahlen >0 in Zelle D6 der Blätter "01", "02" bis "12".

    Die Formel, die ich aus den Hinweisen gemacht habe, funktioniert (für die ersten drei Blätter) nicht: {=SUMME(SUMMEWENN(INDIREKT("'"&{"01"."02"."03"}&"!D6");">0"))}

    Wo hakt es?

    Jürgen
     
    juergenryzek, 8. März 2013
    #4
  5. E-MaX-I Erfahrener User
    Hi,

    ich bin mir nicht sicher ob es diese Formel von dir auch betrifft, aber muss man geschweifte Klammer nicht mit 'Strg+Enter' bestätigen bei der Eingabe, nicht mit einem einfachen 'Enter'

    Jetzt weiß ich woher das mit dem 'gefährlichem Halbwissen' kommt. ;-)

    Gruß
    Emi
     
    E-MaX-I, 8. März 2013
    #5
  6. Hallo,

    tja, das Halbwissen. :-) Die geschweifte Klammer hatte ich als eine Schreibkonvention verstanden, wenn man eine Formel mitteilt. Ist wohl nicht so? In meinem Excel-Blatt steht allerdings die Formel ohne geschweifte Klammer.

    Gruß, Jürgen
     
    juergenryzek, 8. März 2013
    #6
  7. Michael
    Michael Administrator
    Wenn sie ohne drin steht gehst Du auf die Zelle klickst in die Formel und bestätigst die Eingabe mit Strg+Shift+Enter. Damit erzeugst Du die geschweiften Klammern.

    VG
    Michael
     
    Michael, 8. März 2013
    #7
  8. Bedingte Formatierung: Farbe, Bedingung: ODER

    In einem Beispiel des Links http://excelformeln.de/formeln.html?welcher=234 steht die Formel so:

    =SUMME(SUMMEWENN(INDIREKT("'"&{"JensF"."WF"."Boris"}&"'!A:A");">100")).

    Die Namen im Array habe ich geändert, und anstelle der Spalte A habe ich die Zelle D6 eingefügt:

    =SUMME(SUMMEWENN(INDIREKT("'"&{"01"."02"."03"}&"!D6");">0"))

    Das ist aber offensichtlich nicht korrekt, denn es funktioniert nicht.

    Gruß, Jürgen
     
    juergenryzek, 8. März 2013
    #8
  9. silex1
    silex1 Super-Moderator
    Hallo,

    Da Du das 10.000-te Thema hier im Excelboard eröffnet hast, gibt es zur Feier des Tages noch ein Geschenk:

    Den Hinweis auf die Start:Stop-Methode. Diese würde sich in Deinem Falle anbieten.

    Vor den Blätter ein Blatt einfügen mit "Start" und am Schluß ein Blatt mit "Stop". In dem "Test"-Blatt wird nun mittels
    =ANZAHL2(Start:Stop!B1) die Anzahl der "x" abgefragt in den Blättern innerhalb Start:Stop.

    Darauf kannst Du dann in der bedingten Formatierung (hab ich in Blatt 3 mal eingebaut) zugreifen.

    Bei Fragen, fragen;)
     
    Zuletzt bearbeitet: 8. März 2013
    silex1, 8. März 2013
    #9
  10. Hallo,

    super, genau so brauche ich es. :-)

    Ich habe =ANZAHL2(Start:Stop!B1) im "Test"-Blatt auf alle Tage angewendet: =ANZAHL2(Start:Stop!B1:AF1). Die Ergebnisse wandle ich in jedem Blatt zwischen START und STOP mittels =WENN(TEST!b1>0;"n";"") um ("n" ergibt mit WEBDINGS einen Punkt) und wende darauf die Bedingte Formatierung an.

    Wurde also das Motiv in einem der Monate geschaltet, erhalte ich auf jedem Monatsblatt einen roten Punkt.

    Danke für diese Methode. Und die Mühe, extra diese Beispiel-Datei zu erstellen. Tausend Dank. Hat mir sehr geholfen.

    Gruß, Jürgen
     
    juergenryzek, 9. März 2013
    #10
Thema:

Bedingte Formatierung: Farbe, Bedingung: ODER

Die Seite wird geladen...
  1. Bedingte Formatierung: Farbe, Bedingung: ODER - Similar Threads - Bedingte Formatierung Farbe

  2. Zelle in Spalte D färben, wenn Datum in Spalte C

    in Microsoft Excel Hilfe
    Zelle in Spalte D färben, wenn Datum in Spalte C: Moin, ich würde gerne eine Formatierung haben, wenn ich in einer Zelle in der Spalte C das Datum "30.06.2022" eintrage, z.B. in C5, dass die Zelle in D5 dann rot eingefärbt wird. Das jedoch für...
  3. Farbe aus Zelle für bedingte Formatierung übernehmen

    in Microsoft Excel Hilfe
    Farbe aus Zelle für bedingte Formatierung übernehmen: Hallo zusammen, ich habe eine Frage wie ich evtl. einiges an "Klick-Arbeit" einsparen kann. Im angehängten Beispiel, ist eine Urlaubsliste: - die Zellen mit den Namen sind farbig gefüllt - für...
  4. Excel bedingte Formatierung: Jede gleiche Zahl in der gleichen aber zufälligen Farbe

    in Microsoft Excel Hilfe
    Excel bedingte Formatierung: Jede gleiche Zahl in der gleichen aber zufälligen Farbe: Hallo zusammen, ich habe eine Excel-Tabelle mit mehreren Zahlen zwischen 1 und 2000. Jede Zahl kann dabei öfter vorkommen und ich möchte jede Zelle der gleichen Zahl in der selben Farbe...
  5. bedingte Farbformatierung aus mehreren Zellen

    in Microsoft Excel Hilfe
    bedingte Farbformatierung aus mehreren Zellen: Hallo, ich sitze gerade an einer Tabelle und versuche folgende Bedingungen zu erreichen. Wenn C4 und D4 beides 0 ist, dann soll B4 rot sein wenn C4 größer als 0 ist und D4 0 ist, dann soll...
  6. Bedingte - farbliche - Formatierung der angezeigten Anzahl von Mails

    in Microsoft Outlook Hilfe
    Bedingte - farbliche - Formatierung der angezeigten Anzahl von Mails: Hallo, gibt es eine Möglichkeit, die Anzahl der Mails, welche in eckigen Klammern hinter einer Ordnerangabe steht, selber farblich anzupassen? Bsp.: Vorhandene Anzeige Posteingang [3] Entwürfe...
  7. Bedingte Formatierung

    in Microsoft Excel Hilfe
    Bedingte Formatierung: Guten Tag, ich habe eine Tabelle, in der ich für verschiedene Bereiche Differenzmengen erfasse. Ich möchte nun die Bereichsnummer, für die ich Werte erfasst habe farblich kenntlich machen, damit...
  8. Farbe von Bedingten Formatierung auf ganze Zeile übertragen

    in Microsoft Excel Hilfe
    Farbe von Bedingten Formatierung auf ganze Zeile übertragen: Hallo, habe eine Spalte Z.B. E1-E100 mit der bedingter Formatierung kleinsten und größten Wert formatiert. So weit so gut. Nun möchte ich aber gerne, dass auch immer die betreffende ganze Zeile...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden