Office: Datum in einer Liste nach Datum sortieren

Helfe beim Thema Datum in einer Liste nach Datum sortieren in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Grüezi aus der Schweiz Ich habe eine Liste von Daten die ich nach Monate sortieren möchte, ohne eine PT zu benutzen. Ich benutze in diesem Beispiel... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von mscola, 13. Oktober 2011.

  1. mscola Erfahrener User

    Datum in einer Liste nach Datum sortieren


    Grüezi aus der Schweiz

    Ich habe eine Liste von Daten die ich nach Monate sortieren möchte, ohne eine PT zu benutzen. Ich benutze in diesem Beispiel bewusst zwei Tabellenblätter, da ich in meinem Projekt zwei Blätter benutze. In meinem Projekt hat es auch leere Zeilen.

    Für die Monate habe ich folgende Formel benutzt, aber sie scheint nicht zu funktionieren. Kann mir jemand sagen was ich falsch mache, bzw. wie ich sie ändern muss?

    Code:
    =SUMME(WENN(KundenDatum<>"";WENN(MONAT(KundenDatum)=ZEILE()-1;1;0)))
    Vielen Dank

    Massimo



    Blatt 1:

    Arbeitsblatt mit dem Namen 'Datum'
     A
    1Date
    22. Januar 2011
    36. Januar 2011
    412. Januar 2011
    514. Januar 2011
    621. Januar 2011
    721. Februar 2011
    815. März 2011
    921. März 2011
    105. April 2011
    1121. April 2011
    125. Mai 2011
    1321. Mai 2011
    1421. Mai 2011
    15 
    16 
    1721. Juni 2011
    1821. Juli 2011
    1921. August 2011
    207. September 2011
    218. September 2011
    2221. September 2011
    236. Oktober 2011
    2421. Oktober 2011
    259. November 2011
    2621. November 2011
    2710. Dezember 2011
    2821. Dezember 2011
    29 

    Blatt 2:

    [parsehtml]
    Arbeitsblatt mit dem Namen 'Anzahl'
     ABCD
    1Neue Kunden seit
    2
    3Januar1Juli1
    4Februar2August2
    5März2September2
    6April3Oktober3
    7Mai1November1
    8Juni1Dezemeber1
    <tr><td valign='top'>
    NameBezug
    KundenDatum=BEREICH.VERSCHIEBEN(Datum!$A$2;;;ANZAHL2(Datum!$A:$A)-1;1)
    </td><td valign='top'>
    ZelleFormel
    B3{=SUMME(WENN(KundenDatum<>"";WENN(MONAT(KundenDatum)=ZEILE()-1;1;0)))}
    D3{=SUMME(WENN(KundenDatum<>"";WENN(MONAT(KundenDatum)=ZEILE()-1;1;0)))}
    B4{=SUMME(WENN(KundenDatum<>"";WENN(MONAT(KundenDatum)=ZEILE()-1;1;0)))}
    D4{=SUMME(WENN(KundenDatum<>"";WENN(MONAT(KundenDatum)=ZEILE()-1;1;0)))}
    B5{=SUMME(WENN(KundenDatum<>"";WENN(MONAT(KundenDatum)=ZEILE()-1;1;0)))}
    D5{=SUMME(WENN(KundenDatum<>"";WENN(MONAT(KundenDatum)=ZEILE()-1;1;0)))}
    B6{=SUMME(WENN(KundenDatum<>"";WENN(MONAT(KundenDatum)=ZEILE()-1;1;0)))}
    D6{=SUMME(WENN(KundenDatum<>"";WENN(MONAT(KundenDatum)=ZEILE()-1;1;0)))}
    B7{=SUMME(WENN(KundenDatum<>"";WENN(MONAT(KundenDatum)=ZEILE()-1;1;0)))}
    D7{=SUMME(WENN(KundenDatum<>"";WENN(MONAT(KundenDatum)=ZEILE()-1;1;0)))}
    B8{=SUMME(WENN(KundenDatum<>"";WENN(MONAT(KundenDatum)=ZEILE()-1;1;0)))}
    D8{=SUMME(WENN(KundenDatum<>"";WENN(MONAT(KundenDatum)=ZEILE()-1;1;0)))}
    </td></tr><tr><td valign='top'><table><tr><td>Achtung, Matrixformel enthalten!</td></tr><tr><td><span>Die geschweiften Klammern{} werden </span><span>nicht</span><span> eingegeben.</span></td></tr><tr><td><span>Verlassen Sie den Zelleneditor mit </span><span>Strg+Shift + Enter</span><span>, statt Enter alleine.</span></td></tr></table>[/parsehtml]</td></tr></table>[/parsehtml]
     
    Zuletzt von einem Moderator bearbeitet: 30. November 2020
  2. Hajo_Zi
    Hajo_Zi Erfahrener User
    was ist ein PT? Die nicxht benutzt werden soll.
    Sortieren nach Monat und Tag
    das Datum steht in Spalte A
    Sortieren tust Du nur nach einer Hilfsspalte; darin steht:
    =MONAT(A1)+TAG(A1)/100
    und runterkopieren
    von WF

    und
    Monat, Tag und Jahr
    =MONAT(A1)+TAG(A1)/100+Jahr(A1)/10000
    und runterkopieren (Zellformat ist Standart)
    von NG

    Gruß Hajo
     
    Hajo_Zi, 13. Oktober 2011
    #2
  3. Kallewirsch Erfahrener User
    Hallo,

    warum nicht so:

    Arbeitsblatt mit dem Namen 'Tabelle1'
     FGHI
    2Neue Kunden seit   
    3    
    4Januar5Juli1
    5Februar1August1
    6März2September3
    7April2Oktober2
    8Mai3November2
    9Juni1Dezember2
    ZelleFormel
    G4=SUMMENPRODUKT((MONAT($A$2:$A$28)=MONAT(F4&1))*($A$2:$A$28<>""))
    <table><tr><td>Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg</td></tr></table>[/parsehtml]

    @Hajo,

    PT=PivotTabelle


    Gruß

    Edgar
     
    Zuletzt von einem Moderator bearbeitet: 30. November 2020
    Kallewirsch, 13. Oktober 2011
    #3
  4. Thema:

    Datum in einer Liste nach Datum sortieren

    Die Seite wird geladen...
    1. Datum in einer Liste nach Datum sortieren - Similar Threads - Datum Liste Datum

    2. Problem mit Diagramm und Datum

      in Microsoft Excel Hilfe
      Problem mit Diagramm und Datum: Hallo Zusammen, anbei eine Beispieldatei. bekomme es nicht hin das im Diagramm in der Horizontalen Beschriftung wo jetzt 1 bis 31 steht,das Datum wie in den Zellen B37:AF37 angezeigt wird. Und...
    3. Das Datum der nächsten Veranstaltung (in der Zukunft) anzeigen

      in Microsoft Excel Hilfe
      Das Datum der nächsten Veranstaltung (in der Zukunft) anzeigen: Hallo, ich bin auf der Suche nach einer passenden Formel für folgendes Problem: In der Übersicht stehen 3 Daten für Veranstaltungen (hier beispielhaft Veranstaltung 1/2/3 genannt). In der "roten...
    4. Liste nach Datum filtern zerstört auflistung

      in Microsoft Excel Hilfe
      Liste nach Datum filtern zerstört auflistung: Guten Tag, Wir haben eine Liste welche alle Bestellungen beinhaltet. Ich hätte diese Liste gerne auf einem zweiten Blatt gefiltert das nur diesen Monat anzeigt. Leider stimmt dann aber die...
    5. Wenn Datum in Liste dann Buchstabe in folgender Zelle

      in Microsoft Excel Hilfe
      Wenn Datum in Liste dann Buchstabe in folgender Zelle: Hallo, leider hat die Suchfunktion keine Ergebnisse gebracht(oder ich war zu doof richtig zu suchen *frown.gif* ) Folgende Situation: Ich habe eine Tabelle in der User in Spalte A ein Datum...
    6. Registerkarte Lists nach Datum sortieren

      in Microsoft Teams Hilfe
      Registerkarte Lists nach Datum sortieren: Hallo, ich habe in einem Kanal eine Registerkarte von "Lists" die ich nach Datum gruppiert habe. Ist es irgendwie möglich, dass bei dieser Liste immer die neuesten Einträge ganz oben angezeigt...
    7. Liste erstellen mit Werten aus anderer Tabelle mit Abgleich Datum

      in Microsoft Excel Hilfe
      Liste erstellen mit Werten aus anderer Tabelle mit Abgleich Datum: Hallo, ich habe eine Datei (siehe Beilage) erstellt für Gästebuchungen ("Buch.") mit 900 Zeilen, in welcher fortlaufend alle Buchungen eingetragen werden. Nun möchte ich in einer 2. Tabelle...
    8. Aus Abfrage eine Liste mit Datum generieren

      in Microsoft Access Hilfe
      Aus Abfrage eine Liste mit Datum generieren: Hallo, folgendes Problem - ich habe eine Liste von Leuten - mit einer Aufgaben Liste. Ich möchte nun aus beiden eine Art Zeitplan generieren. Jeder hat seinen eigenen Aufgabenplan - beide...
    1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
      Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
      Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
      Information ausblenden