Office: Dubletten/Tripletten filtern/markieren - aber nur bestimmte löschen

Helfe beim Thema Dubletten/Tripletten filtern/markieren - aber nur bestimmte löschen in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Mit meinem ersten Eintrag wünsche ich euch auch direkt ein frohes neues Jahr zusammen. Ich hoffe ich kann mein Problem entsprechend schildern, damit... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von illnino666, 1. Januar 2015.

  1. Dubletten/Tripletten filtern/markieren - aber nur bestimmte löschen


    Mit meinem ersten Eintrag wünsche ich euch auch direkt ein frohes neues Jahr zusammen.

    Ich hoffe ich kann mein Problem entsprechend schildern, damit ihr mir hier weiterhelfen könnt.

    Zum Problem:

    Ich habe eine (korrekte) Statistik. Dort sind u.a. Artikel und Provisionen aufgeführt.
    Die Provisionen sind gestaffelt. Für 0-50 Artikel -> Provision x | Für 51-100 Aritkel -> Provision xy usw.
    Sobald eine höhere Provisionsstufe erreicht wurde, erhält ein Artikel auch die nächste, höhere Provisionsstufe.

    Bsp.:

    Artikel Datum Provision
    0007654321 December 03, 2014 0,47 (Stufe1)
    ------------------------------------------------------------------

    Am 16. Dezember wurde eine neue Provisionsstufe erreicht - der Artikel hat demzufolge einen neuen Wert.
    0007654321 December 16, 2014 0,55 (Stufe2)
    ------------------------------------------------------------------

    Am 26. Dezember wurde eine dritte Provisionsstufe erreicht - der Artikel hat demzufolge erneut einen höheren Wert.
    0007654321 December 26, 2014 0,68 (Stufe3)

    Die 0,68 € sind demzufolge abzurechnen.

    Zum eigentlichen Problem:
    Aufgrund eines Programmierfehlers auf meiner Website wurden die Provisionswerte in mein System falsch importiert.
    In der fehlerhaften Statistik wurden die alten Werte nicht ersetzt, sondern die neuen einfach "on-top" dubliziert.

    Bsp:

    Artikel Datum Provision
    0007654321 December 03, 2014 0,47 (Stufe1)
    0007654321 December 16, 2014 0,55 (Stufe2)
    0007654321 December 26, 2014 0,68 (Stufe3)

    Abgerechnet wurden in diesem Falle alle 3 Beträge zusammen. Demnach zieht das Ganze dementsprechende Differenzen mitsich, die ich nun herausfiltern möchte um den Gesamten Schaden zu analysieren.

    Wie bekomme ich nun diese Dubletten, Tripletten oder Quartetten herausgefiltert, separiert, markiert und im besten Falle den Artikel mit dem höchsten Wert nicht gelöscht.

    Ich hoffe sehr, dass es hierfür eine Funktion, oder ein Script gibt und würde mich sehr über eure Antworten freuen.
    Falls natürlich noch Fragen offen sein sollten, gebt Bescheid.

    Vielen Dank im Voraus!
    IllNino
     
    illnino666, 1. Januar 2015
    #1
  2. schatzi Super-Moderator
    Frohes Neues!

    Wenn der aktuellste Eintrag immer der letzte/unterste Eintrag ist, dann wäre dies eine Möglichkeit:

     AB
    1FilterArtNr
    2 1234
    3 1234
    4X1234
    5 2345
    6 3456
    7X3456
    8 2345
    9X2345
    <br />
    Formeln der Tabelle[parsehtml]
    ZelleFormel
    A2=WENN(ZÄHLENWENN(B3:B$9999;B2);"";"X")
    A3=WENN(ZÄHLENWENN(B4:B$9999;B3);"";"X")
    A4=WENN(ZÄHLENWENN(B5:B$9999;B4);"";"X")
    A5=WENN(ZÄHLENWENN(B6:B$9999;B5);"";"X")
    A6=WENN(ZÄHLENWENN(B7:B$9999;B6);"";"X")
    A7=WENN(ZÄHLENWENN(B8:B$9999;B7);"";"X")
    A8=WENN(ZÄHLENWENN(B9:B$9999;B8);"";"X")
    A9=WENN(ZÄHLENWENN(B10:B$9999;B9);"";"X")
    </td></tr></table>[/parsehtml] <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4 </a>
     
    Zuletzt von einem Moderator bearbeitet: 30. November 2020
    schatzi, 1. Januar 2015
    #2
  3. vielen Dank für die schnelle Antwort.

    Leider nein, dazwischen mischen sich auch "normale" Artikel.
    So beispielsweise.

    <b>Tabelle2</b><br /><br />
     ABCD
    1ArtikelDatumProvision 
    2746494016.12.2012            0,44 €  
    3746494016.12.2012            0,47 € <- korrekt
    4748837814.12.2012            0,78 €  
    5748837814.12.2012            0,84 € <- korrekt
    64132984822.01.2014            0,84 € <- korrekt
    76009129016.01.2013            0,10 € <- korrekt
    86080352525.01.2013            0,30 € <- korrekt
    99956043710.12.2013            0,45 €  
    109956043710.12.2013            0,48 € <- korrekt
    119957012209.10.2014            0,50 € <- korrekt
    1214043771101.09.2014            0,43 €  
    1314043771101.09.2014            0,47 € <- korrekt
    <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4.8 </a>

    Alternativ könnte man auch die falsche und die richtige Statistik-Tabelle vergleichen und die "falschen" Einträge markieren/in ein anderes Tabellenblatt schieben - falls das geht.

    Merci!
    IllNino
     
    Zuletzt von einem Moderator bearbeitet: 30. November 2020
    illnino666, 1. Januar 2015
    #3
  4. schatzi Super-Moderator

    Dubletten/Tripletten filtern/markieren - aber nur bestimmte löschen

    Hallo!

    Wirklich ausprobiert hast du meine Formel nicht, oder?

    Sie markiert genau die von dir gewünschten Zeilen!

     ABCDE
    1ArtikelDatumProvision Filter
    2746494016.12.2012 0,44 €  
    3746494016.12.2012 0,47 €<- korrektX
    4748837814.12.2012 0,78 €  
    5748837814.12.2012 0,84 €<- korrektX
    64132984822.01.2014 0,84 €<- korrektX
    76009129016.01.2013 0,10 €<- korrektX
    86080352525.01.2013 0,30 €<- korrektX
    99956043710.12.2013 0,45 €  
    109956043710.12.2013 0,48 €<- korrektX
    119957012209.10.2014 0,50 €<- korrektX
    1214043771101.09.2014 0,43 €  
    1314043771101.09.2014 0,47 €<- korrektX
    <br />
    Formeln der Tabelle[parsehtml]
    ZelleFormel
    E2=WENN(ZÄHLENWENN(A3:A$999;A2);"";"X")
    E3=WENN(ZÄHLENWENN(A4:A$999;A3);"";"X")
    E4=WENN(ZÄHLENWENN(A5:A$999;A4);"";"X")
    E5=WENN(ZÄHLENWENN(A6:A$999;A5);"";"X")
    E6=WENN(ZÄHLENWENN(A7:A$999;A6);"";"X")
    E7=WENN(ZÄHLENWENN(A8:A$999;A7);"";"X")
    E8=WENN(ZÄHLENWENN(A9:A$999;A8);"";"X")
    E9=WENN(ZÄHLENWENN(A10:A$999;A9);"";"X")
    E10=WENN(ZÄHLENWENN(A11:A$999;A10);"";"X")
    E11=WENN(ZÄHLENWENN(A12:A$999;A11);"";"X")
    E12=WENN(ZÄHLENWENN(A13:A$999;A12);"";"X")
    E13=WENN(ZÄHLENWENN(A14:A$999;A13);"";"X")
    </td></tr></table>[/parsehtml] <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4 </a>
     
    Zuletzt von einem Moderator bearbeitet: 30. November 2020
    schatzi, 1. Januar 2015
    #4
  5. Das ist jetzt peinlich - hatte quasi nen Lesefehler und deshalb gar nicht ausprobiert - sorry!

    Deine Formel funktioniert natürlich.
    Dann kann ich mich glaub erstmal damit austoben und schön hin und her filtern :) ... bei Fragen meld ich mich einfach nochmal.

    Vielen herzlichen Dank für die megaschnelle Hilfe!

    Beste Grüße
    IllNino
     
    illnino666, 1. Januar 2015
    #5
  6. Hallöchen,

    leider hat es doch noch nicht ganz funktioniert. Hab zwar selber etwas herumprobiert aber da muss wohl doch n Profi nochmal ran.

    Wenn ich den Filter nun anwende - werden natürlich alle Artikel in der gesamten Statistik herangezogen und markiert.

    Der Artikel kann natürlich auch im nächsten Monat oder im Jahr darauf wieder auftauchen und zählt dann aber.

    <b>Tabelle2</b><br /><br />
     ABCDE
    1ArtikelDatumProvision Filter
    2748837814.12.2012            0,78 €   
    3748837814.12.2012            0,84 € <- korrektX
    4746494016.12.2012            0,44 €   
    5746494016.12.2012            0,47 € <- korrektX
    66009129016.01.2013            0,10 € <- korrekt 
    76080352525.01.2013            0,30 € <- korrektX
    89956043710.12.2013            0,45 €   
    99956043710.12.2013            0,48 € <- korrektX
    104132984822.01.2014            0,84 € <- korrektX
    116009129024.01.2014            0,10 € <- korrektX
    1214043771101.09.2014            0,43 €   
    1314043771101.09.2014            0,47 € <- korrektX
    149957012209.10.2014            0,50 € <- korrektX
    <br />
    Formeln der Tabelle[parsehtml]
    ZelleFormel
    E2=WENN(ZÄHLENWENN(A3:A$1000;A2);"";"X")
    E3=WENN(ZÄHLENWENN(A4:A$1000;A3);"";"X")
    E4=WENN(ZÄHLENWENN(A5:A$1000;A4);"";"X")
    E5=WENN(ZÄHLENWENN(A6:A$1000;A5);"";"X")
    E6=WENN(ZÄHLENWENN(A7:A$1000;A6);"";"X")
    E7=WENN(ZÄHLENWENN(A8:A$1000;A7);"";"X")
    E8=WENN(ZÄHLENWENN(A9:A$1000;A8);"";"X")
    E9=WENN(ZÄHLENWENN(A10:A$1000;A9);"";"X")
    E10=WENN(ZÄHLENWENN(A12:A$1000;A10);"";"X")
    E11=WENN(ZÄHLENWENN(A12:A$1000;A11);"";"X")
    E12=WENN(ZÄHLENWENN(A13:A$1000;A12);"";"X")
    E13=WENN(ZÄHLENWENN(A14:A$1000;A13);"";"X")
    E14=WENN(ZÄHLENWENN(A15:A$1000;A14);"";"X")
    </td></tr></table>[/parsehtml] <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4.8 </a>

    Wenn ich nun in der Formel nur einen gewissen Spalten-Raum angebe, bekomm ich es zwar gefiltert - kann dann aber nicht mehr sortieren, ohne dass es mir den Filter verschiebt.
    Gibt es hierfür ne Lösung?

    Das ist leider etwas verzwickt - ich weiss. :)

    Nochmals danke für die Hilfe!
    Grüße,
    IllNino
     
    Zuletzt von einem Moderator bearbeitet: 30. November 2020
    illnino666, 2. Januar 2015
    #6
  7. schatzi Super-Moderator
    Hallo!

    Dann probier mal diese Formel:

    =WENN(SUMMENPRODUKT((A3:A$999=A2)*(JAHR(B3:B$999)=JAHR(B2)));"";"X")
     
    schatzi, 2. Januar 2015
    #7
  8. Dubletten/Tripletten filtern/markieren - aber nur bestimmte löschen

    Damit kommts erstmal hin - klasse!

    Als Gegencheck hab ich mir noch ne "IDENTISCH" Mittelzeile gebaut - dann kann ich alt und neu vergleichen.
    Falls etwas doch durchrutscht, kann ich nachbessern.

    Vielen Dank! Ich bin froh, dass ich mich hier angemeldet habe!

    Beste Grüße und ein schönes WE!
    IllNino
     
    illnino666, 2. Januar 2015
    #8
Thema:

Dubletten/Tripletten filtern/markieren - aber nur bestimmte löschen

Die Seite wird geladen...
  1. Dubletten/Tripletten filtern/markieren - aber nur bestimmte löschen - Similar Threads - Dubletten Tripletten filtern

  2. Filterregel für Absender im Suffix (rechts von @)

    in Microsoft Outlook Hilfe
    Filterregel für Absender im Suffix (rechts von @): Hallo zusammen, ich suche bislang erfolglos nach einem Weg nach Teilen der Absender-Emailadresse zu filtern. Und zwar konkret, einem Teil der nach dem @ folgt (im Suffix). Beispiel:...
  3. Tabelle Monat suchen und Namen ausgeben

    in Microsoft Excel Hilfe
    Tabelle Monat suchen und Namen ausgeben: Hallo, ich habe folgendes vor. Ich habe eine Tabelle mit Namen und Geburtstagen. Die habe ich in Excel tab_freunde genannt. Nun möchte ich, dass ich in einem Blatt/Tab alle Name meiner Freunde...
  4. Abfrage nach Dubletten

    in Microsoft Access Hilfe
    Abfrage nach Dubletten: Hallo und guten Tag Vielleicht könnte mir mal jemand einen Tipp geben, was ich falsch mache. Ich habe eine Adresstabelle mit rund 9000 Einträgen darin. Die Tabelle verfügt über verschiedene...
  5. Zellinhalte per VBA in 2tes Tabellenblatt kopieren und anhängen

    in Microsoft Excel Hilfe
    Zellinhalte per VBA in 2tes Tabellenblatt kopieren und anhängen: Hallo, ich stehe vor folgender Herausforderung und meine VBA Kenntnisse sind leider nur sehr rudimentär : Ich möchte aus diversen Zellen im Tabellenblatt1 Daten per "Knopfdruck" in verschiedene...
  6. VBA-Formular ; Dubletten bei der Eingabe erkennen

    in Microsoft Excel Hilfe
    VBA-Formular ; Dubletten bei der Eingabe erkennen: Hallo zusammen, ich überarbeite aktuell eine Anfrageliste, die in Excel geführt wird. Hierbei soll jeder Kundenkontakt mit einheitlichen Informationen erfasst werden. In einem älteren...
  7. VBA-Formular ; Dubletten bei der Eingabe erkennen

    in Microsoft Excel Hilfe
    VBA-Formular ; Dubletten bei der Eingabe erkennen: Hallo zusammen, ich überarbeite aktuell eine Anfrageliste, die in Excel geführt wird. Sinn der Datei ist, dass jeder Kunde der Kontakt aufnimmt einheitlich über diese Liste - mit vorbelegten...
  8. Dubletten/Löschabfrage

    in Microsoft Access Hilfe
    Dubletten/Löschabfrage: Beitrag hat sich erledigt. Vielen Dank.
Schlagworte:
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden