Office: Excel Blattnummer (Tabellennummer) zu Tabellenname konvertieren?

Helfe beim Thema Excel Blattnummer (Tabellennummer) zu Tabellenname konvertieren? in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Grüße, bin noch neu in Excel und im Forum, falls ich im falschen Bereich gepostet habe, wäre es nett mir das zu erklären. Meine Frage wäre: mit der... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von SuperFranTV, 14. Januar 2022.

  1. Excel Blattnummer (Tabellennummer) zu Tabellenname konvertieren?


    Grüße,

    bin noch neu in Excel und im Forum, falls ich im falschen Bereich gepostet habe, wäre es nett mir das zu erklären.

    Meine Frage wäre:
    mit der Funktion BLATT("Tabelle1") bekomme ich die Tabellen-ID oder Blattnummer,
    ich habe mehrere Tabellen und diese werden immer erweitert von der Anzahl und 1 Haupttabelle mit einer allgemeinen Übersicht.

    Dort benutze ich im Moment:
    ='Tabellenname'!A3

    Um nicht jedes mal den Tabellennamen einzutragen, würde ich gerne die Blattnummer nutzen an Stelle des Namens. Die Blattnummern sind fest und mir bekannt.

    Vielen Dank schon einmal.
    Mit freundlichen Grüßen,

    der Neue
     
    SuperFranTV, 14. Januar 2022
    #1
  2. Hajo_Zi
    Hajo_Zi Erfahrener User
    mit der Indexnummer kannst Du nicht in Formel arbeiten.


    vorhandene Tabellen
     ABCD
    1DatumVeranstaltungGästeBeginn
    2Tabelle1   
    3Tabelle2   
    4Tabelle5   
    5Tabelle3   
    6Tabelle4   
    7 Hi Holger,  
    8    
    9 hatte diese Frage auch grad in einem anderen Forum (anderer Fragesteller) so beantwortet:  
    10    
    11 Einfügen -> Namen -> Definieren/Festlegen, Name: x  
    12 bezieht sich auf:  
    13 =ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())  
    14    
    15 In irgendeine Zelle jetzt diese Formel und runterkopieren:  
    16 =WENN(ZEILEN($1:1)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:1));FINDEN("]";INDEX(x;ZEILEN($1:1)))+1;31))  
    17    
    18 Grüße Boris  
    19 ab 2007 als XLSM speichern  
    20    
    21 Formel runter ziehen falls Mehr Tabellen  
    22 fürs Add In  

    verwendete Formeln
    Zelle Formel Bereich N/A
    C4:C5=WENN(ISTFEHLER(INDIREKT(A4&"!E4"));"";INDIREKT(A4&"!E4"))  
    D4: D5=WENN(ISTFEHLER(INDIREKT(A4&"!F4"));"";INDIREKT(A4&"!F4"))  
    B4:B6,B20=WENN(ISTFEHLER(INDIREKT(A4&"!B4: D4"));"";INDIREKT(A4&"!B4: D4"))  
    C6:C21=WENN(ISTFEHLER(INDIREKT(A6&"!G4"));"";INDIREKT(A6&"!G4"))  
    A2:A22=WENN(ZEILEN($1:1)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:1));FINDEN("]";INDEX(x;ZEILEN($1:1)))+1;31))  

    definierte Namen  
    Name Bezieht sich auf Tabelle Z1S1-Formel
    x=ARBEITSMAPPE.ZUORDNEN(1+0*JETZT()) =GET.WORKBOOK(1+0*NOW())
    http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
    http://Hajo-Excel.de/tools.htm
    Add-In-Version 25.23 einschl. 64 Bit
    XHTML-Tabelle zur Darstellung in Foren, einschl. Funktion zum Zurücklesen in eine Excel-Tabelle

    Excel Blattnummer (Tabellennummer) zu Tabellenname konvertieren? GrußformelExcel Blattnummer (Tabellennummer) zu Tabellenname konvertieren? Homepage
     
    Hajo_Zi, 14. Januar 2022
    #2
  3. Exl121150 Erfahrener User
    Hallo,

    um mit der Blattindex-Nummer zusammen mit einem Zellbereich einen Zellbereich innerhalb eines Arbeitsblattes zu ermitteln, wirst wohl oder übel um etwas VBA nicht herum kommen.
    Dazu kannst du in ein allgemeines VBA-Codemodul folgende Funktion eingeben:
    Code:
    Option Explicit
    
    Public Function NrAdr(ByVal BlNr As Integer, ByVal ZellBereich As Variant) As Range
       Application.Volatile
       If VarType(ZellBereich) <> vbString Then ZellBereich = ZellBereich.Address
       Set NrAdr = Worksheets(BlNr).Range(ZellBereich)
    End Function
    
    Es handelt sich um eine volatile Funktion, d.h. nach Drücken der F9-Taste sind die Funktionsergebnisse aktualisiert.
    Im Arbeitsblatt "Tabelle2" habe ich ein paar Funktionsbeispiele eingefügt. Die Demo-Datei liegt bei.
     
    Exl121150, 14. Januar 2022
    #3
Thema:

Excel Blattnummer (Tabellennummer) zu Tabellenname konvertieren?

Die Seite wird geladen...
  1. Excel Blattnummer (Tabellennummer) zu Tabellenname konvertieren? - Similar Threads - Excel Blattnummer Tabellennummer

  2. Sharepoint / Excel

    in Microsoft Excel Hilfe
    Sharepoint / Excel: Hallo zusammen, ich bin jetzt seit Tagen im Internet auf der Suche zu Hilfestellungen zu dem Thema und habe jetzt die Hoffnung das mir hier geholfen werden kann :-) Mein Anliegen ist folgendes:...
  3. Design wird nicht angezeigt

    in Microsoft Excel Hilfe
    Design wird nicht angezeigt: Wenn ich Design anwähle ändern sich zwar die Schriftarten aber keine Farben. Wer kann mir da helfen?
  4. Gantt-Diagramm

    in Microsoft Excel Hilfe
    Gantt-Diagramm: Hallo ich brauche Hilfe bei folgender Sache. Ich habe ein Gantt Diagramm mit Excel erstellt und habe mit folgender FORMEL den Soll-Zustand festgelegt, anhand von Start und Enddatum:...
  5. Hilfe

    in Microsoft Excel Hilfe
    Hilfe: Liebe Alle, ich bin ganz neu in diesem Forum und bräuchte Hilfe zu einem Excel Projekt. Ich möchte (siehe Bild 1) das die Felder die dort ausgefüllt werden automatisch in Bild 2 übertragen in...
  6. Zeilen an Bedingung geknüpft ein- oder ausblenden

    in Microsoft Excel Hilfe
    Zeilen an Bedingung geknüpft ein- oder ausblenden: Guten Morgen zusammen, ich bin seit dieser Woche etwas am Verzweifeln.. Ich bin dabei für meine Kollegen eine neue Eingabemaske für ein Prüfprotokoll in Excel zu bauen, bzw. die meines Vorgängers...
  7. Dropdown - bei Auswahl bestimmte Texte in Zeilen einfügen

    in Microsoft Excel Hilfe
    Dropdown - bei Auswahl bestimmte Texte in Zeilen einfügen: Hallo zusammen, ich habe da mal ein kleines Problem. Aktuell arbeite ich an einer Exceltabelle wo ich ein Prüfprotokoll erstelle. Die Auswahl der Komponenten habe ich mit Dropdown-Listen...
  8. Hyperlink aus mehreren Zellen zusammensetzten

    in Microsoft Excel Hilfe
    Hyperlink aus mehreren Zellen zusammensetzten: Hallo Freunde, ich möchte einen Hyperlink aus 2 Zellen (Pfad und Datei) zusammensetzen. Ich habe folgendes gemacht: In Zelle I16 steht der Pfad und in Zelle J16 der Dateiname. Nun habe ich die...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden