Office: Excel Blattnummer (Tabellennummer) zu Tabellenname konvertieren?

Helfe beim Thema Excel Blattnummer (Tabellennummer) zu Tabellenname konvertieren? in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Grüße, bin noch neu in Excel und im Forum, falls ich im falschen Bereich gepostet habe, wäre es nett mir das zu erklären. Meine Frage wäre: mit der... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von SuperFranTV, 14. Januar 2022 um 11:21 Uhr.

  1. Excel Blattnummer (Tabellennummer) zu Tabellenname konvertieren?


    Grüße,

    bin noch neu in Excel und im Forum, falls ich im falschen Bereich gepostet habe, wäre es nett mir das zu erklären.

    Meine Frage wäre:
    mit der Funktion BLATT("Tabelle1") bekomme ich die Tabellen-ID oder Blattnummer,
    ich habe mehrere Tabellen und diese werden immer erweitert von der Anzahl und 1 Haupttabelle mit einer allgemeinen Übersicht.

    Dort benutze ich im Moment:
    ='Tabellenname'!A3

    Um nicht jedes mal den Tabellennamen einzutragen, würde ich gerne die Blattnummer nutzen an Stelle des Namens. Die Blattnummern sind fest und mir bekannt.

    Vielen Dank schon einmal.
    Mit freundlichen Grüßen,

    der Neue
     
  2. Hajo_Zi
    Hajo_Zi Erfahrener User
    mit der Indexnummer kannst Du nicht in Formel arbeiten.


    vorhandene Tabellen
     ABCD
    1DatumVeranstaltungGästeBeginn
    2Tabelle1   
    3Tabelle2   
    4Tabelle5   
    5Tabelle3   
    6Tabelle4   
    7 Hi Holger,  
    8    
    9 hatte diese Frage auch grad in einem anderen Forum (anderer Fragesteller) so beantwortet:  
    10    
    11 Einfügen -> Namen -> Definieren/Festlegen, Name: x  
    12 bezieht sich auf:  
    13 =ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())  
    14    
    15 In irgendeine Zelle jetzt diese Formel und runterkopieren:  
    16 =WENN(ZEILEN($1:1)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:1));FINDEN("]";INDEX(x;ZEILEN($1:1)))+1;31))  
    17    
    18 Grüße Boris  
    19 ab 2007 als XLSM speichern  
    20    
    21 Formel runter ziehen falls Mehr Tabellen  
    22 fürs Add In  

    verwendete Formeln
    Zelle Formel Bereich N/A
    C4:C5=WENN(ISTFEHLER(INDIREKT(A4&"!E4"));"";INDIREKT(A4&"!E4"))  
    D4: D5=WENN(ISTFEHLER(INDIREKT(A4&"!F4"));"";INDIREKT(A4&"!F4"))  
    B4:B6,B20=WENN(ISTFEHLER(INDIREKT(A4&"!B4: D4"));"";INDIREKT(A4&"!B4: D4"))  
    C6:C21=WENN(ISTFEHLER(INDIREKT(A6&"!G4"));"";INDIREKT(A6&"!G4"))  
    A2:A22=WENN(ZEILEN($1:1)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:1));FINDEN("]";INDEX(x;ZEILEN($1:1)))+1;31))  

    definierte Namen  
    Name Bezieht sich auf Tabelle Z1S1-Formel
    x=ARBEITSMAPPE.ZUORDNEN(1+0*JETZT()) =GET.WORKBOOK(1+0*NOW())
    http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
    http://Hajo-Excel.de/tools.htm
    Add-In-Version 25.23 einschl. 64 Bit
    XHTML-Tabelle zur Darstellung in Foren, einschl. Funktion zum Zurücklesen in eine Excel-Tabelle

    Excel Blattnummer (Tabellennummer) zu Tabellenname konvertieren? GrußformelExcel Blattnummer (Tabellennummer) zu Tabellenname konvertieren? Homepage
     
  3. Exl121150 Erfahrener User
    Hallo,

    um mit der Blattindex-Nummer zusammen mit einem Zellbereich einen Zellbereich innerhalb eines Arbeitsblattes zu ermitteln, wirst wohl oder übel um etwas VBA nicht herum kommen.
    Dazu kannst du in ein allgemeines VBA-Codemodul folgende Funktion eingeben:
    Code:
    Option Explicit
    
    Public Function NrAdr(ByVal BlNr As Integer, ByVal ZellBereich As Variant) As Range
       Application.Volatile
       If VarType(ZellBereich) <> vbString Then ZellBereich = ZellBereich.Address
       Set NrAdr = Worksheets(BlNr).Range(ZellBereich)
    End Function
    
    Es handelt sich um eine volatile Funktion, d.h. nach Drücken der F9-Taste sind die Funktionsergebnisse aktualisiert.
    Im Arbeitsblatt "Tabelle2" habe ich ein paar Funktionsbeispiele eingefügt. Die Demo-Datei liegt bei.
     
Thema:

Excel Blattnummer (Tabellennummer) zu Tabellenname konvertieren?

Die Seite wird geladen...
  1. Excel Blattnummer (Tabellennummer) zu Tabellenname konvertieren? - Similar Threads - Excel Blattnummer Tabellennummer

  2. Fehler in =WENN Formel

    in Microsoft Excel Hilfe
    Fehler in =WENN Formel: Hallo Ich habe Excel 2016 und will die Kürzel in einer Spalte in einer zweiten mit Namen anzeigen lassen mit der =Wenn Formel. Ich habe Kürzel wie L2 oder LM etc. Ich geben die Formel wie...
  3. Excel VBA Exit aus der Schleife verhindern

    in Microsoft Excel Hilfe
    Excel VBA Exit aus der Schleife verhindern: Hallo, ich denke, ich habe ein tatsächlich einfaches Problem. Komme aber nicht auf die Lösung. In dieser Schleife x bis 507 wird eine Funktion aufgerufen, die in einer anderen Liste einen Namen...
  4. Symbolleiste in Excel/Word sichern

    in Sonstiges
    Symbolleiste in Excel/Word sichern: Moin moin zusammen, kann man die "selbstangepasste" Symbolleiste für den Schnellzugriff in WORD und EXCEL bei Microsoft 365 Single irgendwie speichern bzw. sichern, um diese nach einer...
  5. Plötzlich Seitenumbrüche in jeder Excel Datei

    in Microsoft Excel Hilfe
    Plötzlich Seitenumbrüche in jeder Excel Datei: Hallo miteinander, ich weiß ja wie ich für jedes Excel Blatt die Seitenumbrüche an- oder ausschalten kann in den erweiterten Optionen, aber leider hilft mir das nicht, denn seit heute habe ich in...
  6. Schnittpunkt zweier Geraden im Excel Diagramm darstellen

    in Microsoft Excel Hilfe
    Schnittpunkt zweier Geraden im Excel Diagramm darstellen: Hallo zusammen, ich möchte gerne einen Schnittpunkt zweier Geraden im Excel Diagramm darstellen und auswerten. Grund dafür ich habe ein Siebliniendiagramm mit Durchgang in y 0-100 % und in x...
  7. Makro zeichnet nicht auf.

    in Microsoft Excel Hilfe
    Makro zeichnet nicht auf.: Hallo ihr Lieben Muss euch was fragen, wir haben gestern den Pc neu aufgesetzt und 2019 Office installiert, heute bemerkte ich, dass ich kein Makro aufzeichnen kann, mit der Maus das ganze bleibt...
  8. Excel VBA Code

    in Microsoft Excel Hilfe
    Excel VBA Code: Hallo Vielleicht kann mir hierbei wer helfen? Warum funktioniert der Code nicht? Der IF-Codeteile mit "F", "iA" und "O" funktionieren. Aber wenn ich im userform den Teil mit "TF" aufrufe...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden