Office: Formel kopieren Indirekt

Helfe beim Thema Formel kopieren Indirekt in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo zusammen, ich habe seit Tagen ein Problem. Ich habe mir mit Hilfe des WWW folgende Formel zusammen gestellt die in der Spalte I genau das machen... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von Sebastian_braucht_Hilfe, 3. Dezember 2020.

  1. Formel kopieren Indirekt


    Hallo zusammen,

    ich habe seit Tagen ein Problem. Ich habe mir mit Hilfe des WWW folgende Formel zusammen gestellt die in der Spalte I genau das machen soll was ich möchte. Hier die Formel:

    =SUMME(ZÄHLENWENN(INDIREKT({"i13"."i15"."i17"});{"";"LK";"RK"}))

    Wenn die Zellen I13 und/oder I15 und/oder I17 leer sind werden sie gezählt bzw. wenn in irgendeiner der Zellen LK oder RK steht. Soweit so gut.

    Jetzt möchte ich diese Formel kopieren (Zelle markieren und Kreuzchen nach rechts ziehen) ich habe über 120 Spalten…

    Jetzt mein Problem: Dabei ändert sich aber nichts. Ich würde mich freuen, wenn aus dem I13 I15 I17 dann J13 J15 J17 dann K13 K15 K17 usw.

    Kann mir bitte jemand die Formel umstellen das es funktioniert.

    Danke schon einmal im Voraus.

    Gruß

    Sebastian
     
    Sebastian_braucht_Hilfe, 3. Dezember 2020
    #1
  2. steve1da Super-Moderator
    Hola,

    ungetestet:
    =SUMMENPRODUKT((REST(ZEILE(I13:I17);2)=1)*(I13:I17={""."rk"."lk"}))

    Gruß,
    steve1da
     
    steve1da, 4. Dezember 2020
    #2
  3. Hallo steve1da,

    vielen dank für die schnelle Antwort. Das kopieren klappt super. Leider macht die Formel noch nicht das was sie soll. Ich habe mal ein Foto mitgeschickt. In B1 sollen nur die Zellen A3, C5 und E7 gezählt werden. Und zwar wenn sie leer sind und/oder wenn dort LK oder RK steht. Darf ich dich nochmal bitten?!

    Gruß

    Sebastian
     

    Anhänge:

    Sebastian_braucht_Hilfe, 4. Dezember 2020
    #3
  4. steve1da Super-Moderator

    Formel kopieren Indirekt

    Hola,

    die Formel macht was sie soll. Für das erste genannte Beispiel. Wenn du die Aufgabe änderst musst du natürlich auch die Formel ändern. Hast du das gemacht? Wenn ja, wie?

    Gruß,
    steve1da
     
    steve1da, 4. Dezember 2020
    #4
  5. Hallo steve1da,

    die Aufgabe hat sich nicht geändert. Ich habe mich wahrscheinlich nur falsch ausgedrückt. Es geht mir nur um die Zellen I13 I15 und I17. In deiner Formel ist der Bereich I13:I17 angegeben. Die Zellen I14 und I16 dürfen aber nicht mitbetrachtet werden.

    Die Formel benötige ich für eine Personalplanung. I13 bis I17 sind Mitarbeiter. Es sollen aber nur die Mitarbeiter hinter I13 I15 und I17 berücksichtigt werden. Die Reihenfolge ist leider nicht veränderbar. Ist ein Mitarbeiter(I13 I15 oder I17) im Dienst ist das Feld leer und soll gezählt werden. Steht in dem Feld LK oder RK soll es auch gezählt werden. Trage ich irgend etwas anderes in die Zelle ein sollen sie nicht gezählt werden. Wenn du Lust hast kannst du meine Formel mal ausprobieren.

    Ich habe halt nur das Problem das ich diese Formel nicht einfach nach rechts kopieren kann.

    Ich hoffe ich konnte mein Problem jetzt verdeutlichen. Ist halt nicht mein Tages Geschäft.

    Das mitgeschickte Foto sollte nur meine Frage veranschaulichen.



    Gruß

    Sebastian
     
    Sebastian_braucht_Hilfe, 4. Dezember 2020
    #5
  6. steve1da Super-Moderator
    Hola,

    meine Formel macht genau das was sie soll. Sie lässt sich auch wunderbar nach rechts kopieren. Auch werden nur die jeweils 3 Zellen geprüft, das erledigt die Rest() Funktion.
    Was du mit " macht nicht was sie soll" kann ich leider nicht erraten. Ein Bildchen einer Datei mit völlig anderen Bereichen hilft auch nicht weiter. Eine Exceldatei in der du händisch ein Wunschergebnis einträgst könnte helfen.

    Gruß,
    steve1da
     
    steve1da, 4. Dezember 2020
    #6
  7. Hallo steve1da,

    ich muss mich entschuldigen. Mir ist beim kopieren und umstellen ein Fehler unterlaufen.

    Deine Formel macht das was sie soll und wie ich es mir wünsche!!! Vielen Danke für deine Mühe und Geduld!!

    Gruß

    Sebastian
     
    Sebastian_braucht_Hilfe, 4. Dezember 2020
    #7
Thema:

Formel kopieren Indirekt

Die Seite wird geladen...
  1. Formel kopieren Indirekt - Similar Threads - Formel kopieren Indirekt

  2. Formel kopieren, wenn Bedingung erfüllt

    in Microsoft Excel Hilfe
    Formel kopieren, wenn Bedingung erfüllt: Hallo, ich als VBA Neuling suche ein Makro, mit dem ich eine Formel in mehrere Zellen kopieren kann, wenn eine bestimme Bedingung erfüllt ist. Dazu habe ich eine Tabelle, die bei Zeile A1 losgeht...
  3. Formel mit Bezug plus 1 zum kopieren

    in Microsoft Excel Hilfe
    Formel mit Bezug plus 1 zum kopieren: Guten Morgen, ich habe folgendes Problem: Tabelle1, Zelle C3, Formel =Tabelle2!A1 Tabelle1, Zelle C11; Formel =Tabelle2!A2 usw. Ich möchte die Formel in Tabelle1 kopieren und der Bezug in...
  4. Excel VBA oder nur Excel Formel

    in Microsoft Excel Hilfe
    Excel VBA oder nur Excel Formel: Hallo zusammen, ich habe ein folgendes Problem: ich will eine Excel Formel aufstellen in dem es kontrolliert ob diese Name in der Tabelle2 vorhanden ist, falls es vorhanden ist soll es die ganzen...
  5. Datum in Formel fortlaufend kopieren

    in Microsoft Excel Hilfe
    Datum in Formel fortlaufend kopieren: Hallo liebe Community, ich habe folgendes Problem. Ich möchte folgende Formel im Grunde für jeden Tag im Jahr kopieren und er soll mir Einträge zu dem Datum zählen....
  6. Mehrere Zellen kopieren anhand eines Kürzels

    in Microsoft Excel Hilfe
    Mehrere Zellen kopieren anhand eines Kürzels: Hallo zusammen, nachdem meine Suche auch nach einiger Geduld keine für mich verständlichen Erfolge brachte, wende ich mich nun mal direkt an die Profis hier. Ich habe eine Tabelle mit einem...
  7. Office 2013 : Formel kopieren

    in Microsoft Excel Hilfe
    Office 2013 : Formel kopieren: Moin Moin Ich habe eine Frage zum kopieren bzw "runterziehen" von Formeln. Ich moechte in zelle A1 : =ANZAHL2(Abrechnung!C2:C200) A2 : =ANZAHL2(Abrechnung!d2:d200) A3 :...
  8. Ergebnis einer Formel aus Tabelle1 per VBA in 1. freie Zeile von Tabelle2 kopieren

    in Microsoft Excel Hilfe
    Ergebnis einer Formel aus Tabelle1 per VBA in 1. freie Zeile von Tabelle2 kopieren: Hallo und guten Morgen. Ich wurschtel mich gerade mal wieder durch den VBA schungel. Ich habe folgenden Code versucht: Sheets("Tänzerkontos").Select Range("F8").Select Selection.Copy...