Office: Formeln

Helfe beim Thema Formeln in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallöle, bin gerade auf euer schönes Forum gestossen, auf der Suche nach Hilfe... Also, ich möchte folgendes machen, bin mir aber nicht sicher, ob... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von roadrunner, 5. Juli 2005.

  1. roadrunner Neuer User

    Formeln


    Hallöle,
    bin gerade auf euer schönes Forum gestossen, auf der Suche nach Hilfe...

    Also, ich möchte folgendes machen, bin mir aber nicht sicher, ob das schwierig ist oder einfach... :

    Ich habe 3 Variablen, jede dieser Variablen hat verschiedene Klassen (z.B. 1, 2, 3 usw.). Ich möchte nun Abfragen folgender Art machen: Wenn Variable 1 liegt zwischen Wert X und Y und Variable 2 liegt zwischen Wert A und B und Variable 3 liegt zwischen Wert C und D, dann rechne z.B. Variable 1 * Variable 2 * Variable 3, ansonsten schreibe keinen Wert in die betreffende Zelle. Dazu kommt noch, dass die Werte noch varriieren, also Wenn aber Varibale 1 liegt zwischen M und N und Variable 2 zwischen...., dann mache dies und jenes...

    geht das überhaupt alles mit einer Formel bzw. in eine Zelle???

    vielen Dank und viele Grüße :-D
    Roadrunner
     
    roadrunner, 5. Juli 2005
    #1
  2. Michael
    Michael Administrator
    Hallo Roadrunner,

    ja das müsste gehen. Dazu kannst Du denke ich eine verschachtelte Wenn-Funktion benutzen, das heißt mehrere Wenn-Funktionen ineinander schreiben. Schau mal in unsere Tutoriums-Sektion, da steht eine Beschreibung der Wenn-Formel. Wenn Du nicht weiter kommst einfach nochmal posten.

    Gruß
    Michael
     
    Michael, 5. Juli 2005
    #2
  3. roadrunner Neuer User
    Hallo Michael,
    sorry, komme irgendwie nicht weiter...
    Kannst du mir viell. ein kurzes Beispiel für eine geschachtelte WENN-Funktion aufschreiben??? (am besten wie von mir oben beschrieben, also z.B. Wenn Var. 1 = A und Var. 2 = B und Var. 3 = C, dann schreibe "1" und wenn Var. 1= D und Var. 2 = D und Var. 3 = E, dann schreibe "2" und wenn... usw.)

    Danke und viele Grüße
    Roadrunner
     
    roadrunner, 5. Juli 2005
    #3
  4. roadrunner Neuer User

    Formeln

    Hallo Michael,
    ich habe jetzt mal eine Formel geschrieben (wenn auch mit einem etwas anderen Zweck wie vorher beschrieben). Mir erscheint alles sinnvoll, nur Excel meldet immer wieder Fehler (viell. liegt es an den Klammern??):

    =+WENN(ODER(B6="Ss";B6="Sl2";B6="Su2";B6="St2");"1";
    WENN(ODER(B6="Sl3";B6="Sl4";B6="Su3";B6="Su4";B6="St3");"2";
    WENN(B6="Ls4";"3";WENN(ODER(B6="Slu";B6="Ls2");"4";
    WENN(ODER(B6="Us";B6="Uls";B6="Ls3");"5";
    WENN(ODER(B6="Uu";B6="Ut2";B6="Ut3");"6";
    WENN(ODER(B6="Lu";B6="Ut4";B6="Tu4");"7";
    WENN(B6="Tu3";"8";WENN(ODER(B6="Lt2";B6="Lts");"9";
    WENN(ODER(B6="Tt";B6="Tl";B6="Tu2");"10";""))))))))))


    viele Grüße
    Daniel
     
    roadrunner, 5. Juli 2005
    #4
  5. Michael
    Michael Administrator
    Hallo Roadrunner,

    ich denke der Fehler ist klar. Du überforderst Excel. Ich glaube man kann nur 7 oder acht Funktionen ineinander schachteln. Du hast mehr als das wenn ich richtig gezählt habe. Das kann Excel nicht.

    Hier noch ein Beispiel

    =WENN(A1=1;WENN(A2=1;WENN(A3=1;1;"");"");"")

    Die Formel prüft, ob A1, A2 und A3 alle gleich 1 sind. Wenn das der Fall ist wird 1 geschrieben, ansonsten ein Leerzeichen.

    Gruß
    Michael
     
    Michael, 5. Juli 2005
    #5
Thema:

Formeln

Die Seite wird geladen...
  1. Formeln - Similar Threads - Formeln

  2. Prüfen und Verketten von Zellen mit Formeln als Inhalt

    in Microsoft Excel Hilfe
    Prüfen und Verketten von Zellen mit Formeln als Inhalt: Sehr geehrte Damen und Herren, ich möchte in einer Excel Tabelle ca. 72 Zellen miteinander verketten und prüfen, ob diese gefüllt sind, falls manche dieser Zellen leer sind sollen diese aus der...
  3. Übertragung von Formeln in ergänzte Abfragezeilen

    in Microsoft Excel Hilfe
    Übertragung von Formeln in ergänzte Abfragezeilen: Hallo Zusammen, hat hier jemand von einen Lösungsansatz? Die beigefügte Arbeitsmappe enthält 3 Blätter Blatt 1 steht stellvertretend für eine Datenquelle Blatt 2 steht stellvertretend für eine...
  4. Bitte um Hilfe bei Formeln mit mehreren Bedingungen

    in Microsoft Excel Hilfe
    Bitte um Hilfe bei Formeln mit mehreren Bedingungen: Hallo, ich benötige Hilfe bei der Stundenabrechnung für unsere Teilnehmer. Leider kenne ich mich mit Formeln nicht so gut aus. Die Tabelle habe ich angehängt. Ich benötige die Formeln für "gesamt...
  5. Bestimmter Druckbereich plus angehakte Zeilen mit Button drucken

    in Microsoft Excel Hilfe
    Bestimmter Druckbereich plus angehakte Zeilen mit Button drucken: Hallo zusammen. Nachdem ich nun schon intensivst Google bemüht und Freunde gefragt habe und dennoch nicht weiterkomme, hoffe ich bei Euch auf Hilfe. Ich habe eine Preisliste erstellt. Diese...
  6. leere Zelle - anscheinend doch nicht leer

    in Microsoft Excel Hilfe
    leere Zelle - anscheinend doch nicht leer: ich habe - Tabelle A - mit Werten und Daten - Tabelle B - nur Bezüge und Formeln ( beziehen sich auf Tabelle A ) Problem seit kurzem ( bisher ging es jahrelang ohne Probleme ): ( z.B. wird ein...
  7. Zwei "Verweis_Zählenwenn" Formeln verbinden

    in Microsoft Excel Hilfe
    Zwei "Verweis_Zählenwenn" Formeln verbinden: Hallo, ich bekomme meine beiden Formeln einfach nicht in einer Zelle verschachtelt. Die zusammengeführte Formel soll dann in A3 ff stehen. Damit mir aus beiden Tabellen (D:E und G:H) eine Liste...
  8. .xlsm - Formeln werden nicht berechnet

    in Microsoft Excel Hilfe
    .xlsm - Formeln werden nicht berechnet: Hallo zusammen, ich habe eine Arbeitsmappe mit einem kleinen Makro und ein paar "normalen" Berechnungen. Eine davon [...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden