Office: Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert

Helfe beim Thema Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo an alle! leider muss ich dringend eine Excel zur Abrechnung eines KFZ Fuhrparks erstellen. Vorweg ich bin ein Excel Anfänger. Aufgrund... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von Jagsome, 19. Dezember 2020.

  1. Jagsome Neuer User

    Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert


    Hallo an alle!

    leider muss ich dringend eine Excel zur Abrechnung eines KFZ Fuhrparks erstellen.
    Vorweg ich bin ein Excel Anfänger.

    Aufgrund ändernder Formeln für die Berechnung habe ich in verschiedenen Spalten einer Tabelle die Steuern ab 01.10.2020 ; 01.01.2021; 01,01,2022;01.01.2023 und 01.01.2024 berechnet.
    In dem Feld wo die Steuer aus der jeweiligen Spalte ausgegeben werden soll habe ich diese geschachtelte Formel gebastelt

    =WENN([@Anmeldung]<=DATUM(2020;9;30);[@[MVSt vor 30.9.2020]];WENN([@Anmeldung]>=DATUM(2020;10;1);[MVSt ab 01.10.2020]*12;WENN([@Anmeldung]>=DATUM(2021;1;1);[MVSt ab 01.01.2021]*12;WENN([@Anmeldung]>=DATUM(2022;1;1);[MVSt ab 01.01.2022]*12;WENN([@Anmeldung]>=DATUM(2023;1;1);[MVSt ab 01.01.2023]*12;WENN([@Anmeldung]>=DATUM(2024;1;1);[MVSt ab 01.01.2024];"Fehler"))))))

    Nun wird aber nur richtige Werte für ein Datum vor dem 30.9.2020 und nach dem 01.10.2020 ausgegeben - bei allen anderen Daten nach dem 01.10.2020 verändert er diesen Wert nicht mehr.

    Vorweg schon jedem der mir hier helfen möchte/kann großen Dank!
     
  2. Hajo_Zi
    Hajo_Zi Erfahrener User
    Zu Deiner Datei kann ich nichts schreiben, was wohl daran liegt das ich nicht auf fremde Rechner schaue. Ich baue keine Datei nach.

    Sollte die Datei verlinkt werden?

    Der Name einer hochgeladenen Mappe wird im Beitrag automatisch angezeigt, sodass es bei Verwendung von aussagekräftigen Namen leichter fällt, sie später im Ablageordner wiederzufinden und sie gedanklich einem bestimmten Thema zuzuordnen. Namen wie Muster*, Test*, Mappe*, Beispiel*, Fehler*, Kalender*, UserForm* usw. sind so allgemein, dass eine Zuordnung zu einem Thema unmöglich gemacht wird.

    Bilder lade ich mir nicht runter, da Excel damit nichts anfangen kann.

    Hochgeladene Bilder können zwar als solche in Excel importiert werden, sind jedoch bei der Lösung von Problemen nicht sehr hilfreich, da man die eigentlichen Daten nicht ohne große und zeitraubende Umwege direkt in die Tabelle übertragen kann.

    Bilder statt Datei | Excel ist sexy!

    Es sollte ein aussagekräftiger Name sein.

    Das ist nur meine Meinung zu dem Thema.

    Wenn du an Stelle einer Demomappe deine Originalmappe hochladen willst, diese aber sensible Daten enthält, kannst du diese Daten
    Hinweis - Anonymisierung und Pseudonymisierung von Beispielmappen - MS-Office-Forum
    ändern.

    Das ist nur meine Meinung zu dem Thema.

    Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert GrußformelHilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert Homepage
     
  3. Beverly
    Beverly Erfahrener User
    Hi,

    müsste deine Formel nicht nach diesem Prinzip aufgebaut sein:

    =WENN(UND(Anmeldung>=DATUM(2020;9;1);Anmeldung<=DATUM(2020;9;30));.....

    Denn das Datum soll ja zwischen dem Monatsersten und Monatsletzten liegen - oder sehe ich das falsch?



    Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert GrußformelHilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert Beverly's Excel - Inn
     
  4. Jagsome Neuer User

    Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert

    Hallo Beverly , danke für die nachricht - ich schau mir das kurz an was das UND ist - sieht aber gut aus :D
     
  5. Jagsome Neuer User
    Naja "nein" das es gibt 5 varianten - vor 30.02020, nach 01.10.2020, nach 01.01.2021, nach 01.01.2022, nach 01.01.23, nach 01.01.2024
     
  6. Beverly
    Beverly Erfahrener User
    Gut, mein Beispiel ist vielleicht nicht ganz korrekt, da ich mich auf den Monat Novenber bezogen habe - das liegt aber einfach daran, dass es recht kompliziert ist, wenn die entsprechende Mappe nicht vorliegt und man den genauern Tabellenaufbau nicht sieht. Aber: wenn ich das logisch betrachte, dann ist es doch so, dass außer dem Datum vor 30.09.2020 die anderen Vergleiche jeweils zwischen 2 Datumswerten liegen und in dem Fall ist der UND-Vergleich korrekt.


    Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert GrußformelHilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert Beverly's Excel - Inn
     
  7. Jagsome Neuer User
    Da die Originaltabelle riesig ist habe ich den wesentlichen Teil als Muster dargestellt - siehe Anhang - würdest du dir das kurz ansehen ?
     
  8. PAN
    Pan User

    Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert

    Ich wäre viel zu faul für die Menge an WENN(); statt dessen würde ich mit einer Kombination aus VERGLEICH() und INDEX() arbeiten und bei VERGLEICH den Typ auf 1 setzen. Beispiel im Anhang, lässt sich auch besser warten.

    Pan
     
  9. steve1da Super-Moderator
    Hola,

    lass mal die Texte bei den Datumswerten in D1 bis I1 weg so dass da nur die reinen Datumswerte stehen. Dann:
    =WVERWEIS(B2;$D$1:$I$2;2)
    Gruß,
    steve1da
     
    steve1da, 19. Dezember 2020
    #9
  10. Jagsome Neuer User
    Hi, vielen Dank für den Input - leider sind das keine fixen steuersätze sonder wieder "WENN FORMELN" für die verschiedenen Zeiträume/ Daten

    !Habs aber jetzt gelöst ; hatte die wenn verschachtelung verkehrt (beginnend mit dem kleinsten Prüfwert/Datum) aufgebaut - anders rum hats jetzt funktioniert - dennoch vielen Dank für den Input
     
  11. PAN
    Pan User
    Das macht auch keinen Unterschied, da du mehr als einen Parameter aus der Tabelle abrufen und im Worst Case sogar mit INDIRECT arbeiten kannst. Alternativ kannst du zur besseren Lesbarkeit mit WENNS() arbeiten.

    Pan
     
Thema:

Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert

Die Seite wird geladen...
  1. Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert - Similar Threads - Hilfe geschachtelte Formel

  2. Hilfe bei fertigstellung (mehrere "Probleme")

    in Microsoft Excel Hilfe
    Hilfe bei fertigstellung (mehrere "Probleme"): Hallo zusammen, ich arbeite nun schon etwas an dieser Datei und komme jetzt nicht mehr weiter (wahrscheinlich, weil es langsam zu viel für ein ungeschultes Auge wird und ich wie gesagt ungeschult...
  3. Hilfe bei Erstellung eines Zeugnisformulars (Bereichsbreite; Unterstreichungen)

    in Microsoft Access Hilfe
    Hilfe bei Erstellung eines Zeugnisformulars (Bereichsbreite; Unterstreichungen): Hallo an alle und schon einmal vielen Dank, dass ihr den Thread überhaupt angeklickt habt. Vorweg: Ich bin absoluter Anfänger in Sachen Access und habe von Programmierung überhaupt keine Ahnung....
  4. Hilfe beim Datenbankenmodell

    in Microsoft Access Hilfe
    Hilfe beim Datenbankenmodell: Hallo Zusammen, ich gehe der Community hier schon seit zwei Wochen mit nicht richtigen Ideen auf den Zeiger. Damit das aufhört habe ich nochmals versucht mein Datenbankenmodell durch Eure...
  5. Benötige sehr variables Makro

    in Microsoft Excel Hilfe
    Benötige sehr variables Makro: Hallo zusammen, Ich benötige Hilfe für ein Makro wo ich nicht weiter komme.... Das Makro muss folgendes „Können“: 1. Seite „Tourenplan“ auswählen 2. Spalte B soll kopiert werden aber nur wenn...
  6. Hilfe bei Pivot

    in Microsoft Excel Hilfe
    Hilfe bei Pivot: Hallo zusammen, ich habe eine Frage zu Pivot, hoffe dass mir hier jemand helfen kann...(bzw. bin mir da sicher [IMG] ) ich habe eine Tabelle mit folgenden Daten: [ATTACH] Unter "Kontaktart"...
  7. Berechnung Zeitdifferenz

    in Microsoft Excel Hilfe
    Berechnung Zeitdifferenz: Hallo Ihr Lieben, ich habe folgendes Problem und ich komme nicht weiter. Ich möchte die Differenz dieser beiden Daten berechnen, allerdings funktioniert die Formel nicht so wie ich das möchte. er...
  8. Text wird während des Schreibens oder bei Absatzschaltung ausgeblendet

    in Microsoft Word Hilfe
    Text wird während des Schreibens oder bei Absatzschaltung ausgeblendet: Hallo zusammen! Ich habe folgendes Problem: Während ich in Word (Office 365) auf meinem Macbook schreibe, werden Teile des Textes (auch etwaiger Tabellen) ausgeblendet (verschwinden). Während ich...