Office: Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert

Helfe beim Thema Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo an alle! leider muss ich dringend eine Excel zur Abrechnung eines KFZ Fuhrparks erstellen. Vorweg ich bin ein Excel Anfänger. Aufgrund... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von Jagsome, 19. Dezember 2020.

  1. Jagsome Neuer User

    Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert


    Hallo an alle!

    leider muss ich dringend eine Excel zur Abrechnung eines KFZ Fuhrparks erstellen.
    Vorweg ich bin ein Excel Anfänger.

    Aufgrund ändernder Formeln für die Berechnung habe ich in verschiedenen Spalten einer Tabelle die Steuern ab 01.10.2020 ; 01.01.2021; 01,01,2022;01.01.2023 und 01.01.2024 berechnet.
    In dem Feld wo die Steuer aus der jeweiligen Spalte ausgegeben werden soll habe ich diese geschachtelte Formel gebastelt

    =WENN([@Anmeldung]<=DATUM(2020;9;30);[@[MVSt vor 30.9.2020]];WENN([@Anmeldung]>=DATUM(2020;10;1);[MVSt ab 01.10.2020]*12;WENN([@Anmeldung]>=DATUM(2021;1;1);[MVSt ab 01.01.2021]*12;WENN([@Anmeldung]>=DATUM(2022;1;1);[MVSt ab 01.01.2022]*12;WENN([@Anmeldung]>=DATUM(2023;1;1);[MVSt ab 01.01.2023]*12;WENN([@Anmeldung]>=DATUM(2024;1;1);[MVSt ab 01.01.2024];"Fehler"))))))

    Nun wird aber nur richtige Werte für ein Datum vor dem 30.9.2020 und nach dem 01.10.2020 ausgegeben - bei allen anderen Daten nach dem 01.10.2020 verändert er diesen Wert nicht mehr.

    Vorweg schon jedem der mir hier helfen möchte/kann großen Dank!
     
  2. Hajo_Zi
    Hajo_Zi Erfahrener User
    Zu Deiner Datei kann ich nichts schreiben, was wohl daran liegt das ich nicht auf fremde Rechner schaue. Ich baue keine Datei nach.

    Sollte die Datei verlinkt werden?

    Der Name einer hochgeladenen Mappe wird im Beitrag automatisch angezeigt, sodass es bei Verwendung von aussagekräftigen Namen leichter fällt, sie später im Ablageordner wiederzufinden und sie gedanklich einem bestimmten Thema zuzuordnen. Namen wie Muster*, Test*, Mappe*, Beispiel*, Fehler*, Kalender*, UserForm* usw. sind so allgemein, dass eine Zuordnung zu einem Thema unmöglich gemacht wird.

    Bilder lade ich mir nicht runter, da Excel damit nichts anfangen kann.

    Hochgeladene Bilder können zwar als solche in Excel importiert werden, sind jedoch bei der Lösung von Problemen nicht sehr hilfreich, da man die eigentlichen Daten nicht ohne große und zeitraubende Umwege direkt in die Tabelle übertragen kann.

    Bilder statt Datei | Excel ist sexy!

    Es sollte ein aussagekräftiger Name sein.

    Das ist nur meine Meinung zu dem Thema.

    Wenn du an Stelle einer Demomappe deine Originalmappe hochladen willst, diese aber sensible Daten enthält, kannst du diese Daten
    Hinweis - Anonymisierung und Pseudonymisierung von Beispielmappen - MS-Office-Forum
    ändern.

    Das ist nur meine Meinung zu dem Thema.

    Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert GrußformelHilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert Homepage
     
  3. Beverly
    Beverly Erfahrener User
    Hi,

    müsste deine Formel nicht nach diesem Prinzip aufgebaut sein:

    =WENN(UND(Anmeldung>=DATUM(2020;9;1);Anmeldung<=DATUM(2020;9;30));.....

    Denn das Datum soll ja zwischen dem Monatsersten und Monatsletzten liegen - oder sehe ich das falsch?



    Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert GrußformelHilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert Beverly's Excel - Inn
     
  4. Jagsome Neuer User

    Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert

    Hallo Beverly , danke für die nachricht - ich schau mir das kurz an was das UND ist - sieht aber gut aus :D
     
  5. Jagsome Neuer User
    Naja "nein" das es gibt 5 varianten - vor 30.02020, nach 01.10.2020, nach 01.01.2021, nach 01.01.2022, nach 01.01.23, nach 01.01.2024
     
  6. Beverly
    Beverly Erfahrener User
    Gut, mein Beispiel ist vielleicht nicht ganz korrekt, da ich mich auf den Monat Novenber bezogen habe - das liegt aber einfach daran, dass es recht kompliziert ist, wenn die entsprechende Mappe nicht vorliegt und man den genauern Tabellenaufbau nicht sieht. Aber: wenn ich das logisch betrachte, dann ist es doch so, dass außer dem Datum vor 30.09.2020 die anderen Vergleiche jeweils zwischen 2 Datumswerten liegen und in dem Fall ist der UND-Vergleich korrekt.


    Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert GrußformelHilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert Beverly's Excel - Inn
     
  7. Jagsome Neuer User
    Da die Originaltabelle riesig ist habe ich den wesentlichen Teil als Muster dargestellt - siehe Anhang - würdest du dir das kurz ansehen ?
     
  8. PAN
    Pan User

    Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert

    Ich wäre viel zu faul für die Menge an WENN(); statt dessen würde ich mit einer Kombination aus VERGLEICH() und INDEX() arbeiten und bei VERGLEICH den Typ auf 1 setzen. Beispiel im Anhang, lässt sich auch besser warten.

    Pan
     
  9. steve1da Super-Moderator
    Hola,

    lass mal die Texte bei den Datumswerten in D1 bis I1 weg so dass da nur die reinen Datumswerte stehen. Dann:
    =WVERWEIS(B2;$D$1:$I$2;2)
    Gruß,
    steve1da
     
    steve1da, 19. Dezember 2020
    #9
  10. Jagsome Neuer User
    Hi, vielen Dank für den Input - leider sind das keine fixen steuersätze sonder wieder "WENN FORMELN" für die verschiedenen Zeiträume/ Daten

    !Habs aber jetzt gelöst ; hatte die wenn verschachtelung verkehrt (beginnend mit dem kleinsten Prüfwert/Datum) aufgebaut - anders rum hats jetzt funktioniert - dennoch vielen Dank für den Input
     
  11. PAN
    Pan User
    Das macht auch keinen Unterschied, da du mehr als einen Parameter aus der Tabelle abrufen und im Worst Case sogar mit INDIRECT arbeiten kannst. Alternativ kannst du zur besseren Lesbarkeit mit WENNS() arbeiten.

    Pan
     
Thema:

Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert

Die Seite wird geladen...
  1. Hilfe! geschachtelte Wenn/Dann Formel mit Datum als Prüfwert - Similar Threads - Hilfe geschachtelte Formel

  2. Formel in Makro integrieren

    in Microsoft Excel Hilfe
    Formel in Makro integrieren: Hallo Zusammen, ich habe in einem Tabellenblatt "Aufträge" ein Makro, mit dem ich die Spalten einer Zeile nacheinander befüllen kann. Außerdem werden die Informationen aus den Spalten am Ende in...
  3. Hilfe bei Personalplanung (ROT/GRÜNER Hintergrund zu 1/0 ändern)

    in Microsoft Excel Hilfe
    Hilfe bei Personalplanung (ROT/GRÜNER Hintergrund zu 1/0 ändern): Liebe Community, ich bräuchte etwas Hilfe bei der Umsetzung meiner Personalplanung. Es geht sich um folgendes Problem: Gerne würde ich die ,,grün hinterlegten Felder'' durch die Zahl ,,1''...
  4. Auswahlmenü in Formularen erstellen & speichern mehrerer Datensätze

    in Microsoft Access Hilfe
    Auswahlmenü in Formularen erstellen & speichern mehrerer Datensätze: Hallo zusammen, Ich melde mich bezüglich folgenden Sachverhaltes: Ziel unserer Access-Anwendung ist es: Übergabeprotokoll und Rückgabeprotokoll für Technik zu erstellen! Was haben wir bereits:...
  5. Excel Noob sucht Hilfe - einfaches Filtern

    in Microsoft Excel Hilfe
    Excel Noob sucht Hilfe - einfaches Filtern: Hallo, anbei habe ich eine recht simple Tabelle, die ich für einige Kollegen älteren Semesters bearbeiten muss. Ich möchte bloss die Daten nach den Merkmalen in den Spalten G-J filtern. Meine...
  6. ich bräuchte Hilfe bei Office Produkten bitte

    in Sonstiges
    ich bräuchte Hilfe bei Office Produkten bitte: Hallo ich hätte Fragen zu Office Ich habe einen Computer 1 mit Win 7 und Office 2010 Und einen Computer 2 mit Win 10 und Office 2019 Jetzt kommt dauernd bei meinem Office 2019 / Word die...
  7. So Neu und unerfahren

    in Microsoft Excel Hilfe
    So Neu und unerfahren: Hallo und einen schönen guten Tag, ich bräuchte mal unterstützung von enem Profi in Exel. Unter Arb 2021 im Monat 8 stimmt das Endergebnis nicht mehr und ich kann es mir nicht erklären. Habe das...
  8. Hilfe benötigt

    in Microsoft Excel Hilfe
    Hilfe benötigt: Guten Tag, Ich sitze gerade an einem Problem bei dem ich einen Zeitlichen Durchschnittswert ermitteln muss. Ich hatte schonmal ein Thema eröffnet aber es wahrscheinlich zu kompliziert...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden