Office: Mathematisches Runden (Banker's Rounding) ohne VBA

Helfe beim Thema Mathematisches Runden (Banker's Rounding) ohne VBA in Microsoft Excel Tutorials um das Problem gemeinsam zu lösen; im Gegensatz zum normalen "kaufmännischen Runden": =WENN(ISTGERADE(A1/1%)*(REST(A1/1%;1)<=0,5);ABRUNDEN(A1;2);RUNDEN(A1;2)) Quelle, abgewandelt auf... Dieses Thema im Forum "Microsoft Excel Tutorials" wurde erstellt von lupo1, 13. August 2021.

  1. lupo1
    lupo1 Tutorial Guru

    Mathematisches Runden (Banker's Rounding) ohne VBA


    im Gegensatz zum normalen "kaufmännischen Runden":

    =WENN(ISTGERADE(A1/1%)*(REST(A1/1%;1)<=0,5);ABRUNDEN(A1;2);RUNDEN(A1;2))


    Quelle, abgewandelt auf Cent:
    Banker's rounding formula in Excel

    Am Beispiel erläutert:

    Zahl ... wird zu
    5,465 5,46
    5,475 5,48
    5,485 5,48
    5,495 5,50


    Rein statistisch ist das Landen bei einem halben Cent unrelevant, da stetig mit einer Wkt. von Null. Im realen Leben ist es aber so, dass viele Betrags-Summen nur durch 2 geteilt werden, und dann würde der halbe Cent immer nur gleich gerundet, je nach verwendeter Rundungsvorschrift. Und das kann systematisch einer Bank eben nicht schmecken. Ein genau halber Cent ist nämlich außerordentlich "diskret gewichtig, mit hoher Wahrscheinlichkeit", so dass man ihn deswegen hälftig nach oben und nach unten runden muss.

    Bei VBA gibt es daher die EIGENE Funktion Round(), die math./bankermäßig wie oben rundet.

    Die Excelfunktion RUNDEN wird in VBA hingegen als WorksheetFunction.Round() verwendet (kfm. Runden wie gewohnt).

    Angeregt durch: Bankers Rounding bei Prozentwerten
     
    Zuletzt bearbeitet: 13. August 2021
Thema:

Mathematisches Runden (Banker's Rounding) ohne VBA

Die Seite wird geladen...
  1. Mathematisches Runden (Banker's Rounding) ohne VBA - Similar Threads - Mathematisches Runden Banker's

  2. Mathematische und trigonometrische Funktionen (Referenz)

    in Microsoft Excel Tutorials
    Mathematische und trigonometrische Funktionen (Referenz): Mathematische und trigonometrische Funktionen (Referenz) Excel für Microsoft 365 Excel für Microsoft 365 für Mac Excel für das Web Excel 2019 Excel 2016...
  3. Einfügen mathematischer Symbole

    in Microsoft Word Tutorials
    Einfügen mathematischer Symbole: Einfügen mathematischer Symbole Word für Microsoft 365 Word 2019 Word 2016 Word 2013 Word 2010 Word 2007 Mehr... Weniger...
  4. Mathematische Berechnung der Potenz-Trendlinie

    in Microsoft Excel Hilfe
    Mathematische Berechnung der Potenz-Trendlinie: Hallo zusammen! Ich habe einen Zusammenhang zwischen zwei Variablen hergestellt, der durch eine Trendlinie am besten als Potenz dargestellt werden kann. y = b * x^c Die Werte für die Konstanten...
  5. Ändern der handschriftlichen Freihandeingabe in Formen, Text oder Mathematik in PowerPoint ...

    in Microsoft PowerPoint Tutorials
    Ändern der handschriftlichen Freihandeingabe in Formen, Text oder Mathematik in PowerPoint ...: Ändern der handschriftlichen Freihandeingabe in Formen, Text oder Mathematik in PowerPoint für Microsoft 365 PowerPoint für Microsoft 365 PowerPoint für Microsoft 365 für Mac...
  6. Befüllung einer Matrix (mathematisches Problem?)

    in Microsoft Excel Hilfe
    Befüllung einer Matrix (mathematisches Problem?): Hallo Ihr Lieben, ich hab mich hier angemeldet, weil ich seit Tagen an einem Problem rumdoktere und auf keinen grünen Zweig komme. Vielleicht wisst Ihr ja eine Lösung. Es geht um folgende...
  7. Mathematische AutoKorrektur in Word 2011: Tabulatoren nutzen?

    in Microsoft Word Hilfe
    Mathematische AutoKorrektur in Word 2011: Tabulatoren nutzen?: Hallo zusammen! Ich möchte mit Word 2011 (Mac) eine mathematische Formelsammlung schreiben. Das funktioniert auch prächtig - dank der mathematischen AutoKorrektur. Etwas habe ich allerdings...
  8. Mathematische Symbole!!!

    in Microsoft Word Hilfe
    Mathematische Symbole!!!: hi leute ich war gerade dabei meinen Praktikumsbericht zu schreiben bis ich das symbol für die multiplikation benötigte.da ich nicht wusste, dass es so kompliziert sein würde habe ich mir nichts...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden