Office: Mittelwert aus verschiedenen Werten - automatische Formel

Helfe beim Thema Mittelwert aus verschiedenen Werten - automatische Formel in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Servus miteinander und einen schönen Frühlingsanfang! Sorry erstmal für den ungenauen Titel, ich weiß einfach nicht wie ich das besser beschreiben... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von max87, 15. April 2013.

  1. max87 Erfahrener User

    Mittelwert aus verschiedenen Werten - automatische Formel


    Servus miteinander und einen schönen Frühlingsanfang!

    Sorry erstmal für den ungenauen Titel, ich weiß einfach nicht wie ich das besser beschreiben soll Mittelwert aus verschiedenen Werten - automatische Formel :confused:

    Habe folgendes Problem:

    In der Spalte A ist in verschiedensten Zeilen jeweils der Text "Endergebnis" vorhanden, in der Zelle daneben, also jeweils in der Spalte B ein entsprechender Prozentwert.

    BSP:
    In den Zellen A1, A46, A49, A123, A189 steht jeweils "Endergebnis", in den Zellen B1, B46, B49, B123, B189 verschiedene Prozentsätze.

    Ich möchte nun in ein einer Zelle den Mittelwert dieser Prozentwerte ermitteln.
    Klar, manuell mit Mittelwertfunktion wäre easy, da sich die Tabelle aber ständig erweitert, möchte ich gerne eine Formel nutzen, die mir automatisch den Mittelwert aller Werte 1 Zelle rechts von "Endergebnis" ausspuckt. Dachte erst an sverweis, die findet aber ja nur immer den ersten oder nächsten Wert.

    Bin bei diesem sonnigen Wetter nun seit 2 Stunden damit beschäftigt mir eine Lösung aus den Fingern zu ziehen... Habt ihr eine Idee?

    Mit sonnigen Grüßen


    Max


    PS: Excel Professional 2010, Win 7
     
  2. Beverly
    Beverly Erfahrener User
    Hi Max,

    eine Möglichkeit:

    =SUMMEWENNS(A1:A200;B1:B200;"Endergebnis")/ZÄHLENWENN(B1:B200;"Endergebnis")

    Bis später,
    Karin
     
    Beverly, 15. April 2013
    #2
  3. max87 Erfahrener User
    Hi Karin,

    danke für die schnelle Antowrt.

    Bei Eingabe der Formel bekomme ich ein #DIV/0! Fehler.

    Hätte ich erwähnen sollen, dass in der Spalte A in den restlichen Zellen, die nicht "Endergebnis" enthalten, teils Leerzellen, teils andere Texte und Zahlen eingegeben werden?

    LG Max
     
  4. Beverly
    Beverly Erfahrener User

    Mittelwert aus verschiedenen Werten - automatische Formel

    Hi Max,

    ich kenne deine Arbeitsmappe nicht, aber in meiner nachgebauten kommt der Fehler nur, wenn in Spalte B nirgendwo "Endergebnis" drin steht, denn dann ist ZÄHLENWENN() = 0 und Division durch 0 ergibt den Fehler #DIV/0! Das kann man aber umgehen, indem man noch einen Vergleich macht, ob die Division einen Fehlerwert ergibt:

    =WENN(ISTFEHLER(SUMMEWENNS(A1:A15;B1:B15;"Endergebnis")/ZÄHLENWENN(B1:B15;"Endergebnis"));"";SUMMEWENNS(A1:A15;B1:B15;"Endergebnis")/ZÄHLENWENN(B1:B15;"Endergebnis"))

    Bis später,
    Karin
     
    Beverly, 15. April 2013
    #4
  5. max87 Erfahrener User
    Hi Karin!

    Super, funktioniert prächtig! Vielen lieben Dank!

    Vielleicht hab ich es etwas falsch erklärt, "Endergebnis" steht nicht in den Zellen der Spalte B sondern der Spalte A!

    Habe bei deiner Formel also jeweils den a-Bereich und b-bereich vertauscht, jetzt funktioniert es!

    Danke nochmal vielmals!

    LG Max
     
Thema:

Mittelwert aus verschiedenen Werten - automatische Formel

Die Seite wird geladen...
  1. Mittelwert aus verschiedenen Werten - automatische Formel - Similar Threads - Mittelwert verschiedenen Werten

  2. Mittelwert ohne Null; zu viele Argumente

    in Microsoft Excel Hilfe
    Mittelwert ohne Null; zu viele Argumente: Edit: Lösung gefunden:...
  3. Mittelwert berechnen

    in Microsoft Excel Hilfe
    Mittelwert berechnen: Servus ich würde gerne für die Arbeit eine Tabelle ermitteln die mir den Stundenlohn inkl. Trinkgeld abgibt. Dies soll alles ab K3 abgegeben werden. K wird wie folgt bestimmt: Stundenanzahl...
  4. Notetabelle mit Dropdown Menü und Gewichtungen mit Prozenten

    in Microsoft Excel Hilfe
    Notetabelle mit Dropdown Menü und Gewichtungen mit Prozenten: Liebe Alle Leider bin ich ein Excel Banause und komme nicht weiter... Wir Lehrer haben vom Kanton eine Notentabelle bekommen und ich möchte diese anpassen. Beim Dropdown können wir den...
  5. Mittelwert abhängig des Datums bilden

    in Microsoft Excel Hilfe
    Mittelwert abhängig des Datums bilden: Hallo, ich habe folgendes Problem: ich möchte den Mittelwert abhängig vom Datum bilden. Im folgenden ein Beispiel zu meinem Problem: Datum Wert 02.07.2021 12:08 5...
  6. Dynamischer Mittelwert

    in Microsoft Excel Hilfe
    Dynamischer Mittelwert: Hallo zusammen, ich habe eine Menge Daten pro Tag (143) und möchte nun einen Mittelwert pro Tag errechnen, aber ohne für jeden Tag extra den Mittelwertbereich händisch einzutragen. Tag 1...
  7. Tabelle Mittelwert

    in Microsoft Excel Hilfe
    Tabelle Mittelwert: Hallo Zusammen, in der Tabelle sind in Zeile 4 bis 9 Maschinen eingetragen. In der Zellen C4:Z9 stehen % Werte. In Zeile 10 in den Zellen C10:Z10 wird der Mittelwert eingetragen. Wie bekomme ich...
  8. Mittelwert aus verschiedenen markierten Zellen ermitteln

    in Microsoft Excel Hilfe
    Mittelwert aus verschiedenen markierten Zellen ermitteln: Hallo, ich habe eine riesige Tabelle, in der u.a. eine Spalte ermittelt wird aus Dauer Ein- und Ausgang (also Ausgang z.b. 17.04., Eingang 19.04.2011 = Wert 2, hier Tage). Sind noch keine...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden