Office: (Office 2016) Neue Liste aus ungenauer Suche in Matrix

Helfe beim Thema Neue Liste aus ungenauer Suche in Matrix in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Ich versuche schon länger aus einer Tabelle mit Daten eine neue Liste herauszufiltern mit den Einträgen, die meiner "ungenauen" Suche entsprechen. Im... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von canalier, 23. Juli 2021.

  1. canalier Neuer User

    Neue Liste aus ungenauer Suche in Matrix


    Ich versuche schon länger aus einer Tabelle mit Daten eine neue Liste herauszufiltern mit den Einträgen, die meiner "ungenauen" Suche entsprechen.

    Im Beispiel Sheet würde ich gerne nach "Abdeckblech" suchen. Dann sollte mit im Reiter "Resultat" die Zeilen aufgelistet werden, welche das Wort "Abedeckbelch" beinhaltet. Die Prob lematik ist auch noch dass das gesuchete Wort in verschiedenen Spalten vorkommen kann.

    Kann mir jemand weiterhelfen?
     
    canalier, 23. Juli 2021
    #1
  2. DL_
    DL_ hat Ahnung
  3. Exl121150 Erfahrener User
    Hallo,

    in der beiliegenden Excel-Datei habe ich im Formelmanager die benannte Zelle "Suche" eingefügt:
    Name "Suche" bezieht sich auf =Daten!$C$27 - Dort befindet sich die Zelle mit dem Abfragewert, für den im Arbeitsblatt "Resultat" im Bereich A20 die Abfrageformel für die Textzeilen aus Daten!C1:D24 enthalten sind:
    =WENNFEHLER(INDEX(Daten!$C$1:$C$24 & Daten!$D$1:$D$24; AGGREGAT(15;6;(SUCHEN(Suche;(Daten!$C$1:$C$24 & Daten!$D$1:$D$24))>0) * ZEILE($C$1:$C$24);ZEILE(A1)); 1);"")

    Auf diesen Wert greift dann die Formel der Hilfsspalte Resultat!K20 zu:
    =VERGLEICH($A20;Daten!$C$1:$C$24&Daten!$D$1:$D$24;0)
    Diese Formel liefert die Zeilennr. des Wertes aus Resultat!A20 im Bereich Daten!C1:D24

    Mit dieser Zeilennr. kann dann die ARRAY-Formel im Bereich B20:I20 leicht ermittelt werden: {=WENNFEHLER(INDEX(Daten!$I$1:$P$24;$K20;0);"")}

    Diese 3 Formeln in Zeile 20 des Arbeitsblattes "Resultat" können durch Ziehen leicht in die unterhalb liegenden Zeilen 21-29 kopiert werden.
     
    Exl121150, 24. Juli 2021
    #3
    1 Person gefällt das.
  4. Exl121150 Erfahrener User

    Neue Liste aus ungenauer Suche in Matrix

    Hallo,

    in der beiliegenden Version kommt die Datenabfrage im Arbeitsblatt "Resultat" auch ohne Hilfsspalte aus:
    in Zelle Resultat!A20: =WENNFEHLER(INDEX(Daten!$C$1:$C$24 & Daten!$D$1:$D$24; AGGREGAT(15;6;(SUCHEN(Suche;(Daten!$C$1:$C$24 & Daten!$D$1:$D$24))>0)*ZEILE($C$1:$C$24);ZEILE(A1)); 1);"")

    im Zellbereich Resultat!B20:I20 die ARRAY-Formel: {=WENNFEHLER(INDEX(Daten!$I$1:$P$24;VERGLEICH($A20;Daten!$C$1:$C$24&Daten!$D$1:$D24;0);0);"")}

    Anmerkung: Um die ARRAY-Formel einzugeben, bitte so vorgehen:
    1) Den Zellbereich Resultat!B20:I20 markieren
    2) In die Formeleditierzeile die vorgenannte blau geschriebene Formel eingeben (ohne geschweifte Klammern)
    3) Diese Formeleingabe nicht bloß mit der EINGABE-Taste beenden, sondern mit der Tastenkombination Strg+UMSCHALT+EINGABE (Ctrl+Shift+Enter)
    4) Danach sollte die Formel, wie oben geschrieben, in geschweiften Klammern eingeschlossen erscheinen.
     
    Exl121150, 24. Juli 2021
    #4
    1 Person gefällt das.
  5. canalier Neuer User
    Wow, danke dir vielmals für deinen Aufwand. Hoffe dir hat die Herausforderung Spass gemacht :)

    Das kann ich alles genau so verwenden. Danke nochmals :)
     
    canalier, 27. Juli 2021
    #5
Thema:

Neue Liste aus ungenauer Suche in Matrix

Die Seite wird geladen...
  1. Neue Liste aus ungenauer Suche in Matrix - Similar Threads - Liste ungenauer Suche

  2. Jede Kalenderwoche andere Namen von einer Liste?

    in Microsoft Excel Hilfe
    Jede Kalenderwoche andere Namen von einer Liste?: Hello, ich bräuchte eine Excel Datei, in der mir jedes Jahr alle Kalenderwochen angezeigt werden und pro Kalenderwoche sollte Excel aus einem zweiten Sheet mit einer Namensliste, jede Woche 5...
  3. Listen die die Werte übergeben sollen

    in Microsoft Excel Hilfe
    Listen die die Werte übergeben sollen: Hallo, ich habe in Excel 2016 eine Tabelle erstellt. Aus einen zweiten Tabelle soll dann ein 2 stelliger Batch code aus einer Liste übernommen werden. >>Die Liste hat 2 Spalten in der ersten...
  4. MS Lists

    in Sonstiges
    MS Lists: Hallo zusammen, eventuell hat jemand bereits etwas ähnliches gesehen oder kann mir paar Tips zur Umsetzung geben? Integriert in MSTeams soll der Weg eines/mehrerer Produkte nachverfolgt werden...
  5. Liste nach Datum filtern zerstört auflistung

    in Microsoft Excel Hilfe
    Liste nach Datum filtern zerstört auflistung: Guten Tag, Wir haben eine Liste welche alle Bestellungen beinhaltet. Ich hätte diese Liste gerne auf einem zweiten Blatt gefiltert das nur diesen Monat anzeigt. Leider stimmt dann aber die...
  6. Access Formular aktualisieren durch Dropdown-Liste

    in Microsoft Access Hilfe
    Access Formular aktualisieren durch Dropdown-Liste: Hallo, ich bin ein absoluter Neuling in Access, und bin gerade dabei aus dienstlichen Gründen ein Nachschlagewerk in Access zu erstellen. Ziel des im Screenshot angehängten Formulars soll es...
  7. Text Liste sortieren

    in Microsoft Excel Hilfe
    Text Liste sortieren: Hallo, ich bräuchte dringend eure Hilfe. Ich möchte gerne meine Video-Bibliothek so um ändern das diese für Kodi geeignet ist. Ich habe dafür schon eine passende Excel Tabelle erstellt. Jedoch...
  8. Excel: Namen aus Liste in Tabellenblätter Gruppieren

    in Microsoft Excel Hilfe
    Excel: Namen aus Liste in Tabellenblätter Gruppieren: Guten Tag Ich erhalte jede Woche eine Excel Namensliste mit Projektarbeitsstunden. Ich habe 4 Arbeitsblätter erstellt (Gruppe 1 - 4). Bolti: Gruppe 4 Escher: Gruppe 3 Fassers: Gruppe 1...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden