Office: (Office 2016) ODER in Verbindung mit RECHTS in WENN-Bedingungen

Helfe beim Thema ODER in Verbindung mit RECHTS in WENN-Bedingungen in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Moin zusammen, steh grad auf dem Schlauch. Muss in Spalte A Identnummern auslesen in Abhängigkeit der letzten Ziffer und benutze dazu die folgende... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von ertaa, 1. Juni 2017.

  1. ertaa Erfahrener User

    ODER in Verbindung mit RECHTS in WENN-Bedingungen


    Moin zusammen,

    steh grad auf dem Schlauch. Muss in Spalte A Identnummern auslesen in Abhängigkeit der letzten Ziffer und benutze dazu die folgende Formel:

    =WENN(RECHTS(A1;1)*1=3;1;0)

    Soweit funktioniert alles, allerdings funktioniert die Formel nicht mehr wenn ich mehrere Zahlen mit ODER abfragen will.

    =WENN(RECHTS(A1;1)*1=ODER(3;5;9);1;0)

    Könnt ihr mir auf die Sprünge helfen, wo mein Denkfehler ist?
    Vielen Dank im Voraus
     
    ertaa, 1. Juni 2017
    #1
  2. steve1da Office Guru
    Hola,

    du du kannst das nicht so einfach abfragen, sondern musst die Werte einzeln bestimmen.

    =wenn(oder(rechts(.....);(rechts(......);(rechts(.....));DANN;SONST)

    Gruss,
    steve1da
     
    steve1da, 2. Juni 2017
    #2
  3. lupo1
    lupo1 Tutorial Guru
    =--oder(index(--rechts(a1)={3.5.9};))

    {=--oder(--rechts(a1)={3.5.9})}
     
    Zuletzt bearbeitet: 2. Juni 2017
    lupo1, 2. Juni 2017
    #3
  4. ertaa Erfahrener User

    ODER in Verbindung mit RECHTS in WENN-Bedingungen

    Vielen Dank, funktioniert wie gewollt :)

    =wenn(oder(rechts(..);rechts(..);1;0) hatte ich sogar selber davor getestet, allerdings im Nachhinein einen festen Bezug übersehen, weswegen es bei mir nicht lief.

    Formeln mit "--" hab ich noch nie gesehen, werd ich mich mal einlesen. Wieder was neues gelernt, merci.
     
    ertaa, 2. Juni 2017
    #4
  5. Hi lupo,

    =--oder(--rechts(a1)={3.5.9}) sollte doch eigentlich auch ohne INDEX() und ohne Matrixabschluß funktionieren, oder nich?

    Gruß Jonas
     
    Jonas0806, 2. Juni 2017
    #5
  6. lupo1
    lupo1 Tutorial Guru
    Hast recht. Das enthaltene harte Array ermöglicht es. Stehen 3, 5 und 9 hingegen in A2:A4, dann reicht
    =--oder(--rechts(a1)=A2:A4) nicht aus.

    Und da den Fremdprogrammen Google-Docs, OO und SpreadCE harte Arraybestandteile dafür nicht ausreichen, anders als Excel und Planmaker, tendiere ich dazu, meine beiden Varianten anzubieten.

    Bei Docs gleichermaßen ok:
    =--or(index(--RIGHT(A1;1)=C1:C3;))
    =--or(index(--RIGHT(A1;1)={3;5;9};))
    =arrayformula(--or(--RIGHT(A1;1)=C1:C3))
    =arrayformula(--or(--RIGHT(A1;1)={3;5;9}))


    =--or(--RIGHT(A1;1)={3;5;9})
    =--or(--RIGHT(A1;1)=C1:C3)
    hingegen reichen nicht.
     
    Zuletzt bearbeitet: 2. Juni 2017
    lupo1, 2. Juni 2017
    #6
Thema:

ODER in Verbindung mit RECHTS in WENN-Bedingungen

Die Seite wird geladen...
  1. ODER in Verbindung mit RECHTS in WENN-Bedingungen - Similar Threads - Verbindung Bedingungen

  2. Verbindung mehrer Tabellen mit Pivot ohne eindeutige Beziehung

    in Microsoft Excel Hilfe
    Verbindung mehrer Tabellen mit Pivot ohne eindeutige Beziehung: Hallo liebe Office Kommuninity Ich hätte da gerne mal ein Problem und hoffe Ihr könnt mir helfen. Ich habe aus Navision mehrere Abfragen, die ich gerne zu einer Pivot-Tabelle zusammenfügen...
  3. LAMDA in Verbindung mit LET

    in Microsoft Excel Hilfe
    LAMDA in Verbindung mit LET: Hallo Forum, ich versuche gerade mich in die neuen Excel-Funktionen einzuarbeiten und habe angehängte Mappe erstellt. Ich habe für die LET-Funktion Parameter und Berechnungen erstellt und möchte...
  4. Dropdown mit Text verbinden

    in Microsoft Word Hilfe
    Dropdown mit Text verbinden: Hallo, ich habe folgendes Problem: ich habe in mehrere Standort und möchte, dass man per Dropdown den Standort auswählen kann und dann automatisch die dazugehörige Adresse darunter ergänzt wird....
  5. Ersetzen von Wörtern

    in Microsoft Word Hilfe
    Ersetzen von Wörtern: Hallo ich hab ein kleines Problem, bei welchem ich allein einfach nicht weiter komme. Ich möchte gern die Funktion Ersetzen benutzen ohne Sie zu benutzen. (Das klingt blöd, ich weiß ^^) Heißt...
  6. Tabellenübersicht aus mehreren Tabellen nach Datum sortieren

    in Microsoft Excel Hilfe
    Tabellenübersicht aus mehreren Tabellen nach Datum sortieren: Hallo, ich habe eine Tabelle für die Autowartung erstellt und möchte nun eine Übersichtseite als "Deckblatt" erstellen auf dem man alle wichtigen Daten sehen kann. Es gibt für alles auf einem...
  7. WENN FUNKTION / Zelleninhalte verbinden

    in Microsoft Excel Hilfe
    WENN FUNKTION / Zelleninhalte verbinden: Liebes Forum, in diesem Beispiel stand ich vor der Aufgabe, Spalte C und D zu verbinden, mit dem Zusatz dass hinter das auf den Buchstaben D noch ein E und ein Minus folgt. Dies ist mir auch...
  8. ODER in Verbindung mit RECHTS in WENN-Bedingungen

    in Microsoft Excel Hilfe
    ODER in Verbindung mit RECHTS in WENN-Bedingungen: Moin zusammen, ich steh grad auf dem Schlauch: Muss die Endziffer von Identnummern in Spalte A auslesen und daraufhin weitere Operationen ausführen. Dazu verwende ich dieses Formel:...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden