Office: Problem mit Matrixformel

Helfe beim Thema Problem mit Matrixformel in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo, in meiner Tabelle stehen in Spalte A und B die Messwerte. Da ich für eine Messung mehrere Messwerte bekomme, bilde ich daraus die Summe (Spalte... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von elke2, 13. September 2022.

  1. elke2 Neuer User

    Problem mit Matrixformel


    Hallo,
    in meiner Tabelle stehen in Spalte A und B die Messwerte.
    Da ich für eine Messung mehrere Messwerte bekomme, bilde ich daraus die Summe (Spalte D/E). Die Summen fasse ich mit einer Matrixformel
    {=WENN(ZEILE(D1)>ANZAHL2(D:D);"";INDEX(D:D;KKLEINSTE(WENN(D$5:D$1000<>"";ZEILE($5:$1000));ZEILE(D1))))}
    in Spalte J bzw K zusammen.
    Nun mein Problem: Wenn in Spalte A oder B kein Messwert da ist, verschieben sich die Werte in der zusammengefassten Tabelle Spalte L und M. (siehe Datei).
    Gibt es eine Möglichkeit, dass z.B. 0 angezeigt wird? Wie händisch in Spalte N und O eingetragen.

    Ich hoffe ich habe mein Problem verständlich dargelegt (Datei)
    Danke und Gruß
    Elke2
     
  2. Hajo_Zi
    Hajo_Zi Erfahrener User
    ist es die richtige Datei? Ich konnte in Spalte D und E keine Matrix Formel sehen.
    Mir ist nich klar wo un Warum Du 0 angezeigt haben möchtest?

    Problem mit Matrixformel GrußformelProblem mit Matrixformel Homepage
     
  3. steve1da Super-Moderator
    Hola,
    bitte lies doch einfach mal alles richtig.....so schwer ist das doch nicht.

    Natürlich tun sie das, immerhin macht die Formel genau das. Alles was nicht leer ist wird untereinander aufgelistet.
    Du musst die Formel um eine ODER Bedingung erweitern:
    =WENN(ZEILE(G1)>ANZAHL2(G:G);"";INDEX(G:G;KKLEINSTE(WENN((G$5:G$1000<>"")+(G$5:G$1000=0);ZEILE($5:$1000));ZEILE(G1))))
    Gruß,
    steve1da
     
  4. elke2 Neuer User

    Problem mit Matrixformel

    Vielen Dank für die Hilfe, das war genau das was ich brauchte.
     
  5. DL_
    DL_ hat Ahnung
    Es ist also erwünscht dass die Summen nicht identisch sind?
    Spalte A: 1613409,13
    Spalte B: 457874,22
    Spalte L: 1668591,14
    Spalte M: 457874,22
    Spalte N: 1613409,13
    Spalte O: 415190,67

    In den Spalten D bis G gab es Lücken ohne Formel.
     
  6. elke2 Neuer User
    Ja, das ist alles so o.k.
    Das waren nur ein paar Beispieldaten.
    Mein Problem ist damit gelöst.
     
Thema:

Problem mit Matrixformel

Die Seite wird geladen...
  1. Problem mit Matrixformel - Similar Threads - Problem Matrixformel

  2. Problem mit MS Office 2019, 2021 oder 365

    in Microsoft Outlook Hilfe
    Problem mit MS Office 2019, 2021 oder 365: Hi! Habe mir Office 2021 installiert. In Word, Excel, Powerpoint kommt ständig die Meldung "Tell us the account you want to user to open autodiscover.xml" Wisst Ihr, wie man diese Meldung weg...
  3. Sverweis - Problem

    in Microsoft Excel Hilfe
    Sverweis - Problem: Hallo, ich habe leider mal wieder ein Problem mit meinem Sverweis... Ich habe drei Dateien. - A_stock - Diese erhalte ich so täglich aus meiner Software exportiert - A_Upload - Diese muss so im...
  4. Problem mit Drucktitel

    in Microsoft Excel Hilfe
    Problem mit Drucktitel: Moin zusammen, ich habe eine einfach Tabelle mit 100 Zeilen erstellt. In den Zeilen 1 - 3 werden Summen gebildet. Die Zeilen 4 - 5 habe ich als Drucktitel definiert, sie erscheinen auch wie...
  5. Problem bei der Umsetzung der Formeln der Excel Datei

    in Microsoft Excel Hilfe
    Problem bei der Umsetzung der Formeln der Excel Datei: Liebe Forenmitglieder, ich habe ein Problem bei der Umsetzung der Formeln der Excel Datei. Vielleicht kann mir jemand aus dem Forum helfen. Lade die Datei mal hoch, habe das, was mir im Kopf...
  6. Literaturverzeichnis IEEE Absatz Problem

    in Microsoft Word Hilfe
    Literaturverzeichnis IEEE Absatz Problem: Guten Tag an alle, ich verfasse derzeit eine Facharbeit für einen Meisterabschluss und bin um ehrlich zu sein gerade total am verzweifeln. Und zwar geht es darum das wenn ich ein automatisches...
  7. Formel Problem gleicher Grund

    in Microsoft Excel Hilfe
    Formel Problem gleicher Grund: Hallo Zusammen, in der Datei im Anhang werden Top 5 Störungsgründe aus der Tabelle auf der linken Seite in die Tabelle auf der rechten Seite angezeigt. Sie werden absteigend nach der Minutenzahl...
  8. Problem Matrixformel

    in Microsoft Excel Hilfe
    Problem Matrixformel: Hallo, ich habe das Problem, dass die Matrixformel in Spalte L (L60) nicht funktioniert, wenn ich den Zusatz ( WENN(J601;""; )dabei setze. Wäre nett wenn mir jemand helfen könnte das Problem...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden