Office: (Office 2019) Probleme bei Formel-Umsetzung :-(

Helfe beim Thema Probleme bei Formel-Umsetzung :-( in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo Liebe Excel-Formel-Expert*innen, zuerst möchte ich mich als Excel-Newbie vorstellen, Grundkenntnisse sind vorhanden, bei der komplexen Umsetzung... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von ds11, 16. Oktober 2021.

  1. ds11 Neuer User

    Probleme bei Formel-Umsetzung :-(


    Hallo Liebe Excel-Formel-Expert*innen,

    zuerst möchte ich mich als Excel-Newbie vorstellen, Grundkenntnisse sind vorhanden, bei der komplexen Umsetzung von Funktionsberechnungen hapert es dann aber bei mir….

    Ich habe eine Tabelle erstellt wobei mir Beverly hier aus dem Forum schon weitergeholfen hat TOP!!!

    Nun ist es so, klappt erst mal was, dann ist man bestrebt noch das eine oder andere hinzuzufügen bzw. zu ändern. Meine Frage wäre nun, kann mir hier aus dem Forum ein Excel-Formelexperte ggf. Hilfestellung leisten?

    Die Tabelle habe ich beigefügt, das was mir im Kopf vorschwebt ist in …das möchte ich umsetzen… beschrieben.

    Vielen Dank für Eure Hilfe

    Wünsche allen ein schönes Wochenende

    DS11
     
  2. Hajo_Zi
    Hajo_Zi Erfahrener User
    Wo steht was Du möchtest? Wo steht die Formel?

    Probleme bei Formel-Umsetzung :-( GrußformelProbleme bei Formel-Umsetzung :-( Homepage
     
    Hajo_Zi, 16. Oktober 2021
    #2
  3. ds11 Neuer User
    Hallo Hajo,
    ich habe das in die "Datei 55_Versuch" in dem Tabellenblatt ...…das möchte ich umsetzen… beschrieben.
    Gruß
    DS11
     
  4. Hajo_Zi
    Hajo_Zi Erfahrener User

    Probleme bei Formel-Umsetzung :-(

    ich konnte die Tabelle "...…" nicht finden.
    Viel Erfolg noch.

    da meine Beitrag nicht komplett gelesen wurde.
    Das wird schon seinen Grund haben.
    Ich schreibe nicht für den Papierkorn. Ich bin dann raus.
    Viel Erfolg noch.
     
    Hajo_Zi, 16. Oktober 2021
    #4
  5. ds11 Neuer User
    Probleme bei Formel-Umsetzung :-( upload_2021-10-16_14-41-49.png
     
  6. steve1da Super-Moderator
    Hola,
    im Blatt "Liste" im Bereich X5:AU22, was sind da die gelben Spalten? Sind dass die nachträglichen h?
    Warum hat 2020 für jeden Monat 2 Spalten, die anderen Jahre aber nur 1 Spalte pro Monat?

    Gruß,
    steve1da
     
    steve1da, 16. Oktober 2021
    #6
  7. ds11 Neuer User
    Hallo steve1da,
    die gelben Spalten sind für die nachträglichen h gedacht.
    Ich habe bisher nur für das Jahr 2020 diese angelegt, da ich nicht weiß, ob man das so umsetzen kann. Aus diesem Grund habe ich noch eine Tabelle unterhalb erstellt X24:AL45.
    Falls erste Version (gelbe Spalten) umsetzbar ist, werde ich dies natürlich bei den weiteren Spalten in 2021-2032 entsürechend einfügen.
    Gruß
    DS11
     
  8. steve1da Super-Moderator

    Probleme bei Formel-Umsetzung :-(

    Es geht beides. Einfacher wäre die Variante mit den gelben Spalten wie im Jahr 2020. Mach das für für jedes Jahr und lade die Datei wieder hoch.
     
    steve1da, 17. Oktober 2021
    #8
  9. ds11 Neuer User
    Hallo steve1da,
    sorry das ich mich erst jetzt melde. Habe die Tabelle erst Heute abändern können. (Variante "gelbe Spalten")
    Vielen Dank, dass Du dich der Sache annimmst.
    DS11
     
  10. steve1da Super-Moderator
    Beantrage h ab G5:
    =SUMMENPRODUKT((Liste!$B$5:$B$22=B5)*(Liste!$X$3:$OD$3=DATWERT(1&D5&C5));Liste!$X$5:$OD$22)
    nachträglich beantrage h ab H5:
    =SUMMENPRODUKT((Liste!$B$5:$B$22=B5)*(Liste!$X$3:$OD$3<=DATWERT(1&D5&C5))*(ISTZAHL(Liste!$X$3:$OD$3));Liste!$Y$5:$OE$22)
    L5:
    =SUMMENPRODUKT((Liste!$B$5:$B$22=B5)*(Liste!$X$3:$OD$3<=DATWERT(1&D5&C5))*(ISTZAHL(Liste!$X$3:$OD$3));Liste!$X$5:$OD$22)+SUMMENPRODUKT((Liste!$B$5:$B$22=B5)*(Liste!$X$3:$OD$3<=DATWERT(1&D5&C5))*(ISTZAHL(Liste!$X$3:$OD$3));Liste!$Y$5:$OE$22)
    M5:
    =SUMMENPRODUKT((Liste!$E$4:$T$4=C5)*(ZEILE(Liste!$E$5:$T$16)-4<=VERGLEICH(D5;Liste!$D$5:$D$16;0))*(Liste!$E$5:$T$16))*7
     
    steve1da, 19. Oktober 2021
    #10
    1 Person gefällt das.
  11. ds11 Neuer User
    Hallo steve1da,

    WOW, vielen Dank für die Formel`n, wäre ich nie drauf gekommen. Böhmische Dörfer für mich..
    Habe diese in die Tabelle eingepflegt.

    Was noch nicht so ganz funktioniert, wenn ich die Daten (beantragteh/ ggf. noch nachträgliche h) in die Versuchs-Tabelle einfüge, dann werden diese Daten nicht in die Liste für die entsprechende Abteilung/Jahr/Monat übernommen.

    Ebenso der Mehrarbeit Abweichung-Zeitraum gibt nicht die richtigen Werte aus.
    Kannst Du bitte nochmals nachschauen, falls die Tabelle benötigst, lade ich diese noch mal hoch mit ein paar Beispielen.

    Würde mich freuen nochmals von Dir zu hören.

    Nochmals vielen Dank für Deine Mühe, TOP!!!

    DS11
     
  12. steve1da Super-Moderator
    Dann lade eine Datei mit mehr Beispielwerten hoch und einem händisch eingetragenem Wunschergebnis.
     
    steve1da, 20. Oktober 2021
    #12
  13. ds11 Neuer User

    Probleme bei Formel-Umsetzung :-(

    Klasse, vielen Dank.
    Falls mehr Beispiele benötigt werden, einfach bescheid geben.
    Die Beispiele sind in dem Tab-Blatt "Beispiel"
    DS11
     
  14. steve1da Super-Moderator
    Sorry, und wo ist jetzt genau das Problem? Da steht als Beschreibung:
    "Die h die in der Tabelle Versuch eingetragen werden, sollen in die Liste gem. der DropDown Vorgaben Jahr/Monat sowie beantrage/nachträgliche h automatisch übernommen/eingetragen werden, so dass man wenn z.B. bei
    Test 2, 2020 April auswählt in "
    Da fehlt doch was am Ende. Außerdem hast du zwar irgendwelche Zellen rot markiert, aber was jetzt damit ist weiß ich nicht. Irgendwas soll falsch rechnen, aber was, das sagst du nicht - und auch nicht was richtig wäre.
     
    steve1da, 21. Oktober 2021
    #14
  15. ds11 Neuer User
    Hallo steve1da,

    vielen Dank für die Antwort, ist eine schwere Geburt mit Mir....

    Ich probiere es nochmals zu erklären s. Anhang Beschreibung in Anlehnung der Kopie 56.3_Versuch-2

    Würde mich freuen nochmals von Dir zu hören.

    Nochmals vielen Dank für Deine Mühe, TOP!!!

    DS11
     
Thema:

Probleme bei Formel-Umsetzung :-(

Die Seite wird geladen...
  1. Probleme bei Formel-Umsetzung :-( - Similar Threads - Probleme Formel Umsetzung

  2. Probleme mit der Formel Kompatibilität in Excel

    in Microsoft Excel Tutorials
    Probleme mit der Formel Kompatibilität in Excel: Probleme mit der Formel Kompatibilität in Excel Excel für Microsoft 365 Excel 2019 Excel 2016 Excel 2013 Excel 2010 Excel 2007 Excel Starter...
  3. Probleme mehr als 5 Wochentag Funktionen in einer Formel

    in Microsoft Excel Hilfe
    Probleme mehr als 5 Wochentag Funktionen in einer Formel: Hallo ! Ich bin verzweifelt. Folgende Formel funktioniert (in L6 steht das Jahr (2020) und in L7 steht der Monat (Ziffer 1-12) : =WENN(UND(...
  4. Probleme mit einer WENN-Formel

    in Microsoft Excel Hilfe
    Probleme mit einer WENN-Formel: Hallo zusammen, ich habe folgendes Problem mit dieser WENN-Formel: =WENN(Auswertung!$M$29="";"";WENN(AD64=0;0;WENN(AE64>0;AD64&" + EZ";AD64))) Die Formel gibt als Ergebnis (wenn in AE64 mehr...
  5. Probleme mit ZählenWenn-Formel

    in Microsoft Excel Hilfe
    Probleme mit ZählenWenn-Formel: Hallo zusammen! Bin noch ein Newbie und nicht gerade ein Excel-Crack aber frage jetzt doch mal in die Runde ob mir jemand helfen kann von euch :-) Ausgangslage: Es geht um eine...
  6. Probleme mit der DATEDIF-Formel

    in Microsoft Excel Hilfe
    Probleme mit der DATEDIF-Formel: Hallo meine lieben Excel-Kollegen, Ich habe seit einiger Zeit ein Problem mit der DATEDIF-Formel und komme einfach nicht weiter... Ich hoffe einer von euch hat eine Lösung zur Hand. Ich...
  7. Probleme mit mehreren Kriterien in Wenn-Formel

    in Microsoft Excel Hilfe
    Probleme mit mehreren Kriterien in Wenn-Formel: Hallo zusammen Ich habe ein Problem mit einer Wenn-Formel in Zusammenhang mit der bedingten Formatierung. In der Zelle E11 sollte, wenn die Kriterien in der Tabelle entsprechend JA oder...
  8. Probleme mit Formel und Schriftfarbe

    in Microsoft Excel Hilfe
    Probleme mit Formel und Schriftfarbe: Hallo, ich hoffe hier ist jemand der mir weiterhelfen kann. Bin kein Excel Experte, sondern versuche mich immer irgendwie selbst durch zu kämpfen. Habe folgendes Vorhaben: In Zelle A1-A5 sind...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden