Office: Sollarbeitszeit mit SVERWEIS

Helfe beim Thema Sollarbeitszeit mit SVERWEIS in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; HiHo Ich stehe mal wieder vor einem (von vielen) Problem(en) bei meiner Exeltabelle. Es geht hierbei um die Sollarbeitszeit. =WENN(... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von BFS-Technik, 4. Dezember 2023.

  1. Sollarbeitszeit mit SVERWEIS


    HiHo

    Ich stehe mal wieder vor einem (von vielen) Problem(en) bei meiner Exeltabelle.

    Es geht hierbei um die Sollarbeitszeit.

    =WENN(
    ODER(
    C6=SVERWEIS($C$6;Tabelle2!$B$19:$B$31;1;0);
    WOCHENTAG(C6;2)=7;
    WOCHENTAG(C6;2)=6
    );
    0/24;
    WENN(
    ODER(
    D6="Arbeitstag";
    D6="Zeitausgleich"
    );
    7,8/24;
    0/24
    )
    )

    (Ja die Formel geht einfacher... jedoch habe ich diese so auseinander genommen um das mögliche Problem besser zu erkennen)

    Wenn
    1. SVERWEIS zutrifft (also ein Feiertag ist)
    Oder
    2. der Wochentag ein Samstag ist
    Oder
    3. der Wochentag ein Sonntag ist
    Dann
    Setze den Zeitwert auf 0:00
    Sonst
    Wenn
    1. Feld D = Arbeitszeit ist
    Oder
    2. Feld D = Zeitausgleich ist
    Dann
    Setze den Zeitwert auf 7:48
    Sonst
    0:00

    Soweit sollte das eigentlich ja funktionieren.

    Sollte...

    Wie jedoch unschwer an meiner Tabelle zu sehen ist (zb Mai 2023), wird jedoch zb der 18.5. zwar als Feiertag erkannt, jedoch der Wert nicht richtig gesetzt. beim 01.05. stimmt es jedoch.

    Hat wer eine Idee was da Falsch läuft?

    Und vllt hat ja auch jemand eine Idee, warum das ganze noch weniger funktioniert (#NV), wenn ich den Monat ändere. dann kann ich evtl. den Fehler auch gleich noch beheben.
     
    BFS-Technik, 4. Dezember 2023
    #1
  2. steve1da Office Guru
    Hola,
    Hat wer eine Idee was da Falsch läuft?
    du hast C6 absolut fixiert, dh jede Zeile wird mit C6 verglichen.
    Die Wochenend-Abfrage kann man übrigens verkürzen: =wochentag(C6;2)>5
    Gruß,
    steve1da
     
    steve1da, 4. Dezember 2023
    #2
  3. Wenn ich
    "
    =WENN(ODER(C6=SVERWEIS(C6;Tabelle2!$B$19:$B$31;1;0);
    WOCHENTAG(C6;2)=7;
    WOCHENTAG(C6;2)=6);0/24;WENN(ODER(D6="Arbeitstag";D6="Zeitausgleich");7,8/24;0/24))
    "
    verwende, dann zeigt er mir zwar die Feiertage richtig an, aber die Wochentage und Wochenenden zeigt er mir mit #NV an.
    Gleiches auch bei $C6.

    Und ja, ich sagte ja das man die Formel verkürzen kann.
     
    BFS-Technik, 4. Dezember 2023
    #3
  4. steve1da Office Guru

    Sollarbeitszeit mit SVERWEIS

    steve1da, 4. Dezember 2023
    #4
  5. Danke... das scheint zu funktionieren.
     
    BFS-Technik, 4. Dezember 2023
    #5
  6. also die: "
    =UND(ODER(D6="Arbeitstag";D6="Zeitausgleich");WOCHENTAG(C6;11)<6;ZÄHLENWENNS(Feiertage;C6)=0)*"7:48"
    "
    hatte nicht funktioniert.

    Die dagegen:
    "=WENN(ODER(ZÄHLENWENN(Feiertage;C6);
    WOCHENTAG(C6;2)>5);0;WENN(ODER(D6="Arbeitstag";D6="Zeitausgleich");7,8/24;0))"
    geht.

    und ja... der Beitrag war im grunde auch von mir.... hatte es nur nicht mehr auf dem Schirm. Demnach sry für den Doppelpost.
    Jetzt muss ich mal schauen ob sich das auch auf die anderen bereiche (Spalten N-R) anwenden lässt.

    Gibt es da eine Vereinfachungsoption für die Formeln?
     
    BFS-Technik, 4. Dezember 2023
    #6
  7. steve1da Office Guru
    Bei mir ergeben in deiner Datei beide Formeln das gleiche Ergebnis.
    Kürzer als DL_'s Vorschlag gehts glaub ich nicht.
     
    steve1da, 4. Dezember 2023
    #7
Thema:

Sollarbeitszeit mit SVERWEIS

Die Seite wird geladen...
  1. Sollarbeitszeit mit SVERWEIS - Similar Threads - Sollarbeitszeit SVERWEIS

  2. SVERWEIS

    in Microsoft Excel Hilfe
    SVERWEIS: Hej! bin ein absoluter Excel Anfänger und vermutlich wird hier nun über meine Frage geschmunzelt. Sicher findet sich trotzdem ein schlauer Kopf der mir helfen kann. Ich möchte die fehlende PNR...
  3. Bedingte Formatierung funktioniert nicht

    in Microsoft Excel Hilfe
    Bedingte Formatierung funktioniert nicht: Hallo, ich habe eine Excel Datei erstellt und es funktioniert alles, bis auf eine bedingte Formatierung. Ich verstehe einfach nicht wieso. Habe in der Liste schon andere Formatierungen, die sehr...
  4. Access mit Sverweis,???

    in Microsoft Access Hilfe
    Access mit Sverweis,???: =WENN(ISTNV(SVERWEIS(Eingang[@Vorgang];NrDrei2;2;0));"";SVERWEIS(Eingang[@Vorgang];NrDrei2;2;0)) Gesetz dem Falle mich versteht gerade jemand mit dem o. A. Anliegen!!! Ich möchte von Excel mal...
  5. Tabellenformatierung: Effekt auf Verweise

    in Microsoft Excel Hilfe
    Tabellenformatierung: Effekt auf Verweise: Hallo zusammen, ich habe eine Excel, in der sehr viele Produktdaten in einer Listenform gesammelt sind. Viele weitere Dateien sind über S- und X-Verweise mit dieser Produktliste verknüpft. Gerne...
  6. Sverweis mit zwei Intervallen

    in Microsoft Excel Hilfe
    Sverweis mit zwei Intervallen: Hello again, mein Vorsatz für nächstes Jahr ist auf jeden Fall eine Excel-Fortbildung um euch hier nicht immer wieder zu belästigen :oops::rolleyes: Ich steh (mal wieder) etwas auf dem Schlauch....
  7. Werte in 2 Tabellen vergleichen und Zählen wenn Suchbegriff zutrifft

    in Microsoft Excel Hilfe
    Werte in 2 Tabellen vergleichen und Zählen wenn Suchbegriff zutrifft: Hallo, vielleicht kann mir jemand helfen: Ich habe zwei Tabellenblätter und in beiden steht in Spalte A der Nachnahme Es sollen nun alle Namen in den beiden Tabellenblätter miteinander...
  8. sverweis und Wochenenden in Matrix darstellen

    in Microsoft Excel Hilfe
    sverweis und Wochenenden in Matrix darstellen: Hallo, ich habe zwei Probleme, welche ich aktuell nicht gelöst bekomme. Nr. 1 Ich habe eine Jahresübersicht in Form einer Matrix, wo ich nur die WE farblich dargestellt bekommen möchte. Über...
Schlagworte:
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden