Office: (Office Version unbekannt) Summenbereich dynamisch

Helfe beim Thema Summenbereich dynamisch in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo, ich habe folgende Formel mit einem fixem Bereich, hätte dies gerne dynamisch: =SUMMEWENN(E3:E54;6;G3:G54) hat jemand eine Idee? danke gruss... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von ferries, 6. Dezember 2022.

  1. Summenbereich dynamisch


    Hallo,

    ich habe folgende Formel mit einem fixem Bereich, hätte dies gerne dynamisch:

    =SUMMEWENN(E3:E54;6;G3:G54)

    hat jemand eine Idee?
    danke
    gruss Stephan
     
    ferries, 6. Dezember 2022
    #1
  2. Kalk User
    Hallo,

    z.B.

    Code:
    =SUMMEWENN(E3:INDEX(E3:E54;ANZAHL(E3:E54));6;G3:INDEX(G3:G54;ANZAHL(G3:G54)))
     
  3. Ich danke dir, aber ich glaube ich habe mich falsch ausgedrückt, ich wollte das E54 bzw. G54 als dynamischen Wert haben, weil sich die Tabellen jeweils verlängern bzw. verkürzen können.

    danke

    Gruß Stephan
     
    ferries, 6. Dezember 2022
    #3
  4. steve1da Office Guru

    Summenbereich dynamisch

    Hola,
    =SUMMEWENN(INDEX(E:E;3):INDEX(E:E;A3);6;INDEX(G:G;3):INDEX(G:G;A3))
    In A3, oder halt woanders, trägst du den dynamischen Wert ein.
    Gruß,
    steve1da
     
    steve1da, 6. Dezember 2022
    #4
  5. neopa C hat Ahnung
    Hallo Stephan,

    Dein "Problem" stellt sich gar nicht, wenn Du Deine auszuwertende Datenliste in eine "intelligente" Datentabelle formatierst und Du die Auswertung darauf beziehst. Das kann (und sollte) man bereits ab XL 2007 tun.
     
    neopa C, 6. Dezember 2022
    #5
  6. hier mal die Tabelle, es geht um die Summenberechnung F1, H1
    Gruß Stephan
     
    ferries, 6. Dezember 2022
    #6
  7. steve1da Office Guru
    Und jetzt? Was ist mit unseren Vorschlägen?
     
    steve1da, 6. Dezember 2022
    #7
  8. Summenbereich dynamisch

    In A3 ist z.b. ein Wert drin, kam #Wert als Fehler
     
    ferries, 6. Dezember 2022
    #8
  9. steve1da Office Guru
    Dann pack Wennfehler() um deine Formeln, zB in G4:
    =WENNFEHLER(F4*D4;"")
     
    steve1da, 6. Dezember 2022
    #9
  10. Danke,
    habe statts A3 eine andere Freie Zelle genommen.... Ist wie immer, der Wald und die Bäume ....
    hier mal meine zu mind. funktionierende Formel für F1
    =SUMMEWENN(INDEX(E:E;3):INDEX(E:E;F3);6;INDEX(G:G;3):INDEX(G:G;F3))
    Danke euch
    Gruß Stephan
     
  11. HKindler
    HKindler hat Ahnung
    Hi,

    statt INDEX(E:E;3) kann man auch gleich E3 schreiben:
    =SUMMEWENN(E3:INDEX(E:E;F3);6;G3:INDEX(G:G;F3))
     
    HKindler, 6. Dezember 2022
    #11
  12. Danke funktioniert und ist auch kürzer :)
     
  13. neopa C hat Ahnung

    Summenbereich dynamisch

    Hallo ferries,

    im empfehle Dir trotzdem, Dich mal mit "intelligenten" Tabellen vertraut zu machen.
     
  14. und wie würdest du es an meiner Tabelle machen?
    gruss stephan
     
  15. neopa C hat Ahnung
    Hallo Stephan,

    man könnt auch Deine Datenliste in eine "intelligente" Tabelle umformatieren. Für Deine Datenstruktur aber wiederum nicht zu empfehlen.

    Bei Deiner vorhandenen Datenstruktur reicht aber einfach für F1: =SUMMEWENN(A:A;"E-Mai*";G:G) und analog in H1 ...

     
Thema:

Summenbereich dynamisch

Die Seite wird geladen...
  1. Summenbereich dynamisch - Similar Threads - Summenbereich dynamisch

  2. Dynamisches Diagramm

    in Microsoft Excel Hilfe
    Dynamisches Diagramm: Hallo Forum, in meiner Arbeitsmappe habe ich eine Datentabelle in der pro Tag die absolvierten Schritte eingetragen werden. Spalte B, das Tagesdatum. Spalte C die gelaufenen Schritte. Über eine...
  3. Dynamischer Jahreskalender

    in Microsoft Excel Hilfe
    Dynamischer Jahreskalender: Hallo. Ich versuche schon seid längerem mir ein dynamischen Jahreskalender zu erstellen. Man bekommt viele Vorlagen dazu, aber nichts wo jeder Monat auf einem eigenen Blatt ist. Das Heißt das...
  4. Stunden aus Monat/Datumsbereich für jede Person berechnen

    in Microsoft Excel Hilfe
    Stunden aus Monat/Datumsbereich für jede Person berechnen: Hallo, wir haben jedes Jahr eine Excel-Datei für uns Mitarbeiter, wo wir unsere Tageszeiten eintragen. Wir sind nicht fest geplant und können von daher eigentlich kommen und gehen wann wir...
  5. Summewenn bei horizontalem Summenbereich

    in Microsoft Excel Hilfe
    Summewenn bei horizontalem Summenbereich: Hallo Zusammen, ich habe folgendes Problem: -> siehe Beispieldatei Ich würde gerne in Spalte "C" die entsprechende Summe aus der Zeile "H:N" abbilden. Ich habe dies mit der Formel "Summewenn"...
  6. Summewenn mit variablen Summenbereich

    in Microsoft Excel Hilfe
    Summewenn mit variablen Summenbereich: Hallo, ich habe eine Tabelle, in der ich meine Ein- und Ausgaben erfasse. Jetzt möchte ich gerne einen Soll/Ist Vergleich realisieren. Leider komme ich bei den kumulierten Werten nicht weiter....
  7. Summe dynamischer Bereich

    in Microsoft Excel Hilfe
    Summe dynamischer Bereich: Hallo, ich möchte einen dynamischen Bereich addieren, der eine variable Anfangszelle als auch eine variable Endzelle haben kann. In der angehängten Tabelle ist das Beispiel enthalten. In den...
  8. Summenbereich soll sich beim Einfügen von Zeilen anpassen

    in Microsoft Excel Hilfe
    Summenbereich soll sich beim Einfügen von Zeilen anpassen: Hallo, ich steh mal wieder auf dem Schlauch... gegeben ist: Eine Excel-Datei mit mehreren Blättern, alle gleich aufgebaut. Die obersten beiden Zeilen sind festgestellt und enthalten...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden