Office: (Office 365) summewenns ohne negative Werte

Helfe beim Thema summewenns ohne negative Werte in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo, ich bräuche mal wieder eure Hilfe, ich habe folgende Formel:... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von ferries, 12. Dezember 2023.

  1. ferries hat Ahnung

    summewenns ohne negative Werte


    Hallo,
    ich bräuche mal wieder eure Hilfe, ich habe folgende Formel:

    =WENN(A2="";"";SUMMEWENNS(Rechnung[Brutto];Rechnung[Kunde/Firma];Firmenumsätze!A2))

    aber es soll nur Beträge summiert werden die >0 sind keine negativen

    was mache ich gedanklich gerade sehr falsch?

    danke für eure Hilfe
    gruss Stephan
     
  2. HKindler
    HKindler hat Ahnung
    Hi,

    du brauchst doch nur eine weitere Bedingung in dein SUMMEWENNS mit einzufügen:

    =WENN(A2="";"";SUMMEWENNS(Rechnung[Brutto];Rechnung[Kunde/Firma];Firmenumsätze!A2;Rechnung[Brutto];">0"))
     
    HKindler, 12. Dezember 2023
    #2
  3. ferries hat Ahnung
    Danke,
    hab den Wald wie immer vor lauter Bäumen nicht gesehen
    gruss stephan
     
  4. ferries hat Ahnung

    summewenns ohne negative Werte

    habe doch noch eine Frage ich möchte das auch via Teilergebnis bei gefilterten Werten aus Tabelle machen, leider fliegen mir egal was ich mache die Fehlermeldungen um die Ohren: hier mein letzter Versuch mal:

    =SUMMENPRODUKT(TEILERGEBNIS(109;Rechnung[Brutto]);"> 0")

    =TEILERGEBNIS(109;(SUMMEWENN((Rechnung[Brutto]);">0")

    gruss Stephan
     
  5. ferries hat Ahnung
    Hallo,
    mit der Formel bekomme ich es die Summe hin die nur positivie Werte hat:

    =SUMMEWENN(Rechnung[Brutto];">0")

    aber nicht wenn ich gefiltert habe, da möchte ich nur die Werte von der Filterung summiert haben.

    gruss stephan
     
  6. steve1da Office Guru
    steve1da, 13. Dezember 2023
    #6
  7. ferries hat Ahnung
    Danke steve1da,

    ich bin wohl zu blöd das umzuschreiben:
    =SUMMENPRODUKT(TEILERGEBNIS(109;INDIREKT("E"&ZEILE(T4:T999)))*(H4:H999>0))
    kommt immer 0 als Wert
    anbei doch mal die Tabelle
    im Moment liegt es auf E1 soll aber unter H1 später stehen, das andere sind meine Tests ...
    gruss stephan
     
  8. steve1da Office Guru

    summewenns ohne negative Werte

    =SUMMENPRODUKT(TEILERGEBNIS(109;INDIREKT("H"&ZEILE(4:281)))*(H4:H281>0))
     
    steve1da, 13. Dezember 2023
    #8
  9. HKindler
    HKindler hat Ahnung
    Hi,

    mal zum Nachdenken: was könnte wohl die Summe aus z.B. "Monttoni" und "Ekici" sein?

    Ich würde sowieso kein TEILERGEBNIS(109;INDIREKT(...)) verwenden, da mir das wegen INDIREKT zu viel Rechenaufwand verursachen würde. Statt dessen ist es sinnvoller eine weitere Spalte in die Tabelle einzufügen, die ich üblicherweise einfach "sichtbar?" nenne. Diese bekommt die Formel =TEILERGEBNIS(103;[@[Pos.]]) wobei als zweiter Parameter eine Zelle der selben Zeile in einer Spalte verwendet wird, die auf alle Fälle gefüllt ist. Damit hast du nun eine Spalte, in der eine 1 steht, falls die Zeile sichtbar ist und eine 0, falls sie nicht sichtbar ist, Somit kann man alle xxxWENNS()-Funktionen (oder auch Summenprodukt) verwenden um gefilterte Daten auszuwerten.

    Übrigens, die Formel in der Spalte POS. =WENNFEHLER(BEREICH.VERSCHIEBEN(A4;-1;0)+1;1) ist genauso unglücklich. Denn BEREICH.VERSCHIEBEN ist ebenso wie INDIREKT volatil und wird daher ständig neu berechnet, Hier wäre es geschickter =SUMME(A3;1) zu verwenden. Das funktioniert allerdings nur, wenn zwischendurch keine Zeilen gelöscht oder eingefügt werden. Falls du das möchtest, dann bietet sich die Formel =ZEILE()-Rechnung[#Kopfzeilen] an.

    Zur Formel in Spalte R.-Nr. =WENNFEHLER(BEREICH.VERSCHIEBEN(B4;Variablen!$B$3&"-"&-1;0)+1;Variablen!$B$3&"-"&Variablen!$B$2+ZEILE(A1)-1) Hier ist der BEREICH.VERSCHIEBEN()-Teil Humbug, da er immer zu einen Fehler führt und daher sowieso nur der Fehler-Teil ausgeführt wird. Wieso? Weil - egal was in Variablen!$B$3 steht - die Verknüpfung von "-" mit -1 zu einem Text führt, den Excel nicht in eine Zahl überführen kann. Dadurch liefert BEREICH.VERSCHIEBEN einen #WERT!-Fehler. Und wie gesagt, sollte man BEREICH.VERSCHIEBEN so oder so meiden. Ebenso ist es nicht gerade geschickt, hier die Rechnungsnummer aufgrund der Position in der Tabelle zu berechnen. Die Nummer muss doch fest mit Kunde und Datum verbunden sein, oder nicht?
     
    HKindler, 13. Dezember 2023
    #9
  10. ferries hat Ahnung
    Danke für eure Hilfe.
    Sorry bin grad gewesen, lag mit einer Grippe im Bett.
    Gruss Stephan
     
Thema:

summewenns ohne negative Werte

Die Seite wird geladen...
  1. summewenns ohne negative Werte - Similar Threads - summewenns negative Werte

  2. Summewenns mit Datum und Zwei Buchstaben eingrenzen

    in Microsoft Excel Hilfe
    Summewenns mit Datum und Zwei Buchstaben eingrenzen: Guten Abend Zusammen, ich versuche aus einer Tabelle mit Summewenns (sumifs) die Beträge vom Kalendermonat abweichend zu errechnen. Das funktioniert mittlerweile auch. Da das Datum über den...
  3. Jahresumsatz mit summewenn ermitteln

    in Microsoft Excel Hilfe
    Jahresumsatz mit summewenn ermitteln: Hallo Community, ich verzweifle gerade an einer vermeintlich ziemlich einfachen Aufgabe. Und zwar habe ich eine Tabelle, 3 Spalten in der in Spalte A das Datum steht und in Spalte C der Betrag....
  4. Kalenderprobleme

    in Microsoft Excel Hilfe
    Kalenderprobleme: Guten Morgen Zusammen Ich habe so meine Mühe mit SUMMEWENNS in Kombination mit WENN. Habe doch gemerkt, dass diese Verbindung nicht zum Ziel führt. Ich suche die Formeln Violett. F=Frei /...
  5. Probleme mit Summewenn bei neuer EXCEL Version

    in Microsoft Excel Hilfe
    Probleme mit Summewenn bei neuer EXCEL Version: Hallo zusammen, ich bin ratlos. In meinem alten EXCEL sheet hat die Funktion =SUMME(WENN(JAHR($E$7:$E$54)=2019;$G$7:$G$54)) super funktioniert. Mit der aktuellen EXCEL Version jetzt aber nicht...
  6. Wenn/summewenn

    in Microsoft Excel Hilfe
    Wenn/summewenn: Guten Tag Ich bin neu hier in diesem Forum. Ich habe schon gesucht, aber wurde leider nicht fündig. Ich habe eine Tabelle mit verschiedenen Werten in den jeweiligen Zellen. Mein Ziel ist, dass...
  7. SUMMEWENN bei aufgeblendeten/gefilterten Zeilen

    in Microsoft Excel Hilfe
    SUMMEWENN bei aufgeblendeten/gefilterten Zeilen: Hallo, ich steh mal wieder auf dem Schlauch. Ich habe eine Beispieltabelle angehängt. Ich habe hier eine Liste, wo wir unsere Kunden eintragen, die bei uns Bar bezahlen. Dabei gibt es normale...
  8. SUMMEWENN oder SUMMEWENNS zum verzweifeln

    in Microsoft Excel Hilfe
    SUMMEWENN oder SUMMEWENNS zum verzweifeln: Hallo zusammen, manchmal ist es viel schwerer als man denkt. Ich verzweifle an einer Formel die mir anfangs ganz einfach zu sein schien aber anscheinend sind meine Excel Kenntnisse nicht...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden