Office: SVERWEIS angepasste Formeln

Helfe beim Thema SVERWEIS angepasste Formeln in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo, ich habe vorhieriges Topic mit Sverweis hinbekommen, leider bekomme ich bei der Berechnung einen Überlauf und finde nicht das Problem wann und... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von ferries, 24. Januar 2023.

  1. SVERWEIS angepasste Formeln


    Hallo,
    ich habe vorhieriges Topic mit Sverweis hinbekommen, leider bekomme ich bei der Berechnung einen Überlauf und finde nicht das Problem wann und warum der auftritt.

    Für eure Hilfe bin ich bereits sehr dankbar

    gruss Stephan
     
    ferries, 24. Januar 2023
    #1
  2. steve1da Office Guru
    Hola,
    das ist jetzt nicht despektierlich gemeint, aber du hast keine Ahnung was du da genau tust, oder?
    Deshalb noch mal der Rat: ihr verdient damit Geld, also lasst euch helfen indem ihr einen Auftragsprogrammierer beauftragt.
    Es hilft nichts, hier Formeln zu zeigen die nicht funktionieren, aber nicht zu sagen, was wann genau passieren soll. Ist ja nicht das erste Mal.
    Gruß,
    steve1da
     
    steve1da, 24. Januar 2023
    #2
  3. Hallo steve1da,

    Sorry, nur zur Info, ich verdiene damit kein Geld, ich helfe einem guten Freund, der in Excel mit Copy & Paste incl. mind. 3 Fehlern hat, weil er noch mit dem Taschenrechner dabei arbeitet, ich möchte ihm nur alles vereinfachen.

    zu dem Fehler du hast Recht, ich hätte es besser beschreiben müssen, leider war ich überfordert, weil die Berechnung funktioniert hat, nur beim Abändern dann plötzlich der Fehler kommt. liegt wohl am
    =Wenn(MRabatt[Anzahl]=0; ... habe dann in =Wenn(Preise!L2=0; dann geht es, .... warum auch immer, ich verstehs leider nicht..

    gruss stephan
     
    ferries, 25. Januar 2023
    #3
  4. steve1da Office Guru

    SVERWEIS angepasste Formeln

    #ÜBERLAUF erhältst du, weil deine Formel in diesem Falle 2 Ergebnisse automatisch untereinander erzeugt. Schreib die Formel mal in eine leere Zelle rechts neben die Tabelle, da werden 2 Ergebnisse erscheinen. Und da in K53 schon etwas drin steht hat Excel keinen Platz um die Ergebnisse untereinander zu schreiben. Dann erscheint #ÜBERLAUF.
     
    steve1da, 25. Januar 2023
    #4
  5. Hallo steve1da,

    Danke jetzt hab ich es verstanden, habe auch mittlerweile meinen Fehler gefunden ...
    die Formel war eine Matrixformel, wenn man beim Kopieren das ignoriert ...

    vielen Dank für deine Unterstützung
    Gruß Stephan
     
    ferries, 25. Januar 2023
    #5
  6. HKindler
    HKindler hat Ahnung
    Hi,

    wenn du einen Überlauffehler bekommst, dann heißt das, dass dein Excel Spill-Formeln kennt. Das wiederum heißt, dass du keinen Abschluss als Matrix-Formel brauchst, denn dein Excel macht das automatisch. Somit steckt der Fehler in deiner Formel, da sie zwei Ergebnisse erzeugt.
    =WENN(MRabatt[Anzahl]=0;xxx:xxx) erzeugt dir zwei Werte, da MRabatt aktuell zwei Datensätze enthält.
    Wenn du in deiner Version die Formel mit Strg-Shift-Enter abschließt und in diesem Moment die Zelle darunter in diesem Moment belegt ist, dann passiert das selbe wie im altem Excel, nämlich dass das zweite Ergebnis einfach verworfen wird. Ist die Zelle frei, dann wird diese automatisch mit belegt und das zweite Ergebnis dort angezeigt. Dann kannst du diese Zelle auch nicht mehr ändern.
     
    HKindler, 25. Januar 2023
    #6
  7. Hallo Helmut,

    Danke dir auch sehr.

    Dann ist es besser =WENN(Preise!L2=0; xxxx zu benutzen mit einem direkten Bezug zu einer Zelle?

    Gruss Stephan
     
    ferries, 25. Januar 2023
    #7
  8. HKindler
    HKindler hat Ahnung

    SVERWEIS angepasste Formeln

    Ja genau. Oder um konsistent zu bleiben =WENN(INDEX(MRabatt[Anzahl];1)=0;xxx;xxx) Dann kannst du deine Tabelle nämlich verschieben wie du willst. Überhaupt solltest du dich selbst darauf einigen, ob du die Tabellen-Schreibweise oder normale Zell-Adressen verwendest. Das sollte man dann auch durchgehend einhalten.
     
    HKindler, 25. Januar 2023
    #8
  9. Hallo Helmut,

    ich danke dir sehr.

    Ich habe erst angefangen mich mit den Tabellen auseinander zusetzen, ich weiss auch, das meine Formeln noch Verbesserungswürdig sind. Es ist für mich noch vieles Neuland und deswegen das gewohnte noch, bin aber bemüht das zu optimieren.

    gruss stephan
     
    ferries, 25. Januar 2023
    #9
  10. Exl121150 Erfahrener User
    Hallo,

    ich habe dir in der beiliegenden Datei modifizierte Formeln eingebaut, die ebenfalls die bereits angesprochenen Probleme vermeiden (sollten).

    In der Tabelle "Preise" habe ich eine Zusatzspalte eingefügt (ob Mengenrabatt möglich oder nicht).
    Im Arbeitsblatt "Rechnung" habe ich in den Spalten N und O Hilfsformeln eingefügt, um unnötige Mehrfachberechnungen in den Formeln zu vermeiden.
    Wie weit die Rabattberechnungen deinen Vorstellungen entsprechen, weiß ich nicht, da dazu dich bisher nicht geäußert hast.
    Auch wusste ich nicht, welche Excel-Version du dann wirklich hast: Angegeben hast du Excel2016 - aber wenn du in den Rabattzellen einen Überlauf-Fehler hattest, musst du Excel2021 oder Excel365 besitzen.
    Da der Zellbereich B27:L27 im Rechnungsblatt bereits zur struktur.Tabelle "Rechnung" gehört, habe ich diese "Leerzeile" mit in die Formeln genommen - die Formeln würden sonst inkonsistent.
     
    Exl121150, 25. Januar 2023
    #10
  11. Hallo Anton,

    vielen Dank erstmal, ich werde mir das heute abend in Ruhe anschauen.
    Ich selbst habe Office 365 Buissness, aber mein Kumpel hat nur Office 2016, deswegen muss ich bei den Formeln immer aufpassen.

    Zu den Rabatten, habe ich das bisher eingebaut, was ich in seinen Rechnungen so gefunden habe. Wollte den Mengenrabatt flexible gestalten, bei meinen ersten Formeln gab es ein Problem wenn ich zum testen nur einen Rabatt anstatts 2 erfasst hatte.

    ich danke dir für deine Mühe,

    gruss Stephan
     
    ferries, 25. Januar 2023
    #11
  12. Hallo Anton,

    vielen Dank sieht echt super aus, habe es auch getestet und funktioniert wie es sein soll! Nur ist berechnet er bei der Zeile 52 nicht mehr den Mengenrabatt

    Gruss stephan
     
    ferries, 26. Januar 2023
    #12
  13. Exl121150 Erfahrener User

    SVERWEIS angepasste Formeln

    Hallo,

    Das liegt an 2 Problemen mit der Formel in Zelle N52:
    =SUMME(WENNFEHLER(SVERWEIS(Rechnung[Bezeichnung];Preise;6;0);0)*Rechnung[Anz.])

    Problem 1:
    Du hast sie geändert auf:
    =SUMME(WENNFEHLER(SVERWEIS(Rechnung[Bezeichnung];Preise;6;1);0)*Rechnung[Anz.])
    Das darfst du auf keinen Fall tun, denn dann wird mit hoher Wahrscheinlichkeit der SVERWEIS falsch berechnet.

    Problem 2:
    Die Formel funktioniert tadellos (in Excel365), so wie ich sie oben angeführt habe. Da ich kein Excel2016 besitze, kann ich nicht testen, ob sie auch dort so funktioniert oder ob sie dort zwingend als Array-Funktion (mit geschweiften Klammern) einzugeben ist:
    {=SUMME(WENNFEHLER(SVERWEIS(Rechnung[Bezeichnung];Preise;6;0);0)*Rechnung[Anz.])}
    Wenn ich mit meinem Excel365 das tue, erhalte ich als Resultat 0 - warum auch immer, ich weiß es nicht.
    Funktionieren müsste ebenfalls auch folgende Formel:
    =SUMMENPRODUKT(WENNFEHLER(SVERWEIS(Rechnung[Bezeichnung];Preise;6;0);0)*Rechnung[Anz.])

    Falls auch diese Formel in Excel2016 Probleme verursacht, dann müsste im Zeilenbereich der Tabelle "Rechnung" zB. in Spalte O (Zellen O27:O46) folgende Formel ohne SUMME bzw. SUMMENPRODUKT eingegeben werden:
    =WENNFEHLER(SVERWEIS(Rechnung[Bezeichnung];Preise;6;0);0)*Rechnung[Anz.]
    und dann in Zelle N52 stattdessen die Formel (ohne Array-Klammern):
    =SUMME(O27:O46)
     
    Exl121150, 26. Januar 2023
    #13
  14. Danke habe es angepasst nur, wird bei der Formel K52 nur der Wert K50 berücksichtigt nicht die Summe von den Werten die es dürften
    gruss stephan
     
    ferries, 26. Januar 2023
    #14
  15. Ich konnte nach langem probieren, das letzte Problem auch anhand einer neuen Hilfsspalte lösen
    danke euch allen
    Gruß Stephan
     
    ferries, 27. Januar 2023
    #15
Thema:

SVERWEIS angepasste Formeln

Die Seite wird geladen...
  1. SVERWEIS angepasste Formeln - Similar Threads - SVERWEIS angepasste Formeln

  2. SVERWEIS mit Zahlen und Texten

    in Microsoft Excel Hilfe
    SVERWEIS mit Zahlen und Texten: Liebes Forum, ich verzweifle mit Excel. Ich arbeite mit großen Excel Files für meine Frühbestellung. Dabei liegen mir verschiedene Artikelnummern vor, leider auch welche, die eine führende 0...
  3. WECHSELN & SVERWEIS gemeinsam nutzen (oder Alternative?)

    in Microsoft Excel Hilfe
    WECHSELN & SVERWEIS gemeinsam nutzen (oder Alternative?): Ich bräuchte bitte einmal Euer Schwarmwissen. Ich habe Zellen, deren Inhalt ich in Teilen ändern mag. Das Problem dabei, dass die Liste ziemlich lang wird, eine Verschachtelung der WECHSELN Formel...
  4. SVerweis auch mit farbig formatierten Inhalten?

    in Microsoft Excel Hilfe
    SVerweis auch mit farbig formatierten Inhalten?: Ich möchte per Dropdown Feld jeweils die komplette Zeile der angehängten Tabelle einfügen. Dabei soll nicht nur der Inhalt (hier jeweils das "X") übernommen werden sondern auch die farbliche...
  5. SVerweis / komme nicht klar...

    in Microsoft Excel Hilfe
    SVerweis / komme nicht klar...: Hallo zusammen, ich versuche einen "kombinierten" SVERWEIS über mehrere Tabellenblätter zu erstellen und komme nicht weiter. Ich habe insgesamt drei Tabellenblätter und im letzten Tabellenblatt...
  6. Sverweis nach links

    in Microsoft Excel Hilfe
    Sverweis nach links: Hallo. Ich möchte mittels SVerweis nach einem Wert suchen und dann von der gefundenen Zelle den Eintrag links davon ausgegeben haben. Der Wert steht dann immer in der Spalte "C" und der gleichen...
  7. Sverweis mit gleichen Suchkriterien

    in Microsoft Excel Hilfe
    Sverweis mit gleichen Suchkriterien: Hallo liebe Leute, ich habe folgendes Problem: [ATTACH] In Spalte A ist eine Materialnummer und in Spalte B der Lagerort dazu. In Spalte B sind nicht alle Lagerorte gepflegt . Das hat bestimmte...
  8. SVerweis mit mehreren Bedingungen

    in Microsoft Excel Hilfe
    SVerweis mit mehreren Bedingungen: Hallo, ich habe folgende Formel, leider kommt da immer #Wert heraus {=WENN([@qm]="";SVERWEIS([@Bezeichnung]&[@Format];WAHL({1.2};Preise!A:A&Preise!B:B;Preise!C:C;2;FALSCH);"DEPP"))} -> Depp ist...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden