Office: sVerweis Blattübergreifend verwenden

Helfe beim Thema sVerweis Blattübergreifend verwenden in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo Leute, ich habe eine Formel die wie folgt ausschaut: =SVERWEIS(Hersteller_Aus&Modell_Aus;WAHL({1.2};AMX!B2:B500&AMX!C2:C500;AMX!D2:D500);2;0)... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von igor123, 28. Dezember 2020.

  1. sVerweis Blattübergreifend verwenden


    Hallo Leute,

    ich habe eine Formel die wie folgt ausschaut:

    =SVERWEIS(Hersteller_Aus&Modell_Aus;WAHL({1.2};AMX!B2:B500&AMX!C2:C500;AMX!D2:D500);2;0)

    D.h.:
    Er sucht den Wert, welcher in der Zelle "Hersteller_Aus" steht in der Tabelle AMX!B2:B500 und den Wert der in "Modell_Aus" in der Tabelle AMX!C2:C500 und gibt mir den daneben stehenden Wert, welcher in der Tabelle AMX!D2:D500 steht aus - soweit funktioniert das alles super.

    Nun habe ich jedoch sehr viele Blätter welche in unter einem Dropdown stehen habe (in dem Fall im Dropdown "Hersteller_Aus"

    Gibt es irgendwie die Möglichkeit anstatt "AMX!B2:B500" einzugeben, dass er immer statt "AMX" den Namen nimmt welcher in der Zelle "Hersteller_Aus" gewählt wurde?

    dementsprechend würde er dann automatisch die formel immer anpassen

    Danke euch schonmal!

    LG
     
  2. steve1da Super-Moderator
    Hola,

    =SVERWEIS(Hersteller_Aus&Modell_Aus;WAHL({1.2};indirekt(D2&"!B2:B500")&indirekt(D2&"!C2:C500");indirekt(D2&"!D2:D500"));2;0)

    ich habe geraten dass der Blattname in Zelle D2 steht.

    Gruß,
    steve1da
     
    steve1da, 28. Dezember 2020
    #2
  3. So einfach aber doch kommt man nicht selbst drauf - Danke, funktioniert genau wie gewünscht
    LG
    Igor
     
Thema:

sVerweis Blattübergreifend verwenden

Die Seite wird geladen...
  1. sVerweis Blattübergreifend verwenden - Similar Threads - sVerweis Blattübergreifend verwenden

  2. Kundennummer in Sverweis Zelle fortlaufend einfügen und drucken (VBA)

    in Microsoft Excel Hilfe
    Kundennummer in Sverweis Zelle fortlaufend einfügen und drucken (VBA): Hallo und danke schon mal, ich benötige eure Hilfe. Ich habe eine Excel Liste mit der ich Kunden anlege. Mithilfe einer zugeordneten Kundennummer wird mit einem Sverweis ein Dokument ausgefüllt,...
  3. Formel datedif mit sverweis

    in Microsoft Excel Hilfe
    Formel datedif mit sverweis: Hallo zusammen, ich habe ein Problem. Und zwar habe ich eine Excel Datei, in der ich mit der Formel Datedif das Betriebsjahr ausrechne, in dem eine Reparatur angefallen ist. Die Formel Datedif...
  4. Ein Suchkriterium mit mehreren Ergebnissen

    in Microsoft Excel Hilfe
    Ein Suchkriterium mit mehreren Ergebnissen: Hallo zusammen, ich habe leider nach studenlanger Recherche keine vernünftige Lösung gefunden, deshalb hoffe ich ihr könnt mir weiterhelfen. Mein Problem ist folgendes: Im Tabellenblatt 'Lager...
  5. Sverweis & Wahl

    in Microsoft Excel Hilfe
    Sverweis & Wahl: Hallo Zusammen Könnte mir bitte jemand helfen? Ich drehe fast durch :) Ich habe ein File hochgeladen. Ich möchte ganz einfach, dass die Werte unter "O2 und 03" in der Tabelle gesucht werden und...
  6. Daten mit sVerweis oder xverweis raussuchen

    in Microsoft Excel Hilfe
    Daten mit sVerweis oder xverweis raussuchen: Hallo zusammen, Ich bin mir nicht sicher ob mein Problem mit sverweis oder xverweis gelöst werden kann, aber ich denke das es eine der Funktionen ist. Zu meinem Problem: Ich habe mehrere...
  7. Wenn oder Sverweis

    in Microsoft Excel Hilfe
    Wenn oder Sverweis: Habe in meiner Dropdownliste (D2) verschiedene Namen „DG. Links, EG links_2, 1.OG links“ Wenn ich z.B. „DG links“ aufrufe, öffnet sich mein Tabellenblatt „Druckvorlage Mieter“, in dieses...
  8. Min Wert ohne Null bei Sverweis

    in Microsoft Excel Hilfe
    Min Wert ohne Null bei Sverweis: Hallo, ich wollte den kleinsten Wert aus zwei Sverweis ziehen, was zumindest beim größten Problemlos klappt, nicht aber wenn einer der beiden Werte Null ergibt Wie kann ich das Problem lösen?...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden