Office: Tabelle mit Kostenstellen soll in einer Zeile die entsprechende Niederlassung als Text ausgeben

Helfe beim Thema Tabelle mit Kostenstellen soll in einer Zeile die entsprechende Niederlassung als Text ausgeben in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo, habe folgendes Problem. In einer Tabelle mit Name der Niederlassung, Kennzeichen des Fahrzeugs und der dazugehörenden Kostenstelle soll nach... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von Werner211, 5. Januar 2022.

  1. Werner211 Neuer User

    Tabelle mit Kostenstellen soll in einer Zeile die entsprechende Niederlassung als Text ausgeben


    Hallo,
    habe folgendes Problem. In einer Tabelle mit Name der Niederlassung, Kennzeichen des Fahrzeugs und der dazugehörenden Kostenstelle soll nach Änderung der Kostenstelle sich in der ersten Zeile die Niederlassung automatisch ändern.
    Dabei besteht die Kostenstelle in den ersten vier Ziffern aus der Kennung der NL und die restlichen sind die letzten Ziffern des Kennzeichens.
    Was ich versucht habe ist: 2. Tabellenblatt "Daten" eingefügt dort eine Matrix erstellt mit den Kennungen der Niederlassungen in der ersten Spalte und den Namen der NL in der zweiten Spalte. Auf dem Berechnungsblatt eine Hilfsspalte eingefügt mit der Formel "TEIL(C2;1;4)" Gibt daraufhin die ersten 4 Stellen der Kostenstelle richtig aus. Als nächstes habe ich in der ersten Spalte diese Formel eingefügt: "=SVERWEIS(E2;Daten!A1:B4;2;0)" Und da hängts dann, anstatt da der Wert aus der Matrix ausgegeben wird steht da "#NV"
    Hat da jemand eine Lösung? Eine Beispiel Tabelle füge ich bei, die Originale wäre etwas umfangreich die hat doppelt so viele Spalten und ca 540 Zeilen.
    Schön wenn ihr mir helfen könntet. Im Voraus schon mal besten Dank.
    Gruß Werner
     
    Werner211, 5. Januar 2022
    #1
  2. DL_
    DL_ hat Ahnung
    Moin Werner

    Zwei Fehler.
    Das Ergebnis der Funktion TEIL() ist Text. Deine Werte im Blatt Daten sind aber Zahlen. Das sind für den SVERWEIS() verschiedene Werte.
    Ändere die Formel:
    Code:
    =TEIL(C2;1;4)*1
    Im SVERWEIS() verwendest du für die Matrix einen relativen Bezug. Damit ändert sich die Matrix in jeder Zeile.
    Ändere die Matrix auf einen absoluten Bezug:
    Code:
    =SVERWEIS(E2;Daten!A$1:B$4;2;0)
     
  3. Werner211 Neuer User
    Super, funktioniert einwandfrei, vielen Dank DL_, das erspart mir in Zukunft eine Menge Tipperei.Tabelle mit Kostenstellen soll in einer Zeile die entsprechende Niederlassung als Text ausgeben *:)*Tabelle mit Kostenstellen soll in einer Zeile die entsprechende Niederlassung als Text ausgeben *:)*
     
    Werner211, 5. Januar 2022
    #3
Thema:

Tabelle mit Kostenstellen soll in einer Zeile die entsprechende Niederlassung als Text ausgeben

Die Seite wird geladen...
  1. Tabelle mit Kostenstellen soll in einer Zeile die entsprechende Niederlassung als Text ausgeben - Similar Threads - Tabelle Kostenstellen Zeile

  2. Werte aus mehrere Zellen in einer Anzeigen lassen über mehrere Tabellenblätter

    in Microsoft Excel Hilfe
    Werte aus mehrere Zellen in einer Anzeigen lassen über mehrere Tabellenblätter: Hallo zusammen, ich habe eine Frage bezüglich Excel. Gibt es eine Formel die mir ermöglicht mehrere Werte in einer Zelle auszugeben? Ich habe eine Datei, mit mehrere Tabellenblätter (in der...
  3. Hilfe

    in Microsoft Excel Hilfe
    Hilfe: Liebe Alle, ich bin ganz neu in diesem Forum und bräuchte Hilfe zu einem Excel Projekt. Ich möchte (siehe Bild 1) das die Felder die dort ausgefüllt werden automatisch in Bild 2 übertragen in...
  4. Tabelle in Word, Zelle ausfüllen mit: wenn-dann

    in Microsoft Word Hilfe
    Tabelle in Word, Zelle ausfüllen mit: wenn-dann: Hallo zusammen in einer Tabelle in Word möchte ich folgendes machen. Wenn in der Zelle links von der Zelle (wo ich die Formel einfügen möchte) "xy" steht, dann soll in der Zelle "ab" eingetragen...
  5. Zwei identische Tabellen, verschiedene Sortierung

    in Microsoft Excel Hilfe
    Zwei identische Tabellen, verschiedene Sortierung: Hallo, vorab, ich kenne nur die einfachsten Funktionen und meine Formelkenntnis beschränkt sich auf einfache Rechnungen. Ich habe eine Tabelle mit Bestellungen, welche nach dem Namen der...
  6. Word Tabelle Text in Spalte vertikal statt horizontal

    in Microsoft Word Hilfe
    Word Tabelle Text in Spalte vertikal statt horizontal: Beim Erstellen einer Tabelle in Word schreibt sich der Text einiger Spalten vertikal und ich schaffe es nicht, es zu veraendern....bei den ersten zwei Spalten schaffe ich es, die Ueberschriften...
  7. Provision berechnen

    in Microsoft Excel Hilfe
    Provision berechnen: Hallo Ich brauche bitte eure Hilfe. Ich habe in einer Tabelle meine ganzen Kunden mit deren verschiedenen Provisions-Sätze hinterlegt. Auf einer weiteren Tabelle habe ich die Monatlichen...
  8. Webabfrage (Tabelle) mit Login und Filter möglich?

    in Microsoft Excel Hilfe
    Webabfrage (Tabelle) mit Login und Filter möglich?: Hallo liebe Profis, ich habe eine grundlegende Frage. Ist es möglich, eine Tabelle, die im Internet ist (über Microsoft Login erreichbar), in Excel einzubinden? Die Tabelle hat eine...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden