Office: (Office 2019) Teilergebnis bei Summenprodukt aufgrund Filter

Helfe beim Thema Teilergebnis bei Summenprodukt aufgrund Filter in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Liebe Community, für eine Planungsdatei habe ich eine Formel hinterlegt, die mir freie Verfügbarkeiten errechnet. Sofern in Spalte A, Zelle XY ein Wert... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von Glückskind_17, 21. April 2022.

  1. Teilergebnis bei Summenprodukt aufgrund Filter


    Liebe Community,
    für eine Planungsdatei habe ich eine Formel hinterlegt, die mir freie Verfügbarkeiten errechnet.
    Sofern in Spalte A, Zelle XY ein Wert hinterlegt ist, ist zu prüfen, ob sowohl die danebenliegende Zelle XY in Spalte B als auch Zelle XY in Spalte C leer sind. Ist dies der Fall, wird gezählt:
    =SUMMENPRODUKT((B19:B21="")*(C19:C21="")*($A$19:$A$21<>""))+SUMMENPRODUKT((B23:B40="")*(C23:C40="")*($A$23:$A$40<>""))

    Nun möchte ich ein Teilergebnis generieren, sodass mir nur die Verfügbarkeiten angezeigt werden, die ich per Filter der Spalte A ausgewählt habe. Mir ist bewusst, dass es mit Teilergebnis funktionieren kann, nur scheitere ich kläglich in der Umsetzung.

    Könnt Ihr mir helfen?
     
    Glückskind_17, 21. April 2022
    #1
  2. DL_
    DL_ hat Ahnung
    Moin

    Bitte keine Beispieldatei hochladen damit man einen sinnvollen Vorschlag machen kann.
     
  3. steve1da Super-Moderator
    Hola,

    ungetestet:
    =SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("A"&ZEILE(19:21)))*(A19:A21<>"")*(B19:B21="")*(C19:C21=""))
    Für den anderen Summanden dann analog.
    Gruß,
    steve1da
     
    steve1da, 21. April 2022
    #3
    1 Person gefällt das.
  4. Teilergebnis bei Summenprodukt aufgrund Filter

    @DL_ Das mache ich das nächste mal, versprochen! *zwinker*
    @steve1da Das war nicht nur schnell, sondern auch perfekt! IT WORKS! Vielen Dank für die Hilfe. Ich lerne jeden Tag dazu. Großartig!
     
    Glückskind_17, 21. April 2022
    #4
Thema:

Teilergebnis bei Summenprodukt aufgrund Filter

Die Seite wird geladen...
  1. Teilergebnis bei Summenprodukt aufgrund Filter - Similar Threads - Teilergebnis Summenprodukt Filter

  2. Teilergebnis Anzahl2 soll Zellen die nur Formel enthält nicht berücksichtien

    in Microsoft Excel Hilfe
    Teilergebnis Anzahl2 soll Zellen die nur Formel enthält nicht berücksichtien: Hallo Zusammen, ich suche schon seit längerem eine Lösung für folgendes Problem mit der Funktion Teilergebnis: In einer Tabellenspalte suche ich zunächst mit Sverweis nach Werten aus einer anderen...
  3. Summe Wenn mit Filter -> Teilergebnis und Summenprodukt

    in Microsoft Excel Hilfe
    Summe Wenn mit Filter -> Teilergebnis und Summenprodukt: Hallo zusammen, ich habe ein Problem mit einer Tabelle und habe es nun einige Stunden nicht geschafft dieses mit Google und ausprobieren zu lösen. Und zwar tragen in einer Tabelle verschiedene...
  4. Division von Teilergebnissen unter einer Bedingung

    in Microsoft Excel Hilfe
    Division von Teilergebnissen unter einer Bedingung: Guten Tag zusammen, ich habe folgende Formel gebaut: TEILERGEBNIS(9;Tabelle4[ABC])/TEILERGEBNIS(2;Tabelle4[ABC]) und möchte nun noch zur Bedingung machen, dass in Spalte A:A eine bestimmte...
  5. Summenprodukt -Teilergebnis

    in Microsoft Excel Hilfe
    Summenprodukt -Teilergebnis: Hallo zusammen, auf der Suche nach einer Lösung bin ich über dieses Forum gestolpert. Habe auch hier gesucht, einige Ansätze gefunden aber dennoch nicht zum gewollten Ergebnis gekommen. Es geht...
  6. Summenprodukt mit Teilergebnis ohne volatile Funktionen möglich?

    in Microsoft Excel Hilfe
    Summenprodukt mit Teilergebnis ohne volatile Funktionen möglich?: Guten Tag Zusammen, ich habe vor einiger Zeit eine Excel Datei für eine Auswertung zusammengebaut, eine vereinfachte Form habe ich angehängt. Im Prinzip gibt es folgende Spalten: [A] Lieferant...
  7. Summenprodukt(Teilergebnis) nur Zellen zählen

    in Microsoft Excel Hilfe
    Summenprodukt(Teilergebnis) nur Zellen zählen: Hallo, ich habe versucht, eine Zählwenn und eine Teilergebnis funktion zusammen zuschmieden, nur leider nicht mit dem durchschlagendem Erfolg, den ich mir eigentlich erhofft hatte. Ich will nur...
  8. Excel 2010: Wie arbeiten Summenprodukt, Teilergebnis und Indirekt zusammen?

    in Microsoft Excel Hilfe
    Excel 2010: Wie arbeiten Summenprodukt, Teilergebnis und Indirekt zusammen?: Hallo Excelnutzer, ich habe ein Problem und hoffe, hier vielleicht jemanden zu finden, der mir hier „Nachhilfe“ gebe kann. Ich versuche erfolglos, in gefilterten Spalten Wahrheitswerte in...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden