Office: (Office 2019) Textspalte mit unterschiedlicher Trennung in mehrere Spalten aufteilen

Helfe beim Thema Textspalte mit unterschiedlicher Trennung in mehrere Spalten aufteilen in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo zusammen, ich möchte mir mehrere Rezepte in einer Excel-Tabelle sortieren. Nun habe ich die Zutatenliste wie folgt vorliegen ( "|" symbolisiert... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von Lil_Loni, 9. Januar 2021.

  1. Lil_Loni Neuer User

    Textspalte mit unterschiedlicher Trennung in mehrere Spalten aufteilen


    Hallo zusammen,

    ich möchte mir mehrere Rezepte in einer Excel-Tabelle sortieren. Nun habe ich die Zutatenliste wie folgt vorliegen ( "|" symbolisiert Spalte):

    |3 Scheiben roher Schinken|
    |1 EL geriebener Käse|
    |1 ml Milch|
    |1 kleine Zwiebel|
    |Salz und Pfeffer|

    Ich würde aber gerne die Mengenangaben und Zutatenarten trennen, also:

    |3 Scheiben| roher Schinken|
    |1 EL| geriebener Käse|
    |1 ml| Milch|
    |1| kleine Zwiebel|
    | | Salz und Pfeffer|

    Die Position an der getrennt werden soll, ist ja leider immer eine andere, da es untersch. Einheiten usw. gibt. Es reicht also leider nicht, immer nach Leerzeichen oder Zahl zu trennen. Daher bin ich überfordert, wie ich das bewerkstelligen kann, ohne alles händisch eintippen zu müssen.

    Ist es möglich, den Text ohne riesigen Aufwand wie beschrieben zu trennen?
    Danke schonmal im Voraus und liebe Grüße :)
     
    Lil_Loni, 9. Januar 2021
    #1
  2. Hajo_Zi
    Hajo_Zi Erfahrener User
    die Frage ist welche Einheiten gib es?

    Textspalte mit unterschiedlicher Trennung in mehrere Spalten aufteilen GrußformelTextspalte mit unterschiedlicher Trennung in mehrere Spalten aufteilen Homepage
     
    Hajo_Zi, 9. Januar 2021
    #2
  3. Lil_Loni Neuer User
    Also zb. 'EL', 'ml', 'g', 'Dose', 'Stück', aber teilweise auch gar keine, wie bei Salz und Pfeffer.
     
    Lil_Loni, 9. Januar 2021
    #3
  4. Hajo_Zi
    Hajo_Zi Erfahrener User

    Textspalte mit unterschiedlicher Trennung in mehrere Spalten aufteilen


    Tabelle1
     ABCDE
    453 Scheiben roher Schinken3 Scheibenroher Schinken Scheiben
    461 EL geriebener Käse1 ELgeriebener Käse EL
    471 ml Milch1 mlMilch ml
    481 kleine Zwiebel1kleine Zwiebel kg
    49Salz und Pfeffer Salz und Pfeffer g
    50    Dose
    51    Stück

    verwendete Formeln
    Zelle Formel Bereich N/A
    B45:B49=WENN(ISTZAHL(LINKS(A45;1)*1);WENN(ISTFEHLER(SUCHEN(E45:E51;A45))=FALSCH;LINKS(A45;SUCHEN(" ";A45;SUCHEN(" ";A45)+1)-1);LINKS(A45;LINKS(A45;SUCHEN(" ";A45))*1)*1);"")  
    C45:C49=WENN(B45="";A45;WENN(ISTTEXT(B45); TEIL(A45;SUCHEN(" ";A45;SUCHEN(" ";A45)+1)+1;255);TEIL(A45;SUCHEN(" ";A45)+1;255)))  
    http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
    http://Hajo-Excel.de/tools.htm
    XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
    Add-In-Version 25.21 einschl. 64 Bit


     
    Hajo_Zi, 9. Januar 2021
    #4
    2 Person(en) gefällt das.
  5. Lil_Loni Neuer User
    Perfekt, lieben Dank!
     
    Lil_Loni, 9. Januar 2021
    #5
Thema:

Textspalte mit unterschiedlicher Trennung in mehrere Spalten aufteilen

Die Seite wird geladen...
  1. Textspalte mit unterschiedlicher Trennung in mehrere Spalten aufteilen - Similar Threads - Textspalte unterschiedlicher Trennung

  2. Ab- und Angleich unterschiedlicher Schreibweisen in zwei Tabellen

    in Microsoft Excel Hilfe
    Ab- und Angleich unterschiedlicher Schreibweisen in zwei Tabellen: Guten Morgen zusammen, ich habe folgendes Problem / folgende Probleme: 1. Ich habe zwei Tabellen mit jeweils etwa 20.000 Zeilen und ca. 5.000 Zeilen. In einer der beiden Tabellen steht eine...
  3. unterschiedliche Anzahl von Zeilen abwechselnd einfärben

    in Microsoft Excel Hilfe
    unterschiedliche Anzahl von Zeilen abwechselnd einfärben: Hallo und guten Tag, ich bin seit heute neu hier und habe eine Excel-Tabelle, in der grds. Zeilen unterschiedlich eingefärbt werden sollen aufgrund der besseren Übersicht. Aber... In meinem Fall...
  4. Unterschiedliche Varianten eines Frontends durch direkte Anpassungen der Datei?

    in Microsoft Access Hilfe
    Unterschiedliche Varianten eines Frontends durch direkte Anpassungen der Datei?: Guten Morgen Zusammen, ich habe eine kurze Frage, um sicherzugehen, dass ich bei der Aufteilung meiner DB und der späteren Pflege/Entwicklung richtig vorgehe: Wenn ich die DB in Front- und...
  5. Anzahl unterschiedlicher Ausprägungen zählen

    in Microsoft Excel Hilfe
    Anzahl unterschiedlicher Ausprägungen zählen: Hallo, ich habe für eine Forschungsarbeit YouTube-Kommentare untersucht und mit Excel ausgewertet. Dabei habe ich auch die Nutznamen der Personen erfasst. Nun würde ich Excel gerne zählen lassen,...
  6. Unterschiedliche Rechte zwischen OTP und External AAD Gäste-Konto

    in Microsoft Teams Hilfe
    Unterschiedliche Rechte zwischen OTP und External AAD Gäste-Konto: Hallo, wir haben zwei Gäste in in unserem Tenant, die beide in einem Teams Team arbeiten. Ein Gast loggt sich mittels OTP-Konto ein (Authentifizierung mit Einmalkennung für B2B-Gastbenutzer –...
  7. Microsoft Teams: eine Datei mit zwei Teams teilen (mit unterschiedlicher Berechtigung)

    in Microsoft Teams Hilfe
    Microsoft Teams: eine Datei mit zwei Teams teilen (mit unterschiedlicher Berechtigung): Hallo Forum, ich möchte eine Datei mit zwei verschiedenen Teams A und B teilen. Dabei sollte die Datei jeweils direkt unter dem Reiter "Dateien" in Microsoft Teams auftauchen. Team A sollte...
  8. Nur gleichte Textspalten summieren

    in Microsoft Excel Hilfe
    Nur gleichte Textspalten summieren: Hallo liebe Community! Ich habe eine Arbeitsmappe in welcher ich in einer Spalte und mehreren Zeilen viele verscheidene Texte habe, die jedoch jeweils mehrfach vorkommen, nun möchte ich wissen...
Schlagworte: