Office: wenn Formel

Helfe beim Thema wenn Formel in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo zusammen, ich habe ein Problem mit einer Wenn Formel Wenn im Total ein Wert erscheint und dieser Tag ist ein Samstag oder Sonntag ein Zuschlag... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von mfkathie, 20. April 2023.

  1. wenn Formel


    Hallo zusammen,
    ich habe ein Problem mit einer Wenn Formel
    Wenn im Total ein Wert erscheint und dieser Tag ist ein Samstag oder Sonntag ein Zuschlag der Stunden ermittelt werden. Zelle u11 und fortlaufend

    Danke für die schnelle Hilfe im voraus
     
    mfkathie, 20. April 2023
    #1
  2. Kalk hat Ahnung
    Hallo,

    lade doch bitte eine Datei hoch, danke.
     
  3. Datei habe ich runtergeladen
     
    mfkathie, 20. April 2023
    #3
  4. wenn Formel

    hochgeladen
    Sorry
     
    mfkathie, 20. April 2023
    #4
  5. steve1da Office Guru
    Hola,
    keine Ahnung was du meinst. Es gibt nur eine Zelle wo Total drin steht, was hat das mit U11 zu tun?
    Und was bezweckst du mit =SUMMENPRODUKT(M42)+SUMMENPRODUKT(Q42)?
    Wo soll ganz konkret was erscheinen/gerechnet werden, wenn was vorliegt?
    Gruß,
    steve1da
     
    steve1da, 20. April 2023
    #5
  6. Hallo Steve 1da,
    In u11 soll die Formel stehen
    (Wenn a11 = SO, dann t11 + 50%; und wenn a11 Feiertag dann + 25%)
    Feiertage stehen in der Spalte V

    Gruß
    Mfkathie
     
    mfkathie, 21. April 2023
    #6
  7. steve1da Office Guru
    =WENN(WOCHENTAG(A11;2)=7;T11*1,5;WENN(ZÄHLENWENN($Y$9:$Y$20;A11);T11*1,25;""))
    Durch die "..." erhältst du in einigen Zellen #WERT weil das TEXT ist. Entweder du änderst die Formel in Spalte T (normalerweise lässt man 0 ausgeben), oder du packst noch WENNFEHLER() um meine Formel.
     
    steve1da, 21. April 2023
    #7
    1 Person gefällt das.
  8. wenn Formel

    Hallo Steve1da,
    Danke für die schnelle Hilfe
    Gruß
    Mfkathie
     
    mfkathie, 21. April 2023
    #8
  9. steve1da Office Guru
    Kurze Frage noch: in U10 steht SA/SO, es soll aber nur auf Sonntag geprüft werden. Ist das so korrekt?
     
    steve1da, 21. April 2023
    #9
  10. Ja nur Sonntag. Muss ich noch verändern
     
    mfkathie, 21. April 2023
    #10
  11. Hallo Steve1da,
    ich habe noch ein Problem und benötige nochmals deine Hilfe.

    • In den Zellen t43(Feiertage) und t44(Sonntage) sollen die Anzahl Tage des lfd. Monats stehen
    • In den Zellen u43(Feiertage) und u44(Sonntage) sollen die Anzahl Stunden aus der Spalte U stehen, wenn Feiertag oder Sonntag.
    Die andere Formel habe ich schon integriert und sie funktioniert!!

    Danke im voraus für die Hilfe

    Gruß
    Mfkathie
     
    mfkathie, 22. April 2023
    #11
  12. neopa C hat Ahnung
    Hallo Mfkathie,

    dies kannst Du z.B. mit folgenden Formeln tun:

    Arbeitsblatt mit dem Namen 'Arbeitszeit Excel'
     TU
    43201:45
    44507:00

    ZelleFormel
    T43=SUMMENPRODUKT(ZÄHLENWENN(X9:X20;A11:A41))
    U43=SUMMENPRODUKT(ZÄHLENWENN(X9:X20;A11:A41)*U11:U41)
    T44=SUMMENPRODUKT((REST(A11:A41;7)=1)*(ZÄHLENWENN(X9:X20;A11:A41)=0))
    U44=SUMMENPRODUKT((REST(A11:A41;7)=1)*(ZÄHLENWENN(X9:X20;A11:A41)=0)*U11:U41)
    Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
    Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
    Damit sind Sonntage als Feiertage und somit auch deren AZ natürlich herausgerechnet, weil dies ansonsten eine doppelte Erfassung wäre. Und wenn Du den 24.12. als "Feiertag" berücksichtigen willst, musst Du ihn in X:Y noch erfassen.
     
    neopa C, 23. April 2023
    #12
  13. wenn Formel

    Hallo Neopa,

    danke für die Formeln

    Hier noch ein kleiner Fehler, wenn der Monat weniger als 31 Tage hat.

    Bitte überprüfen

    Mit freundlichen Grüßen

    Mfkathie
     
    mfkathie, 23. April 2023
    #13
  14. neopa C hat Ahnung
    Hallo Mfkathi,

    die Fehler kannst Du einfach vermeiden, indem Du Deine Formeln in Spalte A korrigierst.
    In Spalte A ersetze die "" jeweils durch eine 0 und weise diesen Zellen das benutzerdefinierte Zahlenformat: TTT * TT.MM.JJ;; (wichtig die abschließenden ";;") zu.
     
    neopa C, 23. April 2023
    #14
  15. Hallo Neopa C,

    danke für die Hilfe.
    Funktioniert alles

    Mit freundlichen Grüßen

    Mfkathie
     
    mfkathie, 23. April 2023
    #15
Thema:

wenn Formel

Die Seite wird geladen...
  1. wenn Formel - Similar Threads - Formel

  2. Formel mit INDEX, MATCH und MAX gibt Fehler #NAME!

    in Microsoft Excel Hilfe
    Formel mit INDEX, MATCH und MAX gibt Fehler #NAME!: Hallo zusammen, ich habe mit Hilfe von Copliot eine Formel gebaut, die 2 Werte aus einer Tabelle 1 in einer Tabelle 2 prüfen soll und wenn die Konstellation vorkommt, soll das größte Wert dieser...
  3. Hilfe gesucht bei Fertigstellung einer Formel

    in Microsoft Excel Hilfe
    Hilfe gesucht bei Fertigstellung einer Formel: Ich habe einen Stundenzettel erstellt und stehe gerade vor einem kleinen Problem mit meiner Excelformel. Es geht um 3 Spalten im Stundenzettel. Ich habe für die automatische Berechnung des...
  4. Hilfe gesucht, Formel bauen, (Wenn,Dann, 3 Bedingungen, 3 Ergebnisse) )

    in Microsoft Excel Hilfe
    Hilfe gesucht, Formel bauen, (Wenn,Dann, 3 Bedingungen, 3 Ergebnisse) ): Moin, ich könnte mal Hilfe beim Formelbauen gebrauchen. Excel ist mir zwar nicht neu, aber Formeln erstellen habe ich fast noch nie gemacht. Ich wollte eigentlich die Tabelle hier anhängen, aber...
  5. automatische Formelanpassung

    in Microsoft Excel Hilfe
    automatische Formelanpassung: Hallo Excel Spezialisten Bin dankbar für eure Hilfe zu folgender Situation: In einem Arbeitsblatt mit Spalte A, beginnend mit A4, habe ich in Spalte C einen Produktionswert auch ab C4. Der Wert...
  6. VBA Code Anpassen "Wert Einfügen statt Formel"

    in Microsoft Excel Hilfe
    VBA Code Anpassen "Wert Einfügen statt Formel": Hallo alle zusammen. Ich benötige bitte Hilfe von einem Experten, da ich mit meinem Code unzufrieden bin und dieser bei größeren Datenmengen respektive Zeilen ziemlich langsam wird. Wie müsste man...
  7. Formel auf andere Zellen unterschiedlicher Größe anwenden

    in Microsoft Excel Hilfe
    Formel auf andere Zellen unterschiedlicher Größe anwenden: Hallo zusammen, ich habe eine Formel gebastelt, die wie angehängt in der Beispiel-Excel zu sehen ist, funktioniert. Kann ich die Formel so vereinfachen, dass ich nicht 3x die angepasste Formel...
  8. Summewenns erkennt text aus der formel nicht

    in Microsoft Excel Hilfe
    Summewenns erkennt text aus der formel nicht: Hallo zusammen, ich habe ein Problem das meine Formel Summewenns nicht den ausgegebenen Text in der Zelle erkennt!! Bekomme das einfach nicht hin. In der Zelle B8:B60 wird der Monat mit einer...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden