Office: Wenn funktion mit oder Bedingung

Helfe beim Thema Wenn funktion mit oder Bedingung in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; hallo, ich habe folgende Formel: =WENN([@Bezeichnung]="";"";WENN([@Bezeichnung]<>"Großkopie... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von ferries, 29. Dezember 2022.

  1. Wenn funktion mit oder Bedingung


    hallo,

    ich habe folgende Formel:
    =WENN([@Bezeichnung]="";"";WENN([@Bezeichnung]<>"Großkopie Wildformat";WENN([@Falten]="J";[@[Einzelpr.]]*[@[Anz.]]*(Preise!$F$3/100)+[@[Einzelpr.]]*[@[Anz.]];H31*I31);WENN([@Falten]="J";[@qm]*[@[Einzelpr.]]*[@[Anz.]]*(Preise!$F$3/100)+[@qm]*[@[Einzelpr.]]*[@[Anz.]];[@qm]*[@[Einzelpr.]]*[@[Anz.]])))

    wenn ich aber diese anpasse mit einer ODER dann geht er den falschen DANN Weg:
    =WENN([@Bezeichnung]="";"";WENN(Oder([@Bezeichnung]<>"Großkopie Wildformat";[@Bezeichnung]<>"Großdruck Wildformat");WENN([@Falten]="J";[@[Einzelpr.]]*[@[Anz.]]*(Preise!$F$3/100)+[@[Einzelpr.]]*[@[Anz.]];H31*I31);WENN([@Falten]="J";[@qm]*[@[Einzelpr.]]*[@[Anz.]]*(Preise!$F$3/100)+[@qm]*[@[Einzelpr.]]*[@[Anz.]];[@qm]*[@[Einzelpr.]]*[@[Anz.]])))

    es geht um die Gesamtpreis Spalte ...

    2. Problem was ich habe wenn ich die Einzelpreisspalte an das neue Kritierum anpasse, geht auch nix Wenn funktion mit oder Bedingung :(

    was mache ich falsch?

    gruss stephan
     
  2. steve1da Office Guru
    Hola,
    und welches ist der Falsche? Und welches wäre der richtige?
    "geht auch nix" ist als Beschreibung unbrauchbar. Beschreibe genau, was wann passieren soll und was genau "nicht geht".
    Gruß,
    steve1da
     
    steve1da, 29. Dezember 2022
    #2
  3. also in der ersten Formel funktioniert alles wie es soll, ich wollte nur die Bedingung Großkopie... mit entweder Großkopie oder Großdruck erweitern

    gruss stephan
     
  4. Wenn funktion mit oder Bedingung

    beim 2. Problem versuche ich den Wert Großdruck ... hinzu zu fügen, komme da nicht weiter
    gruss stephan
     
  5. steve1da Office Guru
    Beide deiner Antworten beantwortet meine Frage oder beschreibt, was du vorhast.
    "komme nicht weiter" ist der gleiche Mist wie "geht nicht", sorry. Was versuchst du zu erweitern?
     
    steve1da, 29. Dezember 2022
    #5
  6. ich möchte das:
    WENN([@Bezeichnung]<>"Großkopie Wildformat";
    mit ODER erweitern, das geprüft wird, <> "Großkopie Wildformat" oder <> "Großdruck Wildformat"

    bei der Spalte Einzelpreis wird festgestellt ist Großkopie Wildformat und das soll auch noch nach Großdruck Wildformat festgestellt werden
    gruss Stephan
     
  7. steve1da Office Guru
    Deine Erweiterung mit ODER ist vom Aufbau her korrekt. Was jetzt das falsche DANN und das richtige DANN ist verschweigst du immer noch.
    Beim Einzelpreis wird entweder ein Sverweis mit 2 Kriterien ausgeführt, entweder mit Bezeichnung&Format oder mit Bezeichnung&Farbe. Von "Großkopie Wildformat" ist dort überhaupt nicht die Rede.
    Eine Spalte "qm" gibt es in einer Tabelle übrigens auch nicht.

    Mir ist das Nachfragen jetzt schon zu lästig. Ich bin raus, viel Erfolg noch.
     
    steve1da, 29. Dezember 2022
    #7
  8. Wenn funktion mit oder Bedingung

    sorry die ist ausgeblendet (Spalte G) ...

    er soll dann das machen :
    [@qm]*[@[Einzelpr.]]*[@[Anz.]]*(Preise!$F$3/100)+[@qm]*[@[Einzelpr.]]*[@[Anz.]];[@qm]*[@[Einzelpr.]]*[@[Anz.]]

    gruss Stephan
     
  9. steve1da Office Guru
    Sorry, "qm" hab ich jetzt auch gefunden.
    Zur aller ersten Formel: du fragst zuerst ab, ob die Bezeichnung ungleich "Großkopie Wildformat" ist, und dann, wenn Falten ="j" ist, soll eine Berechnung ausgeführt werden. Im SONST Teil fragst du noch mal ab, ob Falten ="j" ist, somit wird immer nur die erste Berechnung ausgeführt, niemals die zweite. Du müsstest meiner Meinung nach im SONST Teil auf Falten ="n" abfragen.

    Theoretisch müsste die ganze Tabelle überarbeitet werden, es fehlen Einträge im Dropdown so dass man diese händisch eintragen muss, die Matrixformeln könnten vereinfacht werden. Dazu müsste man aber eine ganz konkrete Beschreibung haben, was wann passieren oder berechnet werden soll.
     
    steve1da, 29. Dezember 2022
    #9
  10. ich hab mal meine Versuche in der angehängten Datei hochgeladen, die letzte Zeile ist mit der alten Formel ohne Oder, die vorletzte mit der Oder

    Das mit der Frage nach dem Falten ist OK, muss ja 2 Berechnungswege gehen, wenn Wildformat und nicht Wildformat

    Gruss Stephan
    P.S. kann gerne mal Teamviewer oder so aufmachen!
     
  11. steve1da Office Guru
    Wie gesagt, das müsste komplett überarbeitet werden, in meinen Augen.
    Aber ohne konkrete Beschreibung ist das mehr Raten.
    Ich persönlich supporte nicht über TeamViewer o.ä.. Vielleicht findet sich ja hier jemand anderes.
     
  12. OK ich versuche es mal zu beschreiben:
    wenn Großdruck/Großkopie Wildformat, dann soll er qm * Einzelpreis * Anzahl berechnen ansonsten Anzahl mal Einzelpreis
    wenn dann noch Falten auf J steht soll er das ganze mit 10 % addieren

    gruss stephan
     
  13. steve1da Office Guru

    Wenn funktion mit oder Bedingung

    Das würde man so abfragen. Schauen, ob das Wort "wildformat" in der Bezeichnung vorkommt, dann qm*anzahl*preis, ansonsten nur anzahl*preis. Das ganze dann mit 1,1 multipliziert, wenn Falten ="j" ist, ansonsten halt mit 1 multiplizieren.
    =WENN(ISTZAHL(SUCHEN("wildformat";Tabelle2[@Bezeichnung]));Tabelle2[@qm]*Tabelle2[@[Einzelpr.]]*Tabelle2[@[Anz.]];Tabelle2[@[Einzelpr.]]*Tabelle2[@[Anz.]])*WENN(Tabelle2[@Falten]="j";1,1;1)
     
  14. Danke habe die Formel jetzt so umgebaut:

    =WENN([@Bezeichnung]="";"";WENN(ISTZAHL(SUCHEN("Wildformat";[@Bezeichnung]));WENN([@Falten]="J";[@qm]*[@[Einzelpr.]]*[@[Anz.]]+[@qm]*[@[Einzelpr.]]*[@[Anz.]]*(Preise!$F$3/100);WENN([@Falten]="J";[@[Einzelpr.]]*[@[Anz.]]*(Preise!$F$3/100)+[@[Einzelpr.]]*[@[Anz.]];[@qm]*[@[Einzelpr.]]*[@[Anz.]]))))

    nur kommt jetzt wenn kein "Wildformat" als Ergebnis "Falsch" in die Zelle

    gruss stephan
     
  15. steve1da Office Guru
    Und warum hast du die Formel umgebaut?
     
Thema:

Wenn funktion mit oder Bedingung

Die Seite wird geladen...
  1. Wenn funktion mit oder Bedingung - Similar Threads - funktion Bedingung

  2. WENNS Funktion mit mehreren Bedingungen

    in Microsoft Excel Hilfe
    WENNS Funktion mit mehreren Bedingungen: Hallo ihr Lieben, ich würde gerne eine bedingte Formatierung erstellen. Wenn ich in der Zelle E3 (steht für Montag) den Buchstaben "x" eintippe, dann soll in der Spalte C jeder Montag grau...
  3. Makro FIND Funktion mit 2 Bedingungen

    in Microsoft Excel Hilfe
    Makro FIND Funktion mit 2 Bedingungen: Hallo zusammen, ich wüsste gerne wie folgende Zeile aussehen müsste wenn ich nach 2 Textstücken suchen möchte. Formula = "=IF(ISERROR(FIND(""+Y"",B19)),"""",""JA"")" Das er quasi JA ausgibt...
  4. Hilfe bei Formel mit wenn-, und-, & oder-Funktionen

    in Microsoft Excel Hilfe
    Hilfe bei Formel mit wenn-, und-, & oder-Funktionen: Hallo, ich bräuchte Hilfe bei einer Formel mit mehreren Bedingungen. Diese sollte wie folgt funktionieren, beispielhaft gezeigt anhand der Zeile 7: Wenn E7 oder F7 oder beide "Long" anzeigen und...
  5. Wenn-Dann Funktion mit mehreren Bedingungen und Texr

    in Microsoft Excel Hilfe
    Wenn-Dann Funktion mit mehreren Bedingungen und Texr: Hallo Zusammen, ich benötige die Hilfe der Excel-Profis, da ich nicht mehr weiterkomme! Und zwar muss ich mit der Wenn-Dann Funktion Kategorien unterscheiden Hier ein ungefähres Beispiel: Ich...
  6. Wenn-Und Funktion mit Sverweis auf eine Pivottabelle

    in Microsoft Excel Hilfe
    Wenn-Und Funktion mit Sverweis auf eine Pivottabelle: Guten Tag, ich verzweifle gerade ein bisschen, da ich folgendes Problem nicht gelöst bekomme: Über ein Auswertungstool werden monatlich aus einem ERP-System folgende drei Pivottabellen...
  7. ODER in Verbindung mit RECHTS in WENN-Bedingungen

    in Microsoft Excel Hilfe
    ODER in Verbindung mit RECHTS in WENN-Bedingungen: Moin zusammen, steh grad auf dem Schlauch. Muss in Spalte A Identnummern auslesen in Abhängigkeit der letzten Ziffer und benutze dazu die folgende Formel: =WENN(RECHTS(A1;1)*1=3;1;0)...
  8. ODER in Verbindung mit RECHTS in WENN-Bedingungen

    in Microsoft Excel Hilfe
    ODER in Verbindung mit RECHTS in WENN-Bedingungen: Moin zusammen, ich steh grad auf dem Schlauch: Muss die Endziffer von Identnummern in Spalte A auslesen und daraufhin weitere Operationen ausführen. Dazu verwende ich dieses Formel:...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden