Office: WENN-Funktion

Helfe beim Thema WENN-Funktion in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo zusammen, ich habe das Problem, dass ich sehr viele WENN-Funktionen ineinander verschachteln muss, aber das geht ja nur mit max. 7. Mit... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von sneer_cat, 1. Juni 2006.

  1. WENN-Funktion


    Hallo zusammen,

    ich habe das Problem, dass ich sehr viele WENN-Funktionen ineinander verschachteln muss, aber das geht ja nur mit max. 7.

    Mit Makros kenn ich mich leider absolut nicht aus. Kann man dieses Problem auch ohne Makros lösen?
    Wenn ja, wie?
    Wenn nein, wie mit Makros?

    Schon mal vielen Dank im Vorraus!
     
    sneer_cat, 1. Juni 2006
    #1
  2. Amakido Erfahrener User
    Hey,

    kannst du uns etwas mehr Informationen über das eigentlich Problem geben, dass du mit den vielen "WENN" behandeln möchtest?


    Gruß Amakido
     
    Amakido, 1. Juni 2006
    #2
  3. Also, ich möcht eine Übersicht über die Einsätze von Praktikanten erstellen. In einer Tabelle gibt man Name, Zeitraum und Abteilung ein und in deiner anderen Tabelle, die die einzelnen Abteilungen und die Zeiträume enthält werden dann die jeweiligen Zeiträume farbig hinterlegt.

    Nun will ich mit den WENN-Funktionen erreichen, dass er die Tabelle mit Name etc. prüft und dann die jeweilige Zelle in der anderen Tabelle markiert. Ich hab jedoch mehr als sieben Einsätze von Praktikanten.

    Hilft das weiter?
     
    sneer_cat, 1. Juni 2006
    #3
  4. Amakido Erfahrener User

    WENN-Funktion

    wird immer nur 1 Praktikand eingetragen? und die Tabelle in der du die Zellen hervorheben möchtest sieht wie ein Stundenplan aus? Dann könntst du evtl mit der bedingten Formatierung ein ganzes Stück weiter kommen. Auch wenn ich jetzt nicht ganz drauf komme warum du so viele "Wenn"-Funktionen benötigst.

    Aber wenns nicht anders geht hier mal ein paar kleine Beispiele:

    für 1 Variable (2 Fälle): 0, 1
    Code:
    =WENN(x=0 ; 0 ; 1 )
    für 2 Variable (4 Fälle): 00, 01, 10, 11
    Code:
    =WENN(x=0;WENN(y=0; 00 ; 01 ) ;WENN(y=0; 10 ; 11 ) 
    für 3 Variable (8 Fälle): 000, 001, 010, 011, 100, 101, 110, 111
    Code:
    =WENN(x=0;WENN(y=0;WENN(z=0; 000 ; 001 );WENN(z=0; 010 ; 011 ));WENN(y=0;WENN(z=0; 100 ; 101 );WENN(z=0; 110 ; 111 )))
    wobei ich mir fast sicher bin das es auch auf eine andere Art und Weise geht.
     
    Amakido, 1. Juni 2006
    #4
  5. john g. Erfahrener User
    Hallo,

    tschuldigung, wenn ich mich einmische, aber mit der bedingten Formatierung geht das in dieser Form nicht.
    Wobei ich den eigentlichen Ablauf des Geforderten nicht ganz nachvollziehen kann!?

    Gruß
    J.
     
    john g., 2. Juni 2006
    #5
  6. Amakido Erfahrener User
    Die bedingte Formatierung und meine WENN-Formel hat auch NICHTS miteinander zu tun ! da hast du was falsch verstanden

    Gruß Amakido
     
    Amakido, 2. Juni 2006
    #6
  7. Einsatz Praktikanten 2006
    Abteilungen Januar Februar März April __Mai
    __________ 1 _2__ 1_ 2__ 1_2_ 1_ 2_ 1_ 2
    KS
    FK RV
    FK WG
    KAF RV
    KAF WG
    ALG
    ZGS PK
    ZGS IK
    ZGS FK
    Co

    Name ____ Monat Zeitraum ___Abteilung
    Praktikant 1 Januar ___ 1 ___ ALG
    Praktikant 1 Januar ___ 1 ___ Co
    Praktikant 1 März ___ 2 ___ KS
    Praktikant 2 April ___1 ___ZGS PK
    Praktikant 2 April ___ 2 ___ ALG
    Praktikant 3 Januar ___ 1 ___ KAF RV
    Praktikant 3 Januar ___ 2 ___ZGS IK

    So sollte das dann am Schulss ungefähr aussehen. Man trägt einfach unten den Praktikant, den Monat, Zeitraum und Abteilung ein und in der oberen Übersicht wird dann der jeweilige Zeitraum farbig markiert (hier nicht ersichtlich). Vielleicht hilft das ein bisschen mein Problem besser zu verstehen.

    Bin gerade dabei deinen Vorschlag auszuprobieren. Hoffentlich klappts!!

    Schon mal vielen Dank Amakido!

    Grüßle sneer_cat
     
    sneer_cat, 3. Juni 2006
    #7
  8. WENN-Funktion

    Also dein Tipp hat leider nicht funktioniert Amakido. Gibt es sonst noch eine Möglichkeit das Problem zu lösen?

    Schon mal vielen Dank!!

    Grüßle sneer_cat
     
    sneer_cat, 12. Juni 2006
    #8
  9. Z-Video Erfahrener User
    Hallo
    Die WENN-Funktion in zwei oder mehr Zellen unterteilen. in der ersten Zelle von innen heraus die ersten z.B. 7 WENN-Funktionen ausführen, dann mit dem Resultat als innerste Variable in der nächsten Zelle mit der nächsten Wenn-Funktionen weiterfahren usw.

    Gruss Erich
     
    Z-Video, 12. Juni 2006
    #9
  10. Hi Erich,

    hab das jetzt mal ausprobiert und das klappt :-D

    Ist zwar eine heiden Arbeit, aber wenigstens hab ich jetzt eine passable Lösung!

    Vielen Dank!!!!

    Gruß Manu
     
    sneer_cat, 15. Juni 2006
    #10
  11. lavi Erfahrener User
    würde das nicht mit SVERWEIS auch gehen?
     
  12. Hi Lavi,

    kann ich dir leider nicht sagen, dafür kenn ich mich zu wenig aus.

    Gruß Manu
     
    sneer_cat, 19. Juni 2006
    #12
Thema:

WENN-Funktion

Die Seite wird geladen...
  1. WENN-Funktion - Similar Threads - Funktion

  2. WENNS Funktion duplizieren / Frachtraten vereinfacht zuordnen

    in Microsoft Excel Hilfe
    WENNS Funktion duplizieren / Frachtraten vereinfacht zuordnen: Liebes Forum, ich stehe vor einer Herausforderung welche ich in einem vereinfachten Beispiel dargestellt habe. In C5 Wende ich die WENNS Funktion an um die verschickte Anzahl von Paletten an...
  3. Oder Funktion im Serienbrief

    in Microsoft Word Hilfe
    Oder Funktion im Serienbrief: Hallo, ich habe einen Serienbrief welcher mit einer Excel Datei verknüpft ist. Bei einer Sache komme ich aber nicht weiter. Im Brief soll ein Text (entsprechend Mitteilung vom) erscheinen, wenn...
  4. Wenn Funktion

    in Microsoft Excel Hilfe
    Wenn Funktion: Hallo zusammen Ich habe ein Problem mit der Wenn Funktion. und zwar; Ichmöchte in Zeile B2 irgendeinen Monat eingeben und in Zeile B15 soll das darauffolgende Monat angezeigt werden. Ich habe in...
  5. Makro FIND Funktion mit 2 Bedingungen

    in Microsoft Excel Hilfe
    Makro FIND Funktion mit 2 Bedingungen: Hallo zusammen, ich wüsste gerne wie folgende Zeile aussehen müsste wenn ich nach 2 Textstücken suchen möchte. Formula = "=IF(ISERROR(FIND(""+Y"",B19)),"""",""JA"")" Das er quasi JA ausgibt...
  6. Hyperlink bezieht sich auf falsche Zelle trotz richtiger Funktion?

    in Microsoft Excel Hilfe
    Hyperlink bezieht sich auf falsche Zelle trotz richtiger Funktion?: Hallo zusammen Ich hab ein xls File und 2 Sheets: Sheet 1 = Übersicht Sheet 2 = Mieten In Sheet 1 gibt es die Spalte "Kennzeichen", diese Kennzeichen möchte ich aus Sheet 2 "Mieten" beziehen...
  7. WENNS-FUNKTION ZUTEILUNG SPEDITEURE

    in Microsoft Excel Hilfe
    WENNS-FUNKTION ZUTEILUNG SPEDITEURE: Hallo Liebe Leute, ich stehe aktuell noch zuletzt vor folgender Aufgabe. Es geht darum pro Lieferdatum die Summe der Packstuecke einem bestimmten Spediteur zuzuteilen gemäß folgender Kriterien....
  8. Summe Wenn Funktion ?

    in Microsoft Excel Hilfe
    Summe Wenn Funktion ?: Liebes Forum, ich habe folgendes Problem und hoffe ihr koennt mir hierbei helfen. Ausgangslage wie folgt: Es gibt mehrere Kunden in dem selben Postleitzahlgebiet In diesem Beispiel hatten diese...

Users found this page by searching for:

  1. Wenn-funktion office support

    ,
  2. Wennfunktion wenn KS dann zelle 4 ansonster 5

  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden