Office: Wertzuweisung in Abhängigkeit von Menge und Preis

Helfe beim Thema Wertzuweisung in Abhängigkeit von Menge und Preis in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo, ich hab folgendes Problem und hoffentlich könnt ihr mir dabei helfen. Ich möchte dass Excel in der Tabelle mir den Verkaufspreis in... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von Dankes87, 14. Juli 2022.

  1. Dankes87 Neuer User

    Wertzuweisung in Abhängigkeit von Menge und Preis


    Hallo,

    ich hab folgendes Problem und hoffentlich könnt ihr mir dabei helfen.

    Ich möchte dass Excel in der Tabelle mir den Verkaufspreis in Abhängigkeit von Menge und Einkaufspreis ausgibt. Bei dem Beispiel in der Tabelle ist der Einkaufspreis 0,011€ und jetzt brauch ich den Verkaufspreis für 5 Stk. und dieser soll in der Grün gefärbten Zelle(n) ausgegeben werden. Da sich der Einkaufspreis ja ständig ändert müsste dann bei einer Einkaufspreiserhöhung, z.B. auf 0,012€ eben die Werte von Zelle M3 bis M30 ausgegeben werden.

    Gibt es für das Problem eine Lösung?

    Herzlichen Dank für eure Bemühungen.
     
    Dankes87, 14. Juli 2022
    #1
  2. DL_
    DL_ hat Ahnung
    Moin

    Code:
    =INDEX($B$3:$S$30;XVERGLEICH(AA3;$A$3:$A$30;1;2);XVERGLEICH($V$4;$B$2:$S$2;0;2))
     
  3. {Boris} Neuer User
    Hi,

    ergänzend zu DL_: Die Angaben in W3:AA3 müssen ZAHLEN sein - also 1 bis 5. Kann man ja per benutzerdefiniertem Zellformat 0" Stck." als Stück darstellen.
    Alternativ geht das dann auch mit dem SVERWEIS:

    W4:
    =SVERWEIS(W3;$A3:$S30;VERGLEICH($V4;$A2:$S2;);)
    und nach rechts kopieren.
     
    {Boris}, 18. Juli 2022
    #3
  4. Dankes87 Neuer User

    Wertzuweisung in Abhängigkeit von Menge und Preis

    Hallo nochmals,

    herzlichen Dank DL_ und Boris für die schnelle Antwort, funktioniert sehr gut, mit einer Einschränkung.

    Wenn die EK-Preise nicht exakt dem Wert entsprechen dann funktioniert es nicht.

    In meiner Tabelle werden z.B. ab einen Ek-Preis von 50€ nur 1€ Schritte dargestellt, also die nächste Spalte enthält dann die Vk-Preise für 51€. (siehe Tabelle).
    Kann man diese Problem auch noch lösen, wenn ein Ek-Preis eines Artikels z.B. bei 50,49€ liegt und dieser EK-Preis dann den entsprechenden Vk-Preisen zugewiesen werden? Also in diesem Fall wird mathematisch abgerundet, also entspricht dass dann der Spalte Ek-Preis 50€.

    Vielen Dank.
     
  5. DL_
    DL_ hat Ahnung
    Schau dir Optionen von XVERGLEICH() an.
     
  6. Exl121150 Erfahrener User
    Hallo,

    zB. Formel in AB4:
    =INDEX( $B$3:$W$30; XVERGLEICH(AB3;$A$3:$A$30;1;2); XVERGLEICH($AA$4;$B$2:$W$2; -1;2) )
    Wertzuweisung in Abhängigkeit von Menge und Preis upload_2022-8-7_8-34-14.png
    Die erste rote 1 bewirkt, dass statt der (nicht in der Tabelle enthaltenen) Menge 26 die in der Tabelle enthaltene Mengenstufe 30 genommen wird (also Tabelle mit bis-Mengenstufen)
    Die zweite rote -1 bewirkt, dass statt des (nicht in der Tabelle enthaltenen) EK-Preises 50,490 die in der Tabelle enthaltene EK-Preisstufe 50,000 genommen wird (also Tabelle mit ab-EK-Preisstufen)
     
Thema:

Wertzuweisung in Abhängigkeit von Menge und Preis

Die Seite wird geladen...
  1. Wertzuweisung in Abhängigkeit von Menge und Preis - Similar Threads - Wertzuweisung Abhängigkeit Menge

  2. Farbliche Markierungen mit Abhängigkeit einer anderen Zelle

    in Microsoft Excel Hilfe
    Farbliche Markierungen mit Abhängigkeit einer anderen Zelle: Hallo zusammen, ich soll aus einer Exel Liste einmal alle Besuche eines Kollegen, welche vor Februar eingespielt wurden (Spalte C) und noch nicht beuscht wurden, rot werden lassen in Spalte G....
  3. Farbbalken B1 abhängig von A1

    in Microsoft Excel Hilfe
    Farbbalken B1 abhängig von A1: Hallo, ich möchte Farbbalken, die abhängig von der benachbarten Zelle ist. Also A1=10 B1=1 B1 bekommt einen 10% Farbbalken - Idealerweise auch eingefärbt <30% Rot <60% Gelb >60% Grün Es geht...
  4. Zelle mit Datumsangabe in Abhängigkeit von benachbarter Zelle einfärben

    in Microsoft Excel Hilfe
    Zelle mit Datumsangabe in Abhängigkeit von benachbarter Zelle einfärben: Hallo, ich muss in Excel eine Zelle (gewünschter Liefertermin) so formatieren, dass Sie rot eingefärbt wird, wenn das Datum = Heute ist, soweit kein Problem mit bedingter Formatierung. Sie soll...
  5. Mittelwert, abhängig von 2 bestimmten Werten einer Spalte

    in Microsoft Excel Hilfe
    Mittelwert, abhängig von 2 bestimmten Werten einer Spalte: Hallo zusammen, ich muss leider mal wieder feststellen, dass Excelformeln scheinbar nicht meine Stärke sind, daher habe ich eine Frage an Euch und hoffe Ihr könnt helfen. ;-) Ich versuche...
  6. Berechnung abhängig von unterschiedlichen Inventurdaten je Standort

    in Microsoft Excel Hilfe
    Berechnung abhängig von unterschiedlichen Inventurdaten je Standort: Ich habe für meinen Arbeitgeber eine Lager- und Bestandsführungstabelle pro Kalenderjahr erstellt, mit der wir Ein- und Ausgänge von persönlicher Schutzausrüstung dokumentieren, die bei uns auf...
  7. Funktion in Excel-VBA nutzen

    in Microsoft Excel Hilfe
    Funktion in Excel-VBA nutzen: Hallo, ich habe einige Zeit nichts mehr mit der VBA-Programmierung gemacht. Da scheint sich einiges geändert zu haben. Ich dachte mir, ein allgemeiner Funktionsaufruf funktioniert immer noch...
  8. Wertzuweisung von Formeln mit Variablen (erledigt)

    in Microsoft Excel Hilfe
    Wertzuweisung von Formeln mit Variablen (erledigt): Ich hab mit folgendem Code Probleme Sub formula_autofill() ' Sheets("PCB Area Estimation").Cells(10, 2) = "=WENN((A10="");"";SUMMENPRODUKT(N(' &Aktueller_Pfad "[" &Aktuelle_Datei...
Schlagworte:
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden