Office: Zählenwenn Monat als Text in Datum

Helfe beim Thema Zählenwenn Monat als Text in Datum in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo zusammen, ich möchte in einer anderen Mappe in einer bestimmten Spalte, in der Datumswerte eingetragen sind (TT.MM.JJ), über "Zählenwenn" die... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von Hotte-Berlin, 29. Juli 2012.

  1. Hotte-Berlin Erfahrener User

    Zählenwenn Monat als Text in Datum


    Hallo zusammen,

    ich möchte in einer anderen Mappe in einer bestimmten Spalte, in der Datumswerte eingetragen sind (TT.MM.JJ), über "Zählenwenn" die Anzahl der Einträge aus einem bestimmten Monat ermitteln.
    Dazu hatte ich folgende Formel, die aber nicht das gewünschte Ergebnis ermittelt:
    =ZÄHLENWENN([dateiname]blattname!$F5:$F1000;TEIL(TEXT([dateiname]blattname!$F5:$F1000;"TT.MM.JJ");3;4)=".07.")

    Es sollte also die Anzahl der Datumseinträge des Monats Juli gezählt werden.

    Andere Ideen? (Nein, in der zu durchsuchenden Datei kann das Datum niccht als Text hinterlegt werden. Und dateiname/blattname haben natürlich existierende Realwerte)

    Danke und Gruß
    Hotte-Berlin
     
    Hotte-Berlin, 29. Juli 2012
    #1
  2. schatzi Super-Moderator
    Hallo!

    ungetestet:

    =SUMMENPRODUKT(N(MONAT([dateiname]blattname!$F5:$F1000)=7))
     
    schatzi, 29. Juli 2012
    #2
  3. Hotte-Berlin Erfahrener User
    Hey! Kompliment! Eine kleine Erklärung über die Funktionsweise (will ja nicht gar so dumm sterben ;-)
    Danke!
     
    Hotte-Berlin, 29. Juli 2012
    #3
  4. schatzi Super-Moderator

    Zählenwenn Monat als Text in Datum

    Hallo!

    MONAT(Zelle)=7
    ergibt WAHR oder FALSCH, je nachdem, ob Juli oder nicht.

    Die Funktion N wandelt WAHR und FALSCH in 1 und 0.

    SUMMENPRODUKT bildet hier einfach die Summe dieser Einsen (und Nullen).
     
    schatzi, 29. Juli 2012
    #4
  5. Hotte-Berlin Erfahrener User
    Hallo Schatzi,

    okay, super habe ich verstanden.

    Gibt es auch die Möglichkeit, statt des Datei- und Blattnamens den Inhalt einer Zelle anzugeben, in der genau diese Angaben stehen (variabel)?

    Oder müsste ich jetzt eine neues Thema erstellen?

    Danke und Gruß
    Hotte
     
    Hotte-Berlin, 29. Juli 2012
    #5
  6. schatzi Super-Moderator
    Hallo!

    Theoretisch geht das mit der Funktion INDIREKT, aber dazu muss die Datei, auf die du dich beziehst, ZWINGEND geöffnet sein.

    ABC
    11 A1:A99
    22
    33 6
    4
    ZelleFormel
    C3=SUMME(INDIREKT(C1))
     
    Zuletzt von einem Moderator bearbeitet: 30. November 2020
    schatzi, 29. Juli 2012
    #6
  7. Hotte-Berlin Erfahrener User
    okay, danke (hatte ich mir gedacht, die Dateien sollen aber eigentlich nicht alle geöffnet werden)
     
    Hotte-Berlin, 29. Juli 2012
    #7
Thema:

Zählenwenn Monat als Text in Datum

Die Seite wird geladen...
  1. Zählenwenn Monat als Text in Datum - Similar Threads - Zählenwenn Monat Text

  2. Zählenwenn bei Datum mit Uhrzeit

    in Microsoft Excel Hilfe
    Zählenwenn bei Datum mit Uhrzeit: Guten Tag allerseits, ich möchte folgende Funktion=ZÄHLENWENN(E1:E141327;"31.12.19*") anwenden bei einer Reihe mit Zellen folgenden Formats 31.12.2019 23:41:00 doch kriege ich immer Null raus....
  3. Zählenwenn

    in Microsoft Excel Hilfe
    Zählenwenn: Hallo, ich möchte eine Tabelle auswerten. Diese habe ich hier angehangen. Ich möchte, dass das Wort "Urlaub" bei jedem Mitarbeiter gezählt wird. Allerdings nur vom Jahr 2021. Die Tabelle geht...
  4. =ZÄHLENWENNS mit Monat und Jahr

    in Microsoft Excel Hilfe
    =ZÄHLENWENNS mit Monat und Jahr: Hallo zusammen, ich habe eine kleine Tabellendatenbank und möchte diverse Daten aus einer vorgegebenen Tabelle ziehen. Dafür habe ich folgende Formel:...
  5. Zählenwenns (Bestimmte Werte pro Monat Zählen)

    in Microsoft Excel Hilfe
    Zählenwenns (Bestimmte Werte pro Monat Zählen): Hallo zusammen, in einer recht großen Tabelle möchte ich zählen, wie oft ein bestimmter Wert in einem Monat vorgekommen ist. Datumspalte = tt.mm.jjjj Meine Formel bisher:...
  6. Monat Funktion in Zählenwenns Formel

    in Microsoft Excel Hilfe
    Monat Funktion in Zählenwenns Formel: Hallo Forum, ich suche jetzt schon seit Stunden nach einer Lösung, vielleicht kann mir ja die geballte Kraft des Forums helfen. Folgende Formel bringt mich um den Verstand:...
  7. Alternative für ZÄHLENWENN

    in Microsoft Excel Hilfe
    Alternative für ZÄHLENWENN: Guten Morgen, ich habe zwei voneinander getrennte Dateien. In Tabelle A befinden sich die fixen "Stammdaten" von mehreren Artikeln. Dies sind bis zu 4 Zubehörteile, die den Artikeln zugeordnet...
  8. Anzahl unterschiedlicher Ausprägungen zählen

    in Microsoft Excel Hilfe
    Anzahl unterschiedlicher Ausprägungen zählen: Hallo, ich habe für eine Forschungsarbeit YouTube-Kommentare untersucht und mit Excel ausgewertet. Dabei habe ich auch die Nutznamen der Personen erfasst. Nun würde ich Excel gerne zählen lassen,...

Users found this page by searching for:

  1. Wenn Monat als Text wie geht datum