Office: (Office 365) Zählewennfunktion mit Tabellenauswahl aus Liste

Helfe beim Thema Zählewennfunktion mit Tabellenauswahl aus Liste in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo alle zusammen, für eine Art Dashboard möchte ich Daten aus verschiedenen Tabellen zusammenfassen. Diese Tabellen sind alle exakt gleich... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von frzmffl, 10. Februar 2022.

  1. frzmffl Neuer User

    Zählewennfunktion mit Tabellenauswahl aus Liste


    Hallo alle zusammen,

    für eine Art Dashboard möchte ich Daten aus verschiedenen Tabellen zusammenfassen.
    Diese Tabellen sind alle exakt gleich aufgebaut mit unterschiedlichen Werten.
    Folgende Formel wird für den Januar eingesetzt:

    =ZÄHLENWENNS(Tabelle2022[Monat];Januar;Tabelle2022[Grund];"*")

    Ich suche eine Möglichkeit den Tabellennamen aus einer Dropdownliste wie folgt zu übernehmen:
    =ZÄHLENWENNS(A16[Monat];Januar;A16[Grund];"*")

    Aber das jeweilige anzuzeigende Jahr auszuwählen wäre wohl zu einfach gewesen Zählewennfunktion mit Tabellenauswahl aus Liste :(
    Es erscheint die Meldung, das es mit der Formel ein Problem gibt.

    Kennt Ihr vielleicht eine Möglichkeit ohne jedes Jahr ein neues Tabellenblatt
    anfangen zu müssen?

    Danke und Grüße
     
    frzmffl, 10. Februar 2022
    #1
  2. steve1da Super-Moderator
    Hola,
    warum werden die Daten dann auf verschiedene Blätter verteilt? Völliger Unsinn. Alles auf ein Blatt, das Dashboard auf einem zweiten Blatt und du hast solche Probleme nicht.
    Ansonsten musst du zu Indirekt() greifen.
    Gruß,
    steve1da
     
    steve1da, 10. Februar 2022
    #2
  3. frzmffl Neuer User
    Hey steve1da,

    eigentlich hast du Recht. Manchmal ist man in sein Vorgehen so vernarrt das man keine anderen
    Lösungsmöglichkeiten sieht.

    Da ich sowieso zu jedem Fall das genaue Datum hab, habe ich es jetzt mit einem dritten Kriterium wie folgt gelöst:
    =ZÄHLENWENNS(Tabelle2021[Monat];A21;Tabelle2021[Grund];"*";Tabelle2021[Jahr];$A$16)

    Danke
     
    frzmffl, 10. Februar 2022
    #3
Thema:

Zählewennfunktion mit Tabellenauswahl aus Liste

Die Seite wird geladen...
  1. Zählewennfunktion mit Tabellenauswahl aus Liste - Similar Threads - Zählewennfunktion Tabellenauswahl Liste

  2. Zeiterfassung und Überprüfung arbeitszeit erfüllt

    in Microsoft Excel Hilfe
    Zeiterfassung und Überprüfung arbeitszeit erfüllt: Hallo zusammen, ich würde gerne eine auflistung über dropdown-auswahl erstellen, welche überprüft ob die tägliche arbeitszeit erreicht wurde und wenn zutreffend diese eingaben in z.b. zeile...
  3. Dropdown - bei Auswahl bestimmte Texte in Zeilen einfügen

    in Microsoft Excel Hilfe
    Dropdown - bei Auswahl bestimmte Texte in Zeilen einfügen: Hallo zusammen, ich habe da mal ein kleines Problem. Aktuell arbeite ich an einer Exceltabelle wo ich ein Prüfprotokoll erstelle. Die Auswahl der Komponenten habe ich mit Dropdown-Listen...
  4. Anfrage zu einer Anzeige in einer Liste

    in Microsoft Excel Hilfe
    Anfrage zu einer Anzeige in einer Liste: Hallo liebe Community, ich habe folgende Frage und benötige bitte Euer Schwarmwissen. Es geht um Folgendes: Ich möchte für unseren Verein ein Bestellformular für Vereinskleidung entwerfen. Dazu...
  5. VBA dyn. Zellen kopieren und am ende der Liste einfügen

    in Microsoft Excel Hilfe
    VBA dyn. Zellen kopieren und am ende der Liste einfügen: Guten Morgen zusammen, ich hoffe ihr könnt mir helfen, da ich mich zwar mit Excel auskenne aber mit Makros nichts zu tun habe. Ich habe folgendes Problem: Ich möchte einen Zelleneinträge...
  6. Drop Down Indirekt

    in Microsoft Excel Hilfe
    Drop Down Indirekt: Moin, Ich habe eine Drop Down Liste erstellt. In der einen Spalte wähle ich aus der Liste einen Begriff aus. In der Spalte daneben kann ich dann über "INDIRECT" aus den zu dem Begriff gehörenden...
  7. Tabellenauswahl?

    in Microsoft Excel Hilfe
    Tabellenauswahl?: Hallo, ich habe ein Problem. Hoffentlich könnt ihr mir helfen! Ich habe folgende Tabellen Inahlte: A 1-6 B 1-13 C 1-10 Hier die Tabbelle: [IMG] Jetzt habe ich folgende Werte in...
  8. Tabellenauswahl nach Dropdown

    in Microsoft Excel Hilfe
    Tabellenauswahl nach Dropdown: Servus, zuerst großes Kompliment all euch Wissenden...habe hier schon viele großartige Tipps gefunden! Ich bastle grad an einem Kalkulationsschema in der je nach Dropdown- Auswahl eine...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden