Office: Zahlen in Felder filtern

Helfe beim Thema Zahlen in Felder filtern in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo, ich habe eine Tabellen an der bei K23:K37 entweder steht: 8 Lanes oder 10 Athletes oder 3 pits <- die Zahlen sind Bsp. ich will anhand einer... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von ferries, 9. Dezember 2022.

  1. Zahlen in Felder filtern


    Hallo,

    ich habe eine Tabellen an der bei K23:K37 entweder steht:
    8 Lanes oder 10 Athletes oder 3 pits <- die Zahlen sind Bsp.
    ich will anhand einer Formel herausfinden lassen, was als Text steht und dann Anhand einer Formel bestimmte Zeiten berechnen lassen, habe angefangen mit lanes, aber da kommt Falsch als Ergebnis:
    =WENN(K23="*Lanes";AUFRUNDEN(B23/LINKS(K23;1);0)) -> E23
    für eure Hilfe bin ich sehr Dankbar,
    gruss stephan
     
    ferries, 9. Dezember 2022
    #1
  2. steve1da Office Guru
    Hola,
    =wenn(istzahl(suchen("lanes";K23));Aufrunden(.....);wenn(istzahl(suchen("athletes";K23));DANN;wenn(istzahl......
    Gruß,
    steve1da
     
    steve1da, 9. Dezember 2022
    #2
  3. Ich danke dir, funktioniert soweit, nur hab ich was vergessen Zahlen in Felder filtern :( ich werde doch Älter,
    wenn z.b. in A23:A37 im Text Relay steht, soll er =AUFRUNDEN(((B36+C36)/4)/8;0) machen
    sorry
    gruss Stephan
     
    ferries, 9. Dezember 2022
    #3
  4. steve1da Office Guru

    Zahlen in Felder filtern

    Dann kommt das als weitere Wenn-Bedingung halt dazu, wie die anderen auch.
     
    steve1da, 9. Dezember 2022
    #4
  5. wenn ich die Formel:

    =WENN(WENN(SUCHEN("Relay";A36);AUFRUNDEN((B36+C36)/4/LINKS(K36);1));ISTZAHL(SUCHEN("lanes";K36));AUFRUNDEN(B36/LINKS(K36;1);WENN(ISTZAHL(SUCHEN("athletes";K36));AUFRUNDEN(B36/LINKS(K36;2);0);WENN(ISTZAHL(SUCHEN("pits";K36));

    Wenn in Axx Relay steht kommt als Ergebnis Wahr und bei ohne #Wert! anstatts einer Berechnung,
    wo ist mein Denkfehler?

    gruss Stephan
     
    ferries, 9. Dezember 2022
    #5
  6. Bin etwas schlauer, aber auch nicht wirklich:

    =WENN(WENN(ISTTEXT(SUCHEN("Relay";A26));AUFRUNDEN((B26+C26)/4/LINKS(K26);1));ISTZAHL(SUCHEN("lanes";K26));AUFRUNDEN(B26/LINKS(K26;1);WENN(ISTZAHL(SUCHEN("athletes";K26));AUFRUNDEN(B26/LINKS(K26;2);0);WENN(ISTZAHL(SUCHEN("pits";K26));AUFRUNDEN(B26/8;0);0))))

    jetzt wird zwar wieder berechnet, aber bei Relay nicht die Formel verwendet sondern die mit nur "Lanes" und was noch merkwürdig ist, das Aufrunden wird auch nicht mehr gemacht ...

    Zahlen in Felder filtern upload_2022-12-9_12-8-39.png

    Bei der Vorletzten Zeile müsste 9 heraus kommen, keine 17
    gruss Stephan
     
    ferries, 9. Dezember 2022
    #6
  7. steve1da Office Guru
    Habs jetzt nicht getestet, aber von der Syntax her müsste das so lauten:
    =WENN(ISTZAHL(SUCHEN("Relay";A23));AUFRUNDEN((B23+C23)/4/LINKS(K23);1);WENN(ISTZAHL(SUCHEN("lanes";K23));AUFRUNDEN(B23/LINKS(K23;1);WENN(ISTZAHL(SUCHEN("athletes";K23));AUFRUNDEN(B23/LINKS(K23;2);0);WENN(ISTZAHL(SUCHEN("pits";K23));AUFRUNDEN(B23/8;0);0)))))
     
    steve1da, 9. Dezember 2022
    #7
  8. Zahlen in Felder filtern

    Ich danke dir

    sieht besser aus, nur berechnet er nicht wenn unter Kxx Athletes oder pits steht, da kommt nur Falsch als ergebnis Zahlen in Felder filtern :(
    Zahlen in Felder filtern upload_2022-12-9_12-24-55.png

    sorry, .... und aufrunden will er auch nicht, siehe letzte beide Zeilen

    gruss stephan
     
    ferries, 9. Dezember 2022
    #8
  9. OK vor lauter Wald die Bäume nicht gesehen, hab falsche Aufrunden angegeben, nachdem ich den Wert 0 eingegeben hat er gerechnet ....

    =WENN(ISTZAHL(SUCHEN("Relay";$A23));AUFRUNDEN((B23+C23)/4/LINKS($K23);0);WENN(ISTZAHL(SUCHEN("lanes";$K23));AUFRUNDEN(B23/LINKS($K23;1);0);WENN(ISTZAHL(SUCHEN("athletes";$K23));AUFRUNDEN(B23/LINKS($K23;2);0);WENN(ISTZAHL(SUCHEN("pits";$K23));AUFRUNDEN(B23/8;0);0))))

    nur geht das auch etwas einfacher?

    gruss stephan
     
    ferries, 9. Dezember 2022
    #9
  10. steve1da Office Guru
    Zum einen war da noch ein Klammerfehler, zum anderen ist Aufrunden auf eine Stelle halt 8,7. Wenn das 9 sein soll musst du auf 0 Stellen aufrunden.
    =WENN(ISTZAHL(SUCHEN("Relay";A23));AUFRUNDEN((B23+C23)/4/LINKS(K23);0);WENN(ISTZAHL(SUCHEN("lanes";K23));AUFRUNDEN(B23/LINKS(K23;1);0);WENN(ISTZAHL(SUCHEN("athletes";K23));AUFRUNDEN(B23/LINKS(K23;2);0);WENN(ISTZAHL(SUCHEN("pits";K23));AUFRUNDEN(B23/8;0);0))))
     
    steve1da, 9. Dezember 2022
    #10
  11. HKindler
    HKindler hat Ahnung
    Hi,

    nun ja, wenn du deine Spalte K (Facilities) in zwei Spalten (K:L) aufteilst, dann kannst du das ISTZAHL(SUCHEN("irgendwas";K23)) durch ein einfaches L23="irgendwas" ersetzen. Und aus LINKS(K23;2) wird K23. Genauso kannst du aus ISTZAHL(SUCHEN("Relay";A23)) ein LINKS(A23;5)="Relay" machen.
     
    HKindler, 9. Dezember 2022
    #11
Thema:

Zahlen in Felder filtern

Die Seite wird geladen...
  1. Zahlen in Felder filtern - Similar Threads - Zahlen Felder filtern

  2. Kann man die Felder nach der Füllfarbe zählen lassen

    in Microsoft Excel Hilfe
    Kann man die Felder nach der Füllfarbe zählen lassen: Hallo, geht es irgendwie, dass man sich angeben lässt wie viele Felder in einer Zeile blau, rot oder grün gefüllt sind? Die Felder haben nur eine Farbe, keinen Wert. 305920
  3. Ja/Nein-Felder zählen

    in Microsoft Access Hilfe
    Ja/Nein-Felder zählen: Hallo, benötige mal ein wenig Unterstützung bei einer Abfrage. In einer Tabelle „Ergebnisse“ sind folgende Felder: „BteilNr“ (Bauteilnummer), „BHgrp“ (Bauteilhauptgruppe, „BUgrp“...
  4. bestimmte Felder nach Eingabe einer Zahl, in einer bestimmten Zelle, ausfüllen

    in Microsoft Excel Hilfe
    bestimmte Felder nach Eingabe einer Zahl, in einer bestimmten Zelle, ausfüllen: Hallo, ich habe eine Tabelle zur Prüfung von Meldern einer Brandmeldeanlage. Da jede Brandmeldeanlage unterschiedliche Konfigurationen und dadurch andere Anzahl an Meldern in einer Gruppe hat,...
  5. Zählen von befüllten Feldern

    in Microsoft Excel Hilfe
    Zählen von befüllten Feldern: Hallo ich habe folgende Aufgabe : Ich habe eine Tabelle in der ich jeden Tag Daten eintrage also vom 01.01. eines Jahres bis zum 31.12. Nun benötige ich ein Feld in dem ich die Tage zähle an...
  6. Wenn zwei Felder mit Inhalt, nur eines zählen

    in Microsoft Excel Hilfe
    Wenn zwei Felder mit Inhalt, nur eines zählen: Hallo, Ich habe folgenden Aufbau: Spalte B und C. Egal, welcher Wert in den Zeilen der Spalte B und C steht, möchte ich nur gerne filtern, ob in einer Zeile eine oder beide Zellen belegt sind....
  7. Mehrere Bedingungen, Wenn Abfrage, Suchen von Zahlen, Ausgabe in anderes Feld

    in Microsoft Excel Hilfe
    Mehrere Bedingungen, Wenn Abfrage, Suchen von Zahlen, Ausgabe in anderes Feld: Hallo, ich habe folgendes Excelproblem: Ich habe eine Tabelle, die wie folgt aussieht. [ATTACH] Die Werte kommen von einer Gültigkeitsprüfung aus dem 2ten Tabellenblatt. (Danke für die...
  8. Löschen von Buchstabe aus Feld mit Zahl und Buchstabe

    in Microsoft Excel Hilfe
    Löschen von Buchstabe aus Feld mit Zahl und Buchstabe: Moin! Leider konnte ich über suche nichts richtiges finden, da ich nicht genau weiß, wonach ich suchen soll ;-) Also das Problem: Ich möchte aus Microsoft Project einen Bereich mit...
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden