Office: Zelle formatieren

Helfe beim Thema Zelle formatieren in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo Gemeinde, ich möchte eine Zelle, in der eine Zahl steht, folgendermaßen formatieren: Wenn die Zahl kleiner als Null ist, soll die Zelle... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von Michedu, 15. Dezember 2011.

  1. Zelle formatieren


    Hallo Gemeinde,

    ich möchte eine Zelle, in der eine Zahl steht, folgendermaßen formatieren:

    Wenn die Zahl kleiner als Null ist, soll die Zelle frei bleiben und nicht die Ziffer "0" anzeigen. Es geht um ein Notenblatt, bei dem die Ziffer "0" als ausgefüllte Zelle mitgezählt wird (bei Durchschnittsnote); und das verfälscht den Wert der endgültigen Note.

    Vielen Dank für Eure Hilfe

    Michedu
     
  2. Michael
    Michael Administrator
    Hi Michedu,

    das hat nix mit Formatierung zu tun. Ich würde wie folgt vorgehen.

    [TABLE]
    <colgroup><col style="width: 28ptpx"><col width="60pt"><col width="60pt"></colgroup><tbody>[TR="bgcolor: #cacaca"]
    [TD] [/TD]
    [TD]A[/TD]
    [TD]B[/TD]
    [/TR]
    [TR]
    [TD="bgcolor: #cacaca"]1[/TD]
    [TD="align: right"]1[/TD]
    [TD="align: right"]1[/TD]
    [/TR]
    [TR]
    [TD="bgcolor: #cacaca"]2[/TD]
    [TD="align: right"]2[/TD]
    [TD="align: right"]2[/TD]
    [/TR]
    [TR]
    [TD="bgcolor: #cacaca"]3[/TD]
    [TD="align: right"]3[/TD]
    [TD="align: right"]3[/TD]
    [/TR]
    [TR]
    [TD="bgcolor: #cacaca"]4[/TD]
    [TD="align: right"]-2[/TD]
    [TD="align: left"] [/TD]
    [/TR]
    [TR]
    [TD="bgcolor: #cacaca"]5[/TD]
    [TD="align: right"]4[/TD]
    [TD="align: right"]4[/TD]
    [/TR]
    [TR]
    [TD="bgcolor: #cacaca"]6[/TD]
    [TD="align: right"] [/TD]
    [TD="align: right"] [/TD]
    [/TR]
    [TR]
    [TD="bgcolor: #cacaca"]7[/TD]
    [TD="align: right"] [/TD]
    [TD="align: right"]2,5[/TD]
    [/TR]
    </tbody>[/TABLE]

    [TABLE]
    <tbody>[TR="bgcolor: #aaaaaa"]
    [TD]Zelle[/TD]
    [TD]Formel[/TD]
    [/TR]
    [TR]
    [TD]B1[/TD]
    [TD]=WENN(A1<0;"";A1)[/TD]
    [/TR]
    [TR]
    [TD]B2[/TD]
    [TD]=WENN(A2<0;"";A2)[/TD]
    [/TR]
    [TR]
    [TD]B3[/TD]
    [TD]=WENN(A3<0;"";A3)[/TD]
    [/TR]
    [TR]
    [TD]B4[/TD]
    [TD]=WENN(A4<0;"";A4)[/TD]
    [/TR]
    [TR]
    [TD]B5[/TD]
    [TD]=WENN(A5<0;"";A5)[/TD]
    [/TR]
    [TR]
    [TD]B7[/TD]
    [TD]=MITTELWERT(B1:B6)[/TD]
    [/TR]
    </tbody>[/TABLE]


    Viele Grüße
    Michael
     
  3. Zelle darstellen

    Vielen Dank, Michael.
    Bei Dir ist die Zelle leer; so, wie ich es haben möchte. Bei mir zeigt sie, wenn ich deine Formel eingebe, eine "0" an. Außerdem geht es um die gleiche Zelle. Z.B.: wenn A4 kleiner als "0" ist, bleibt A4 frei

    Danke schön für Deinen Vorschlag.

    Gruß Michedu
     
  4. Michael
    Michael Administrator

    Zelle formatieren

    Was Du willst funktioniert nicht. Du kannst nicht in eine Zelle etwas eintragen und dann soll Excel es wieder löschen wenn es kleiner als 0 ist. Das kann Excel nicht. Daher leicht verändertet Vorschlag.

    Meine Formel kann nur dann eine null anzeigen wenn in der Originalzelle 0 steht. Weil Du sagtest kleiner als Null. Wenn Du die Formel änderst auf =WENN(A1<=0;"";A1) dann zeigt er auch bei null eine leere Zelle an.

    Gruß
    Michael
     
  5. silex1
    silex1 Super-Moderator
    Hallo,

    hier mal was, ohne dass die Zelle irgendwie formatiert werden muss:

    1
    2
    3
    0
    4
    2,5
    ZelleFormel
    B6{=MITTELWERT(WENN(B1:B5>0;B1:B5))}
    Achtung, Matrixformel enthalten!Die geschweiften Klammern{} werden nicht eingegeben.Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
    ZelleSchriftartInhalt
    B1Tahoma1
    B2Tahoma2
    B3Tahoma3
    B4Tahoma0
    B5Tahoma4
    Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
     
    Zuletzt von einem Moderator bearbeitet: 30. November 2020
Thema:

Zelle formatieren

Die Seite wird geladen...
  1. Zelle formatieren - Similar Threads - Zelle formatieren

  2. Formatieren von Text in Zellen

    in Microsoft Excel Tutorials
    Formatieren von Text in Zellen: Formatieren von Text in Zellen Excel für Microsoft 365 Excel für Microsoft 365 für Mac Excel für das Web Excel 2019 Excel 2016 Excel 2019 für Mac...
  3. Zelle in abhängigkeit der nachbarzelle formatieren

    in Microsoft Excel Hilfe
    Zelle in abhängigkeit der nachbarzelle formatieren: Hallo, wollte euch fragen ob es möglich ist eine Zelle zu formatieren die von der nachbarzelle abhängig ist. Z.b wenn in der Zelle B1 der Wert eins vorhanden ist soll die Zelle A1 grün formatiert...
  4. CSV Import: Zellen formatieren

    in Microsoft Excel Hilfe
    CSV Import: Zellen formatieren: Hallo zusammen, ich importiere mit der Methode QueryTables.Add in einer Schleife mehrere identisch aufgebaute CSV Dateien in eine Arbeitsmappe. Dabei wird für jede Datei ein neues Tabellenblatt...
  5. Zelle als Zahl formatieren

    in Microsoft Excel Hilfe
    Zelle als Zahl formatieren: Guten Tag allerseits. Ich gebe in Textboxen mit folgendem Code Zahlen in Zellen ein: Code: rngZelle.Offset(0, 3) = TextBox2.Value Das Eintragen klappt auch. Jetzt wollte ich mal wissen, wie...
  6. Bedingte Formatierung oder Zelle Formatieren

    in Microsoft Excel Hilfe
    Bedingte Formatierung oder Zelle Formatieren: Nabend zusammen, stehe gerade ein wenig auf dem Schlauch und bräuchte mal eure Hilfe. Ist es möglich eine Zelle so zu formatieren das nach Eingabe von zb.: 100b der Einzug Linksbündig ist...
  7. Ändern der Hintergrundfarbe einer Zelle bei Auswahl bestimmter anderer Zellen

    in Microsoft Excel Hilfe
    Ändern der Hintergrundfarbe einer Zelle bei Auswahl bestimmter anderer Zellen: Guten Morgen zusammen, mein Name ist Alex und ich habe mich bei euch angemeldet, da ich ein Problem mit Excel nicht gelöst bekomme und mir die bisherigen Beiträge zu dem Thema nicht...
  8. Zelle bei Erreichen des darin befindlichen Datums automatisch formatieren

    in Microsoft Excel Hilfe
    Zelle bei Erreichen des darin befindlichen Datums automatisch formatieren: Hallo Experten, in einer Liste habe ich folgende drei Spalten: 1. Ausstellungsdatum 2. Gültigkeitsdauer (jeweils 6 Monate oder 1 Jahr) 3. daraus resultierendes Ablaufdatum, kalkuliert mit...