Office: Zellen einen "Status" zuweisen

Helfe beim Thema Zellen einen "Status" zuweisen in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo. Ich möchte einer Zelle, die eine Zahl enthält, in Abhängigkeit der Nachbarzelle (Text) einen Status zuweisen. Oder anders gesagt, die Zahl-Zelle... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von erzkanzler, 3. April 2022.

  1. erzkanzler Neuer User

    Zellen einen "Status" zuweisen


    Hallo.
    Ich möchte einer Zelle, die eine Zahl enthält, in Abhängigkeit der Nachbarzelle (Text) einen Status zuweisen. Oder anders gesagt, die Zahl-Zelle soll zu Kategorie 1 oder 2 gehören, basierend auf dem Eintrag im Nachbarfeld.
    Anschließend sollen dann alle Zahlen einer Zeile addiert werden, je einmal pro Kategorie.
    Beispiel mit den Kategorien "u" und "e":

    6 | u | 0 | e | 5 | e |Summe(e)=5 | Summe(u)=6
    0 | u | 0 | u | 4 | e |Summe(e)=4 | Summe(u)=0
    3 | e | 0 | e | 1 | e |Summe(e)=4 | Summe(u)=0
    6 | e | 5 | u | 2 | e |Summe(e)=8 | Summe(u)=5

    Ich danke im Voraus!
     
    erzkanzler, 3. April 2022
    #1
  2. Hajo_Zi
    Hajo_Zi Erfahrener User
    zu welcher Zahl welche Kategorire. Du hast 3 unterschiiedluche Zahlen aber nur 2 Kategorien?
    Ich gehe mal von Spalte A aus.

    Zellen einen "Status" zuweisen GrußformelZellen einen "Status" zuweisen Homepage
     
    Hajo_Zi, 3. April 2022
    #2
  3. Exl121150 Erfahrener User
    Hallo,

    in der beiliegenden Datei habe ich dir eine benutzerdef. VBA-Funktion eingefügt:
    =SUMMEWENNZeile($A1:$F1;"e")
    um alle mit "e" gekennzeichneten Werte im Bereich A1:F1 zu summieren oder
    =SUMMEWENNZeile($A1:$F1;"u")
    um alle mit "u" gekennzeichneten Werte im Bereich A1:F1 zu summieren.

    Die dazu gehörige VBA-Funktion lautet:
    Code:
    Option Explicit
    
    Public Function SUMMEWENNZeile(Bereich As Range, Krit As String) As Variant
       Dim I As Long
       Dim s As Variant
      
       s = 0
       With Bereich
          For I = 1 To .Cells.Count
            If I Mod 2 = 0 Then
              If .Cells(I).Value = Krit Then s = s + .Cells(I - 1).Value
            End If
          Next I
       End With
       SUMMEWENNZeile = s
    End Function
    
    Der zu verwendende Bereich muss einzeilig sein mit einer geradzahligen Anzahl an Zellen.
     
    Exl121150, 3. April 2022
    #3
  4. erzkanzler Neuer User

    Zellen einen "Status" zuweisen

    Es sind sogar noch mehr Zahlen und nur 2 Kategorien. Die Kategorien dienen ja quasi nur der Zuweisung, welche Zahlen addiert werden sollen.


    Danke für die Antwort. VBA hab ich noch nie gemacht, guck ich mir aber an.
    Ohne VBA gehts wohl nicht? :)
     
    erzkanzler, 4. April 2022
    #4
  5. steve1da Super-Moderator
    Hola,
    vielleicht versteh ich's ja auch nur falsch...
    =SUMMEWENN(B1:F1;"e";A1:E1)
    bzw.
    =SUMMEWENN(B1:F1;"u";A1:E1)
     
    steve1da, 4. April 2022
    #5
Thema:

Zellen einen "Status" zuweisen

Die Seite wird geladen...
  1. Zellen einen "Status" zuweisen - Similar Threads - Zellen Status zuweisen

  2. Listenfeld mit Verbundenen Zellen

    in Microsoft Excel Hilfe
    Listenfeld mit Verbundenen Zellen: Hallo Zusammen, habe mir einen Code mit Hilfe aus einem Video geschrieben. Hier soll wenn in eine Zelle in dem Bereich Stoerungen_ eine Listbox auftauchen und den Ausgewählten Störgrund einfügen....
  3. Excel: Farben aus Zellen auslesen

    in Microsoft Excel Hilfe
    Excel: Farben aus Zellen auslesen: Hallo, ich habe die Aufgabe, dass ich aus Artikelnummern jeweils nach der Farbe suchen muss und diese dann in eine neue Zelle auslesen soll. Wie lässt sich das umsetzen? Die Farben stehen oft an...
  4. Duplikate entfernen, Zellen zählen, Werte hinzufügen

    in Microsoft Excel Hilfe
    Duplikate entfernen, Zellen zählen, Werte hinzufügen: Hallo Leute, ich arbeite aktuell noch händisch mit meinen Werten und wollte das ganze per VBA umsetzen. Leider ist das ganze ein bisschen kompliziert. Ich habe mal eine TB angehangen wo ich auf...
  5. Zellen per VBA sperren wenn Datum erreicht

    in Microsoft Excel Hilfe
    Zellen per VBA sperren wenn Datum erreicht: Hallo, ich benötige Hilfe bei einer Erstellung eines VBA Codes (Excel). Ich würde gerne das die Zellen B5:AF33 automatisch gesperrt werden, wenn das Datum in Zelle B1 größer wie in Zelle AO30...
  6. Zelle formatieren wenn wenn bestimmter Wert in Zelle vorhanden

    in Microsoft Excel Hilfe
    Zelle formatieren wenn wenn bestimmter Wert in Zelle vorhanden: Hallo Leute, Ich hab in einer Spalte Zellen wo Werte mit "SW" oder "MN" oder "AN" oder "N" drinnen stehen. und die Zellen wo einer der Werte(Buschstaben) stehen sollen Fett formatiert werden....
  7. Excel Formatierung/Textausgabe bei bestimmten Inhalt in anderer Zelle

    in Microsoft Excel Hilfe
    Excel Formatierung/Textausgabe bei bestimmten Inhalt in anderer Zelle: Hallo Zusammen, hoffe ihr könnt mir helfen. Ich habe zur Veranschaulichung meines Problemes mal ein Screenshot beigefügt. Ich will in der Zeile 1 eine Formel (wenn mgl. Bedingte Formatierung)...
  8. Format aus Zelle in USF übernehmen

    in Microsoft Excel Hilfe
    Format aus Zelle in USF übernehmen: Moin allerseits, in einer Datentabelle habe ich eine Zelle als Zeit formatiert und möchte diesen Wert (dyn.) in einer Userform als Label darstellen. Dort kommt aber immer nur die...
Schlagworte:
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden