Office: (Office 365) Inhalte mehrer Spalten in zwei Spalten (untereinander)

Helfe beim Thema Inhalte mehrer Spalten in zwei Spalten (untereinander) in Microsoft Excel Hilfe um das Problem gemeinsam zu lösen; Hallo, ich habe Daten, die wie in der Tabelle unten formatiert sind. Ich habe ein ähnliches Thema bereits im Forum gefunden: Einziger Unterschied... Dieses Thema im Forum "Microsoft Excel Hilfe" wurde erstellt von Toerser, 20. Januar 2023.

  1. Toerser Neuer User

    Inhalte mehrer Spalten in zwei Spalten (untereinander)


    Hallo,

    ich habe Daten, die wie in der Tabelle unten formatiert sind.

    Ich habe ein ähnliches Thema bereits im Forum gefunden:


    Einziger Unterschied ist, dass ich nicht nur eine Liste aller vorkommenden Themen benötige. Ich benötige zusätzlich noch die Info aus Spalte 1 zu jedem einzelnen Wert aus den weiteren Spalten. (siehe Output-Spalten)

    Input
    Output
    a 1 2
    a 1
    a 3 4
    a 2
    b 5 6
    a 3
    c 7 8
    a 4
    d 9 10
    b 5




    b 6




    c 7




    c 8




    d 9




    d 10


    Gibt es hier eine Möglichkeit das darzustellen? Bestmöglich wäre mit Excel-Formeln, aber auch VBA wäre natürlich eine Lösung.

    Vielen Dank schon im Voraus.

    Grüße Toerser
     
    Toerser, 20. Januar 2023
    #1
  2. Hajo_Zi
    Hajo_Zi Erfahrener User
    Du bist im falschen Forum. Bildbearbeitung ist ein anderes.
    Bilder lade ich mir nicht runter, da Excel damit nichts anfangen kann.

    Hochgeladene Bilder können zwar als solche in Excel importiert werden, sind jedoch bei der Lösung von Problemen nicht sehr hilfreich, da man die eigentlichen Daten nicht ohne große und zeitraubende Umwege direkt in die Tabelle übertragen kann.

    Ich baue keine Datei nach, die Zeit hat schon jemand investiert.

    Bilder statt Datei | Excel ist sexy!
    Eine hochgeladene Arbeitsmappe erhöht die Wahrscheinlichkeit, dass Du eine Lösung für Dein Problem erhältst.
    Erstelle folglich bitte eine Demomappe, aus der deine Aufgabenstellung klar erkennbar ist und lade diese Mappe mit einem aussagekräftigen Dateinamen hoch.
    Der Name einer hochgeladenen Mappe wird im Beitrag automatisch angezeigt, sodass es bei Verwendung von aussagekräftigen Namen leichter fällt, sie später im Ablageordner wiederzufinden und sie gedanklich einem bestimmten Thema zuzuordnen. Namen wie Muster*, Test*, Mappe*, Beispiel*, Fehler*, Kalender*, UserForm*, Forum* usw. sind so allgemein, dass eine Zuordnung zu einem Thema unmöglich gemacht wird.
    Es sollte ein aussagekräftiger Name sein.
    Wenn du an Stelle einer Demomappe deine Originalmappe hochladen willst, diese aber sensible Daten enthält, kannst du diese Daten ändern. Schaue Datei
    http://hajo-excel.de/gepackt/fremd/Datei_verschluesseln.zip
    Bei Download beachte bitte: von unsicheren Servern file-upload lade ich keine Datei herunter (lt. Einschätzung meines Virenprogramms)

    Das ist nur meine Meinung zu dem Thema.

    Inhalte mehrer Spalten in zwei Spalten (untereinander) GrußformelInhalte mehrer Spalten in zwei Spalten (untereinander) Homepage
     
    Hajo_Zi, 20. Januar 2023
    #2
  3. neopa C hat Ahnung
    Hallo Toerser,

    wenn Du die ursprüngliche Listenreihenfolge beibehalten willst, dann z.B. wie nachstehend aufgezeigt. Wenn Du die Zahlenwerte sortiert gelistet haben willst, werden die Formeln etwas anders.

    Z.B. für Daten in A2:C6:
    Formel in E2: =WENN(ZEILE(A1)>ANZAHL(B:C);"";INDEX(A:A;KÜRZEN(ZEILE(A4)/2;)))
    und in F2: =WENN(E2="";"";INDEX(B:C;KÜRZEN(ZEILE(A4)/2;);REST(ZEILE(A4);2)+1))

    und diese nach unten kopieren.
     
    Zuletzt bearbeitet: 20. Januar 2023
    neopa C, 20. Januar 2023
    #3
  4. Hajo_Zi
    Hajo_Zi Erfahrener User

    Inhalte mehrer Spalten in zwei Spalten (untereinander)

    mal die Tabelle richtig dargestellt.

    Arbeitsblatt mit dem Namen 'Tabelle1'
     ABCDEF
    1      
    2a72 a7
    3a34 a2
    4b21 a3
    5c103 a4
    6d98 b2
    7    b1
    8    c10
    9    c3
    10    d9
    11    d8
    12      

    ZelleFormel
    E2=WENN(ZEILE(A1)>ANZAHL(B:C);"";INDEX(A:A;KÜRZEN(ZEILE(A4)/2;)))
    F2=WENN(E2="";"";INDEX(B:C;KÜRZEN(ZEILE(A4)/2;);REST(ZEILE(A4);2)+1))
    Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
    Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
    [ parsehtml ]
    [ /parsehtml ]
    ohne Leerstelle.

     
    Hajo_Zi, 20. Januar 2023
    #4
  5. neopa C hat Ahnung
    Hallo Hajo,

    woran lag es, dass meine Tabelle nur als Code dargestellt war und was hast Du getan diese hier korrekt einzustellen?
     
    neopa C, 20. Januar 2023
    #5
  6. Hajo_Zi
    Hajo_Zi Erfahrener User
    Hallo Werner,

    schaue am Ende meines Beitrag da steht HTML Code und ohne Leerstelen, zwischen beiden.

     
    Hajo_Zi, 20. Januar 2023
    #6
  7. neopa C hat Ahnung
    Hallo Hajo,

    danke. Ich versuche es damit gleich nochmal mit einer erweiterten Tabelle.

    @Toerser,

    nachfolgend hab ich gleich noch meine zusätzliche Formelvariante mit aufgezeigt, wenn die Datenwerte sortiert ausgegeben werden sollen. Allerdings sah ich aber eben noch, dass Du XL365 im Einsatz hat. Da sollten beide Formelvarianten einfacher möglich sein. Ich hab allerdings noch eine ältere XL-Version im Einsatz.

    Arbeitsblatt mit dem Namen 'Tabelle1'
     ABCDEFGHI
    1         
    2a72 a7 b1
    3a38 a2 a2
    4b21 a3 b2
    5c33 a8 a3
    6d98 b2 c3
    7    b1 c3
    8    c3 a7
    9    c3 a8
    10    d9 d8
    11    d8 d9
    12         

    ZelleFormel
    E2=WENN(ZEILE(A1)>ANZAHL(B:C);"";INDEX(A:A;KÜRZEN(ZEILE(A4)/2;)))
    F2=WENN(E2="";"";INDEX(B:C;KÜRZEN(ZEILE(A4)/2;);REST(ZEILE(A4);2)+1))
    H2=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE(B$2:B$99)/(B$2:C$99=I2);ZÄHLENWENN(I$2:I2;I2)))&"";"")
    I2=WENNFEHLER(KKLEINSTE(B:C;ZEILE(A1));"")
    Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
    Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
     
    neopa C, 20. Januar 2023
    #7
  8. lupo1
    lupo1 Tutorial Guru

    Inhalte mehrer Spalten in zwei Spalten (untereinander)

    Zuletzt bearbeitet: 20. Januar 2023
  9. Exl121150 Erfahrener User
    Hallo,

    und jetzt noch eine Version: PowerQuery
    Inhalte mehrer Spalten in zwei Spalten (untereinander) upload_2023-1-20_16-56-33.png
    Mit folgendem Abfragecode, der durch ein paar Tastendrücke erzeugt werden kann:
    Code:
    let
        Quelle = Excel.CurrentWorkbook(){[Name="Tabelle1"]}[Content],
        #"Geänderter Typ" = Table.TransformColumnTypes(Quelle,{{"Bez", type text}, {"Anz1", Int64.Type}, {"Anz2", Int64.Type}}),
        #"Entpivotierte andere Spalten" = Table.UnpivotOtherColumns(#"Geänderter Typ", {"Bez"}, "Attribut", "Wert"),
        #"Entfernte Spalten" = Table.RemoveColumns(#"Entpivotierte andere Spalten",{"Attribut"})
    in
        #"Entfernte Spalten"
    
     
    Exl121150, 20. Januar 2023
    #9
  10. Toerser Neuer User
    Hallo Hajo,

    danke für den Hinweis. Ich weiß ehrlich gesagt nicht was hier schief gelaufen ist. Ich habe nachdem ich die Tabelle gepostet habe, die Tabelle per Copy&Paste nochmal in eine frische Excel getestet und das hat funktioniert . Vielen Dank fürs geradeziehen.

    Grüße Toerser
     
    Toerser, 21. Januar 2023
    #10
  11. Toerser Neuer User
    Hallo neopa,

    vielen Dank, damit konnte ich das Problem in erster Linie schon einmal lösen!

    Grüße Toerser
     
    Toerser, 21. Januar 2023
    #11
  12. Toerser Neuer User
    Hallo lupo1,

    vielen Dank auch für deine Lösung, damit kann ich es noch etwas variabler gestalten, ich habe mich schon gewundert, wie das ganze mit variablen Spalten und/oder leeren Zellen funktioniert.

    Grüße Toerser
     
    Toerser, 21. Januar 2023
    #12
  13. Toerser Neuer User

    Inhalte mehrer Spalten in zwei Spalten (untereinander)

    Hi Anton,

    Wow, ich habe die Power Query schon ein, zwei Mal für einen größeren Daten-Import genutzt, aber noch nie für Daten in Excel selbst. Während ich für die einfachen Problemstellungen eher die Formeln verwenden werde, habe ich ein ähnliches Problem mit einem deutlich größeren Datensatz. Das habe ich gerade mit der Power Query getestet und es hat sofort funktioniert! Das ist wirklich ein Gamechanger für mich! Vielen Dank, dass du mir das näher gebracht hast. :)

    Grüße Toerser
     
    Toerser, 21. Januar 2023
    #13
Thema:

Inhalte mehrer Spalten in zwei Spalten (untereinander)

Die Seite wird geladen...
  1. Inhalte mehrer Spalten in zwei Spalten (untereinander) - Similar Threads - Inhalte mehrer Spalten

  2. Bestimmte Inhalte mehrerer Tabellenblätter auf separatem Blatt darstellen

    in Microsoft Excel Hilfe
    Bestimmte Inhalte mehrerer Tabellenblätter auf separatem Blatt darstellen: Hallo zusammen, in einer Mappe möchte ich die Inhalte in Spalte A der Blätter 1.0 und 1.1 auf dem Blatt 2.0 sammeln. Die Einträge sollen dort untereinander ohne Leerzeilen stehen, wenn der...
  3. Mehrere Zellen auf Inhalt überprüfen

    in Microsoft Excel Hilfe
    Mehrere Zellen auf Inhalt überprüfen: Hallo zusammen, für die Personalplanung in unserer Firma habe ich eine Excelliste angelegt. Wir haben maximal 6 Mitarbeiter, es müssen mindestens 3 da sein. Wenn durch Urlaub oder Krankmeldungen...
  4. Inhalte mehrer Spalten in eine Spalte (untereinander)..?

    in Microsoft Excel Hilfe
    Inhalte mehrer Spalten in eine Spalte (untereinander)..?: Liebes Forum, ich sitze gerade an einem riesigen Datensatz, den ich für eine weiterführende Aufgabe umstrukturieren muss. Das ganze sieht folgendermaßen aus: <table border='1' cellspacing='0'...
  5. Inhalt aus mehreren Spalten/Zeilen zusammenfassen

    in Microsoft Access Hilfe
    Inhalt aus mehreren Spalten/Zeilen zusammenfassen: Hallo, als Ergebnis einer Abfrage erhalte ich 3 Felder/Spalten A, B, Kommentar, z.B.: A I B I Kommentar 4 I 13.9 I dies ist die erste Zeile 4 I 13.9 I danach kommt die 2te Zeile 4 I 13.9 I und...
  6. Zusammenführen eines Inhaltes von mehreren Spalten in eine

    in Microsoft Excel Hilfe
    Zusammenführen eines Inhaltes von mehreren Spalten in eine: Hallöle , nun da ich der absolute Excel Laie bin aber nun mit csv tabellen arbeiten muß hoffe ich hier hilfe zu finden ... Ich möchte die Beschreibeungen aus 3 oder mehreren Spalten alle...
  7. Inhalt aus einer Spalte trennen und in mehrere kopieren

    in Microsoft Excel Hilfe
    Inhalt aus einer Spalte trennen und in mehrere kopieren: hi leute, ich hab da so n problem :D habe ne spalte wie folgt: ['Kundennummer'] 'Firmenname' 'Adresse' ['Kundennummer'] 'Firmenname' 'Adresse' ['Kundennummer'] 'Firmenname' 'Adresse'...
  8. Inhalte mehrerer Zeilen/Spalten miteinander verketten

    in Microsoft Excel Hilfe
    Inhalte mehrerer Zeilen/Spalten miteinander verketten: Hallo! Ich habe zwei Spalten, die ich gerne samt Inhalt zu einer machen würde. Bei einzelnden Zeilen habe ich die Formel C1=A1&B1 angewendet, das klappt, aber da ich ca. 3500 Zeilen habe, daert...
Schlagworte:
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Auf dieser Website werden Cookies für die Zugriffsanalyse und Anzeigenmessung verwendet.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden